Go Back   Tech Support Forum > Gaming Forum > Online/Network Gaming Support

User Tag List

Lag/Latency problems in WoW (1 of 2 PCs)

This is a discussion on Lag/Latency problems in WoW (1 of 2 PCs) within the Online/Network Gaming Support forums, part of the Tech Support Forum category. Recently my girlfriend decided to jump back into WoW, and after having everything set up and jumping in we were


Closed Thread
 
Thread Tools Search this Thread
Old 07-07-2011, 04:16 PM   #1
Registered Member
 
Join Date: Feb 2009
Posts: 6
OS: Windows XP



Recently my girlfriend decided to jump back into WoW, and after having everything set up and jumping in we were met with lag. We shut everything down, updated to the latest video driver and it seemed to have gotten better.

Short after that she gets into Tol Barad (big fight, lots of people for non-WoW players) and she has horrible lag and gets disconnected like 5 times, it would happened at most 30 seconds after logging back on even if there was no fighting around her.

The thing we find very confusing is that we both have identical computers (except for the RAM and PSU brands) and I have absolutely no issues (I average 60 fps and no more than 200ms latency) and she would have 20 fps and 500+ms latency.

If anyone has any idea what this could be, or know the steps to figure out if it is an issue with the PC, the help would be greatly appreciated.

PS: We're both running on Win7 64. Let me know if there's any added info you need.

Thanks in advance.
Jdpr86 is offline  
Sponsored Links
Advertisement
 
Old 07-07-2011, 05:18 PM   #2
Registered Member
 
Join Date: Feb 2009
Posts: 6
OS: Windows XP



Quick update;

I just started noticing lag on my own PC, when I normally don't. I am starting to thing part of this issue is with the game itself, but her issues are far worse than mine. Any help in figuring this out is appreciated.
Jdpr86 is offline  
Old 07-07-2011, 05:25 PM   #3
Registered Member
 
Join Date: Feb 2009
Posts: 6
OS: Windows XP



Well this is really lame...apparently I just started getting the same lag issues. Sorry for the useless thread, since the problem seems to be with the game.
Jdpr86 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
MSI 560 TI Problems with WoW
There's been a graphical issue with my new 560 Ti on Warcraft that is really ticking me off. Everytime I turn my character or my camera, the game gets choppy at that point. This results in lower framerates and for me the game is unplayable. Also, when I am running or flying forward, I can see what...
Zdunmeister Video Card Support 15 04-25-2011 06:52 PM
WoW Problems
Um ok so I am pretty sure I know my password on World of Warcraft but when I type it in it says my name or password is not right. So I do not know what is wrong with it at the moment.
Justin5091 PC Gaming Support 1 04-06-2011 06:42 PM
WoW private server problems
OK, I do have an account and play retail WoW....no problems there I also have other versions of WoW that I use to play on a few private servers. One is only upgraded to Wrath of the Lich King (3.3.5a) and the other is vanilla WoW(1.12.1) I have no problems with the vanilla wow, but when I try to...
WOLFMAN1966 PC Gaming Support 1 04-03-2011 06:37 PM
File and Printer sharing problems
Hi, First time poster :wave: and hoping for some help and advice, if possible. Have a small network of 5xPC Workstations that I am experiencing some problems with. Details as follows: Desktop PC (A) = Windows XP Home, RJ45 Hard-Wired to Netgear Router, USB cable-connected to HP LaserJet
JayBlake Networking Support 6 01-08-2011 07:22 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts