Go Back   Tech Support Forum > Gaming Forum > Online/Network Gaming Support

User Tag List

Bad Company 2 lag spikes

This is a discussion on Bad Company 2 lag spikes within the Online/Network Gaming Support forums, part of the Tech Support Forum category. So i just bought a brand new computer less then a week ago and i installed Battlefield Bad Company 2.


Closed Thread
 
Thread Tools Search this Thread
Old 03-31-2011, 07:04 PM   #1
Registered Member
 
Join Date: Mar 2011
Posts: 4
OS: Windows 7



So i just bought a brand new computer less then a week ago and i installed Battlefield Bad Company 2. Game runs fine for the first 10-15 mins then after that i get huge lag spikes lasting about 5-20. the lag is so bad it pretty much locks up the game. then it returns to normal for a few minutes and then again spikes.

my specs are


Computer:
Operating System Windows 7 Home Premium Home Edition
OS Service Pack -
DirectX 4.09.00.0904 (DirectX 9.0c)
Computer Name USER-HP
User Name User

Motherboard:
CPU Type 2x , 3100 MHz
Motherboard Name Unknown
Motherboard Chipset Unknown
System Memory 4087 MB
BIOS Type Unknown

Display:
Video Adapter ATI Radeon HD 5570
Video Adapter ATI Radeon HD 5570
Monitor Generic PnP Monitor [NoDB] (SPBNAJ0126888)

Multimedia:
Audio Adapter High Definition Audio Controller [NoDB]
Audio Adapter High Definition Audio Controller [NoDB]

Storage:
SCSI/RAID Controller AMD AHCI Compatible RAID Controller
SCSI/RAID Controller AMD RAID Console
Disk Drive Hitachi HDS721010CLA332 SCSI Disk Device (931 GB)
Disk Drive Generic- SD/MMC USB Device
Disk Drive Generic- SM/xD-Picture USB Device
Disk Drive Generic- Compact Flash USB Device
Disk Drive Generic- MS/MS-Pro USB Device
Disk Drive ST350032 0AS USB Device (465 GB, USB)
Optical Drive DTSoftBusCd00
Optical Drive hp DVD RW AD-7251H5 SCSI CdRom Device
SMART Hard Disks Status Unknown

Partitions:
C: (NTFS) 939810 MB (875075 MB free)
D: (NTFS) 13760 MB (1694 MB free)
K: (NTFS) 476937 MB (337338 MB free)
Total Size 1397.0 GB (1185.7 GB free)

Input:
Keyboard HID Keyboard Device
Mouse HID-compliant mouse

Network:
Network Adapter 802.11n Wireless LAN Card
Network Adapter Realtek PCIe GBE Family Controller (192.168.0.21)

Peripherals:
Printer Fax
Printer Microsoft XPS Document Writer
USB1 Controller Standard OpenHCD USB Host Controller [NoDB]
USB1 Controller Standard OpenHCD USB Host Controller [NoDB]
USB1 Controller Standard OpenHCD USB Host Controller [NoDB]
USB1 Controller Standard OpenHCD USB Host Controller [NoDB]
USB1 Controller Standard OpenHCD USB Host Controller [NoDB]
USB2 Controller Standard Enhanced PCI to USB Host Controller [NoDB]
USB2 Controller Standard Enhanced PCI to USB Host Controller [NoDB]
USB Device USB Composite Device
USB Device USB Input Device
USB Device USB Input Device
USB Device USB Mass Storage Device
USB Device USB Mass Storage Device

it has a 400w power supply as well.

ping goes from 100 up to 400-800 in a split second. i tried wireless, thought that was the problem so i went hard wired and no change.
Shrubmite is offline  
Sponsored Links
Advertisement
 
Old 04-01-2011, 09:02 PM   #2
Registered Member
 
Join Date: Mar 2011
Posts: 4
OS: Windows 7



ok i starting to think this is not a network issue. i started to guess that maybe its an overheating issue. while playing, it lag 3 times and shut down. i downloaded speedfan to take a look at temps.

idle is about 38-45 c on average. when playing it spikes to 55 ish. but the wierd thing is that is only on one core. the other two (triple core) seem good.

any suggestions?
Shrubmite is offline  
Old 04-01-2011, 09:28 PM   #3
TSF Enthusiast
 
Join Date: Jan 2011
Posts: 720
OS: Windows 7

My System


First off, 400 watts is low for that setup, you should at least be at 550 w. This could be causing the lag spikes as the PSU is not able to provide stable power to the video card. What is the brand and model of the psu? Either way, you should upgrade: Newegg.com - CORSAIR CMPSU-550VX 550W ATX12V V2.2 SLI Ready CrossFire Ready 80 PLUS Certified Active PFC Compatible with Core i7 Power Supply

I realize it's out of stock, you don't have to get it from newegg. it's doesn't get much better than Corsair when it comes to PSUs


Secondly, I've seen some benchmarks for this video card, it doesn't seem to perform too well with modern games on high settings. See if toning down the settings and/or resolution helps anything.

CPU temps look ok, what about the GPU? Check those with GPU-Z.
Markgg88 is offline  
Sponsored Links
Advertisement
 
Old 04-02-2011, 10:34 AM   #4
Registered Member
 
Join Date: Mar 2011
Posts: 4
OS: Windows 7



so i am pretty sure its just overtemp issues. i took off the side case and its all good now. might have to invest in some cooling. i think the power supply is large enough...i looked into what i needed before i bought. i use about 350-360 w so i have a 40-50 w buffer which is pretty good.
Shrubmite is offline  
Old 04-03-2011, 09:07 AM   #5
TSF Enthusiast
 
Join Date: Jan 2011
Posts: 720
OS: Windows 7

My System


Even if it's just a heat issue, I still think you need a better PSU. Have a look at this article here:https://www.techsupportforum.com/foru...on-192217.html

Read the whole thing, you'll see where I'm coming from. It's your decision in the end though.
Markgg88 is offline  
Old 04-03-2011, 11:37 AM   #6
Registered Member
 
Join Date: Mar 2011
Posts: 4
OS: Windows 7



link doesnt work
Shrubmite is offline  
Old 04-03-2011, 02:23 PM   #7
TSF Enthusiast
 
Join Date: Jan 2011
Posts: 720
OS: Windows 7

My System


That's odd, it works for me. How about now? If it still doesn't work, just navigate to the Ram and Power Supply support section on this site, you'll find it on a stickied thread.

https://www.techsupportforum.com/forums/f210/power-supply-information-and-selection-192217.html
Markgg88 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Random Internet Lag Spikes
Hello, I have been getting random lag spikes for quite a long time, and it is really annoying. Here's the problem: I am playing a game, like Battlefield Bad Company 2. Every 5-15 minutes, I get 3 lag spikes. When I get the lag spikes, everyone who is using my internet, also gets it the same time...
awesomealvin Networking Support 11 08-11-2012 12:21 AM
GTA IV (Lag spikes)
Hey, After buying the game 2 days ago from the local shop and finaly got to install it it appears that the lag spikes are unbearable for my nerves atleast. It's basically constant lag spikes all the time, It doesn't matter that do I just drive around or run... Specs: AMD Phenom X4...
yiebaza PC Gaming Support 2 03-18-2011 04:52 PM
Random lag spikes plz help
I've been experiencing random lag spikes for the past few months now. At first it only started with high demanding games then little demanding games were having the same problems and now the bubbles as my screen saver is having random lag spikes. With games this occurs for 5 mins then it goes off...
Wars_Hero Windows 7 , Windows Vista Support 5 02-21-2011 11:48 AM
Random lag spikes plz help
I've been experiencing random lag spikes for the past few months now. At first it only started with high demanding games then little demanding games were having the same problems and now the bubbles as my screen saver is having random lag spikes. With games this occurs for 5 mins then it goes off...
Wars_Hero BSOD, App Crashes And Hangs 3 02-20-2011 08:50 AM
Battlefield: Bad Company 2 causes BSOD.
Okay, so just lately I've been experiencing some issues with Bad Company 2, after about 30-60 Minutes of Gameplay, the game freezes and the sound is set on a very fast loop which creates this kind of "buzzing" sound. The BSOD itself fails to show up, but it says I had a BSOD when I've rebooted...
Dealman BSOD, App Crashes And Hangs 1 01-19-2011 01:22 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 03:29 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts