Go Back   Tech Support Forum > Microsoft Support > Windows 7 , Windows Vista Support

User Tag List

Error 1721 - There is a problem with this Windows Installer package [Java]

This is a discussion on Error 1721 - There is a problem with this Windows Installer package [Java] within the Windows 7 , Windows Vista Support forums, part of the Tech Support Forum category. Hello! I've been trying to install Java for quite some time, but everytime I try to do so, when the


Closed Thread
 
Thread Tools Search this Thread
Old 06-28-2012, 04:04 PM   #1
Registered Member
 
Join Date: Apr 2012
Location: Portugal
Posts: 3
OS: Windows Vista Home Premium SP2 32-bit


Mistake

Hello! I've been trying to install Java for quite some time, but everytime I try to do so, when the installation is near the end, the following error always pops up:

Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.

I have no clue what to do.
Help please?
Marceline is offline  
Sponsored Links
Advertisement
 
Old 06-28-2012, 05:01 PM   #2
TSF Enthusiast
 
Join Date: Dec 2011
Location: North East England
Posts: 5,919
OS: Win 7 Home Premium SP1 64bit



Here are a couple of links to download the Windows Installer which should fix your broken one.

The first is for Vista SP1 and the second says it's for a 32bit version, they're the only links I could find, but have a read through them first before you choose (if any) to install.

Download Windows Installer 4.5 Windows Drivers - Software Patch.

Microsoft Windows Installer - Download
Tomken15 is offline  
Old 06-28-2012, 05:23 PM   #3
TSF Enthusiast
 
Join Date: Dec 2011
Location: North East England
Posts: 5,919
OS: Win 7 Home Premium SP1 64bit



Found this MS link which should be more reliable Windows Installer 4.5 is available
Tomken15 is offline  
Sponsored Links
Advertisement
 
Old 07-20-2012, 03:18 PM   #4
Registered Member
 
Join Date: Apr 2012
Location: Portugal
Posts: 3
OS: Windows Vista Home Premium SP2 32-bit



Hello! Thank you for your help.
I checked the last link you sent me and after reading through it, I saw that it only contains the Windows Installer for SP1, and not for SP2.
Is there a Vista SP2 version of the Windows Installer Service that I can download and install? Or do you know any other way of fixing this?

Thank you and sorry for my bad english.
Marceline is offline  
Old 08-02-2012, 08:19 AM   #5
Registered Member
 
Join Date: Apr 2012
Location: Portugal
Posts: 3
OS: Windows Vista Home Premium SP2 32-bit



.....
Marceline is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows XP PC unable to access internet or copy files
Hi - I have a Dell slimline PC running Windows XP that is slowly losing all functionality. I cannot load IE, Chrome has a message ERR 138 (Access Denied). I am unable to copy files from a USB stick and cannot remove certain programs (er McAfee) using the Add / Remove program utility. :facepalm: ...
NDWales Virus/Trojan/Spyware Help 54 07-15-2012 03:19 PM
IE7 cannot connect with secure sites
Hi...my problem with IE7 may well be part of a bigger problem. However at the moment every time I try to connect with microsoft.com or other M/soft sites I get the message "Internet Explorer cannot display the web page". The same applies with any site resembling anti virus s/ware or other...
raringer Internet Explorer & Edge Forum 6 05-21-2012 11:27 AM
"System Fix" virus hijacked computer
Hello, I’ve got a computer infected with the “System Fix” Virus. I believe the OS is Windows XP Professional. Searching the Tech Support Forum lead me to this thread: https://www.techsupportforum.com/forums/f50/im-in-trouble-614906.html Since that thread is getting quite long, I figured...
SilentJim Resolved HJT Threads 48 12-02-2011 08:10 AM
3TB HDD won't format
I recently bought a 3TB 5400RPM hard drive and placed it in an enclosure. I orginially had connected it to my PC via USB 2.0 and formatted the entire drive and everything seemed to be in working order. After that I decided to connect the drive via eSATA because of the speed increase. When...
UhOhOhNo Hard Drive Support 8 09-13-2011 08:22 PM
After closing previous thread my problems continue
Hi there. After lots of great help from CatByte all the memory I had lost was returned and it looked like my problems were solved. However I've noticed that the memory I got back has been going down at the same rate as before (see link to thread below). It also takes a long time to shut down with...
Oberjeen Resolved HJT Threads 7 03-19-2011 03:48 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 12:26 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts