Go Back   Tech Support Forum > Hardware Support > RAM and Power Supply Support

User Tag List

Getting A New PSU

This is a discussion on Getting A New PSU within the RAM and Power Supply Support forums, part of the Tech Support Forum category. Hi all. I'm replacing my power supply (my old one, an ultra x4 850w, is dying after only a year


Closed Thread
 
Thread Tools Search this Thread
Old 11-02-2011, 07:18 PM   #1
Registered Member
 
Join Date: Sep 2011
Posts: 55
OS: windows 7



Hi all. I'm replacing my power supply (my old one, an ultra x4 850w, is dying after only a year) and looking for advice. I'm looking at a Corsair 1050HX Professional Modular 1050w. My system specs are:

CPU:i5-750 @2.66 ghz
Motherboard:EVGA p55sli
GFX: 2 EVGA GTS 450s (1gb) in sli
RAM: 8gb Corsair XMS3 @ 1333mhz
Hard Drive: Western Digital Caviar Blue 500gb
Audio: Microsoft Life Chat LX-3000
OS:Windows7 Home Premium 64bit

Is the 1050HX a good unit? Any other suggestions?
wildblue is offline  
Sponsored Links
Advertisement
 
Old 11-03-2011, 05:10 AM   #2
Emeritus
 
Join Date: May 2009
Location: Illinois
Posts: 51,675
OS: XP Pro-7



Anything made by SeaSonic (SeaSonic-XFX-Corsair) is top quality.



Tyree is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Typical lifespan of PSU?
Hi, what is the typical lifespan of a PSU ? I'm currently running my system with a six year old Nexus NX-4090 400watt psu. I was running it earlier with 3 years old Delta 300W psu (I know the minium requirement for 5670 is 400watts), which has been working perfectly fine. It is still working,...
Jooo RAM and Power Supply Support 7 10-31-2011 06:48 AM
New PSU won't POST; old PSU works
I'm trying to upgrade a 250W Bestec PSU with OCZ 600W SXS. The motherboard takes 20-pin without -5V pin. Bestec PSU has no -5V pin, and the system runs fine. I put in OCZ PSU, and fans (CPU, PSU and case) run, there is power to CD-ROM and hard drive, but motherboard won't POST -- no video signal...
flybone RAM and Power Supply Support 6 01-27-2011 05:31 AM
Desktop fried, bought new PSU, won't start. Help??
I'm kinda stuck here - my homemade rig is kaput and need help getting it started again. Original problem was that after moving it and hooking it up again I would hit the power switch and get absolutely no response. Opening the case I saw the mobo LED solid-on. If I hit the rocker switch on the...
korbitz Motherboards, Bios|UEFI & CPU 1 01-08-2011 02:03 PM
Power Supply Information and Selection
:smile: CHOOSING AND UNDERSTANDING A POWER SUPPLY UNIT The power supply unit in today’s modern computer assumes a role probably more critical than any other single component in your system even when compared to the CPU and motherboard. Therefore, there are multiple factors that must...
Tumbleweed36 RAM and Power Supply Support 0 07-09-2006 03:41 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 04:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts