Go Back   Tech Support Forum > Hardware Support > RAM and Power Supply Support

User Tag List

Adaptor for CPU Connection

This is a discussion on Adaptor for CPU Connection within the RAM and Power Supply Support forums, part of the Tech Support Forum category. I currently have a Corsair TX650W power supply. I just bought a MSI X470 Pro Carbon Motherboard and it requires


Closed Thread
 
Thread Tools Search this Thread
Old 07-29-2019, 02:11 PM   #1
Registered Member
 
Join Date: Aug 2009
Location: Florida
Posts: 77
OS: Win 7 64bit



I currently have a Corsair TX650W power supply. I just bought a MSI X470 Pro Carbon Motherboard and it requires two 8 Pin CPU Power connections but the PSU I'm using only has 1. Are there any adaptors to make molex connectors into CPU power connectors or any other way to make my current PSU work with the MSI MB? This is the model number of my current PSU is CMPSU-650TX.

Thanks
bnporter is offline  
Sponsored Links
Advertisement
 
Old 07-29-2019, 02:26 PM   #2
Registered Member
 
Join Date: Aug 2009
Location: Florida
Posts: 77
OS: Win 7 64bit



The PSU I mentioned in my original post is one that I've had before Corsair sold. Its one of the old school PSUs. I'll be running a MSI RX590 GPU also in this build
bnporter is offline  
Old 07-29-2019, 02:39 PM   #3
Administrator
Team Manager, Gaming
Team Manager, Microsoft Support
Team Manager, Hardware Team
Microsoft MVP
 
Wrench97's Avatar

Microsoft Most Valuable Professional
 
Join Date: May 2008
Location: S.E. Pennsylvania
Posts: 54,013
OS: Win7



What CPU are you planing to use, I doubt you'll need the 4 pin connected if you are not running one of the 105w CPU's overclocked> https://www.msi.com/Motherboard/supp...RO#support-cpu
Wrench97 is offline  
Sponsored Links
Advertisement
 
Old 07-29-2019, 04:20 PM   #4
Registered Member
 
Join Date: Aug 2009
Location: Florida
Posts: 77
OS: Win 7 64bit



I'm installing 2700x cpu
bnporter is offline  
Old 07-29-2019, 04:22 PM   #5
Registered Member
 
Join Date: Aug 2009
Location: Florida
Posts: 77
OS: Win 7 64bit



Wrench97,

My mistake. Its the MSI X470 Pro Carbon MB.
bnporter is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 07:42 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts