Go Back   Tech Support Forum > Design Forum > Web Serving and Management

User Tag List

XAMPP and Wordpress - "Object not found"

This is a discussion on XAMPP and Wordpress - "Object not found" within the Web Serving and Management forums, part of the Tech Support Forum category. I am using XAMPP and wordpress to develop a website locally. I just recently purchased a new laptop. I have


Closed Thread
 
Thread Tools Search this Thread
Old 03-24-2012, 12:22 PM   #1
Registered Member
 
Join Date: Mar 2012
Posts: 3
OS: Windows 7



I am using XAMPP and wordpress to develop a website locally. I just recently purchased a new laptop. I have moved my 'wordpress' folder and export/imported my database from my old PC to my new PC. On my new PC the home page opens fine with all of the images, the html content, and the correct css. However, when I try to access any of the other pages or create a new page in wordpress I continue receiving a "Object not found" error message.

Yet this problem only occurs for the site and database that I have transferred over. For example, when I create a new database and and link wordpress to it via my wp-config.php file, I can create new wordpress pages with no problems.

I am not sure why I am experiencing this problem. Any help or incite would be greatly appreciated!

Cheers,
Nico Lauria
Nico88 is offline  
Sponsored Links
Advertisement
 
Old 03-26-2012, 07:43 AM   #2
Manager
- Alternative Computing
- Design
 
wmorri's Avatar
 
Join Date: May 2008
Location: New York
Posts: 6,492
OS: Window 7/Ubuntu/Fedora/Backtrack 5

My System

Send a message via AIM to wmorri Send a message via MSN to wmorri

Hi,

Welcome to TSF!!

Not sure if you have looked at the Moving WordPress site yet. If not then have a look at the section moving to another server. It will give you the process that they recommend. If you are still having problems after that we can work on the issues as they come.
__________________


Linux Forever!|html5 boilerplate
wmorri is offline  
Old 05-14-2012, 06:40 PM   #3
Registered Member
 
Join Date: Mar 2012
Posts: 3
OS: Windows 7



Hello Wmorri,

Thank you for your response. It has been a while since my original post and I managed to solve the problem simply by clearing my browser's cache.

However, now I have run into a similar problem. I am attempting to import a wordpress site that I have been working on locally onto another machine. I have copied the wp-content folder into my htdocs/wordpress directory. I have also imported the correct database file as well as modified the wp-config file to match my new database.

The homepage loads alright, except for my image slider. However when I try to load any of the other pages I get a "Object not found!" error.

I have looked at my apache/logs/error file which states that the files do not exist. They do however...
Any help with this matter would be greatly appreciated. The following is my apache/logs/error text file in case that helps.

Cheers,
Nico

[Mon May 14 18:37:10 2012] [error] [client ::1] File does not exist: C:/xampp/htdocs/wordpress/home, referer: https://localhost/wordpress/
[Mon May 14 18:38:03 2012] [error] [client ::1] File does not exist: C:/xampp/htdocs/wordpress/wp-content/plugins/content-slide/js, referer: https://localhost/wordpress/
[Mon May 14 18:38:03 2012] [error] [client ::1] File does not exist: C:/xampp/htdocs/wordpress/wp-content/plugins/thethe-image-slider/style/js, referer: https://localhost/wordpress/
[Mon May 14 18:38:03 2012] [error] [client ::1] File does not exist: C:/xampp/htdocs/wordpress/wp-content/plugins/content-slide/js, referer: https://localhost/wordpress/
[Mon May 14 18:38:03 2012] [error] [client ::1] File does not exist: C:/xampp/htdocs/wordpress/wp-content/plugins/thethe-image-slider/style/js, referer: https://localhost/wordpress/
[Mon May 14 18:38:03 2012] [error] [client ::1] File does not exist: C:/xampp/htdocs/wordpress/wp-content/themes/web_creations/Images/footer-top.png, referer: https://localhost/wordpress/wp-conten...ions/style.css
[Mon May 14 18:38:05 2012] [error] [client ::1] File does not exist: C:/xampp/htdocs/wordpress/home, referer: https://localhost/wordpress/
Nico88 is offline  
Sponsored Links
Advertisement
 
Old 05-14-2012, 07:08 PM   #4
Registered Member
 
Join Date: Mar 2012
Posts: 3
OS: Windows 7



Hello again,

I just wanted to post that I have solved the problem. The solution was quite easy... and only took me forever to figure out.

Hopefully I can save someone else the stress. If you are experiencing a problem similar to mine, where after transferring your wordpress site locally your inner pages do not load and display a "object not found" error, it most likely has to do with your Permalinks structure.

Go to your dashboard, to settings, and to Permalinks. Restore the permalinks structure to its original state and update. After doing this you should be able to restore it any other state that you like without experiencing problems.

Hope that helps someone!

Cheers,
Nico
Nico88 is offline  
Old 07-20-2015, 05:09 PM   #5
Registered Member
 
Join Date: Jul 2015
Posts: 1
OS: Windows 7



Yep, that did it. Permalinks just needed to be resaved.

Thanks
dw_n_cinti is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I apply and animation to a video which plays automatically in Powerpoint 2007?
I have a video which I want to play automatically on top of a slide in PowerPoint 2007, I want this video to fade out (revealing the slide) after the video has played. The way I was going to do it was to add a custom animation to the video object, and selecting a fade effect with a 7 second...
kkid106 Microsoft Office support 4 04-01-2012 04:18 AM
Rootkit Virus and lost internet connection
My wife's laptop had a Google redirect problem, when I was investigating I found a Rootkit Virus also. I started following some directions in another thread and inadvertantly lost my internet connection. My internet and router work, because I'm using them with other laptop. I was told to take...
AMB1101 Resolved HJT Threads 37 03-27-2012 07:39 PM
broken sword 3 demo works, game not
at first i couldnt install any version: not the downloadable demo from the internet and not full game that i own on DVD(2discs) when updated the nvidia driver to the newest, the demo works just fine but still not the full game, i cant even install it...no matter from disc or by copying...
x45641 PC Gaming Support 0 03-24-2012 11:23 AM
Lost internet connection and have a Rootkit Virus
My wife's laptop had a Google redirect problem, when I was investigating I found a Rootkit Virus also. I started following some directions in another thread and inadvertantly lost my internet connection. My internet and router work, because I'm using them with other laptop. My thought was get...
AMB1101 Networking Support 1 03-24-2012 09:55 AM
sp3 and amd processors
I have a Presario V6000 with AMD Turion 64 Processor. I am using XP w/sp2. When sp3 came out I installed it and lost everything on my computer. I had warranty on it so HP was able to talk me through a rebooting and reinstall of xp. I have been using xp since 2009 without sp3 but keeping up with...
LPL Windows XP Support 2 03-24-2012 09:31 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 07:27 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts