Go Back   Tech Support Forum > Hardware Support > Hard Drive Support

User Tag List

Weird slow transfer on drive?

This is a discussion on Weird slow transfer on drive? within the Hard Drive Support forums, part of the Tech Support Forum category. I've got a 3TB internal drive that I bought and connected internally in my PC using SATA. I've noticed it


Closed Thread
 
Thread Tools Search this Thread
Old 01-07-2018, 11:09 AM   #1
Registered Member
 
Join Date: Jan 2008
Posts: 108
OS: Windows 7 Ultimate 64-bit


Question

I've got a 3TB internal drive that I bought and connected internally in my PC using SATA.

I've noticed it takes ages for files to copy to it

Using the default Windows 10 file copy handler I get unusual behaviour in that a transfer completes and then the disk activity light just goes solid and continues on well after.

For a test file using TeraCopy it shows a much slower speed of 4.5 MB/s but then has no trailing disk activity (completes).

Any ideas for a fix of this? Is this a situation of delayed writes or a write queuing issue?

Screenshots: https://imgur.com/a/AJqAj
random1 is offline  
Sponsored Links
Advertisement
 
Old 01-07-2018, 03:36 PM   #2
TSF Moderator
Hardware Team
Networking Team
 
SpywareDr's Avatar
 
Join Date: Jun 2013
Location: Maryland, USA
Posts: 6,602
OS: W10P64 10.0.19041.264; W7U64; W7P64; XPP32; Zorin; Slax; Ubuntu; Kali (BackTrack); Android 6.01



The WD30EZRZ is a 5,400 RPM model hard drive. A 7,200 RPM would be ~33% faster.
SpywareDr is offline  
Old 01-08-2018, 02:29 PM   #3
TSF Team, Emeritus
 
spunk.funk's Avatar
 
Join Date: May 2010
Location: Los Angeles
Posts: 40,548
OS: Windows 10 64 bit

My System


Is this drive New? Or just new to you?
Download and run Crystal Disk Info it will give you a better handle on the health of this drive. Once installed go to the toolbar to Disk, and select the 3TB drive to view the SMART details and other specs.
__________________
Please press the Like link to right of any post you found helpful.
spunk.funk is online now  
Sponsored Links
Advertisement
 
Old 01-13-2018, 09:26 AM   #4
Registered Member
 
Join Date: Jan 2008
Posts: 108
OS: Windows 7 Ultimate 64-bit



After all my tests I fixed it by enabling disk write caching (weirdly it was off):

https://www.tenforums.com/tutorials/...dows-10-a.html
random1 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] WD 500Gb HD gone awol
Good Day, It started out with explorer crashing then notebook, I though a reboot would sort it. I could not get back on to the drive, Windows could not run refresh, the usual suspects chkdsk etc I have a second system disk and I used that to get back on. I can see the 500GB drive but it is...
Dylanatstrumble Hard Drive Support 20 11-06-2014 01:07 PM
Win7 backup "completed" with error 0x8100002F
My profile lists systems specs. My OS drv (C:) has 1.64TB free of 1.80TB. Backup is to external Seagate Expansion Drv (K:) (1.81TB). Used space is 919GB, Free space is 943GB. I run ESET NOD32 which is always up-to-date. Windows Firewall is on. Error.log for the backup indicates that Windows...
MS47 Hard Drive Support 12 10-31-2014 10:51 AM
internal hard drive failing
I have a Dell Dimensions that was given to me and it has a 20GB Maxtor Hard Drive in it and is running Windows XP Home Edition. To make a very long story shorter I believe that the hard drive is failing on it since I was having real problems with it and was unable to access Windows at all. I was...
lmhjcr Hard Drive Support 8 06-04-2011 12:18 PM
Maxtor SATA drive - Very slow working speed
I have Maxtor Sata 160gb . I have put it as Secondary Drive and I m facing problem in it that while reading My Computer starts Lagging ,you can say slow .. mean if any song is playing while transferring , the song sounds like weird like low pitch voice .. mean my hard reading is slow SMART is...
kamithegreat Hard Drive Support 6 03-09-2011 08:55 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 01:41 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts