Go Back   Tech Support Forum > Hardware Support > Hard Drive Support

User Tag List

Maxtor External HD Doesn't Install

This is a discussion on Maxtor External HD Doesn't Install within the Hard Drive Support forums, part of the Tech Support Forum category. Maxtor One-Touch4 Plus External Drive Doesnít Install : I just bought a Maxtor One-Touch4 Plus 1000GB (1T) External Hard Drive


Closed Thread
 
Thread Tools Search this Thread
Old 03-26-2009, 06:09 PM   #1
Registered Member
 
Join Date: Dec 2008
Location: East Norriton, PA
Posts: 23
OS: WIN VISTA BUSINESS



Maxtor One-Touch4 Plus External Drive Doesnít Install :

I just bought a Maxtor One-Touch4 Plus 1000GB (1T) External Hard Drive and hooked it up to my new Dell Vostro 420 desktop using the supplied power adapter and USB connections as instructed. The power light is on. The drive beeped quietly for a few minutes, then stopped. After waiting more than 20 minutes, no Maxtor installation screen display appeared and the drive is, in effect, unusable.

My system uses the Windows Vista Business operating system. Now I already have a Maxtor One-Touch4 Plus 500GB External Hard Drive that I installed on this computer a few months ago and itís working fine.

Do I need to reboot the computer, with the new drive connected, for it to display the install screen?

My aim is to have both Maxtor One-Touch Touch4 Plus external hard drives installed and working on the same computer?

Thanks.
shamrock838 is offline  
Sponsored Links
Advertisement
 
Old 03-26-2009, 06:17 PM   #2
TSF Enthusiast
 
manic's Avatar
 
Join Date: Aug 2005
Location: Florida
Posts: 5,741
OS: xp



Does it show up in disk management? If so format and initiate from there.
manic is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 09:53 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts