Go Back   Tech Support Forum > Hardware Support > Hard Drive Support

User Tag List

Brand new seagate barracuda 2tb not spinning or powering on not detected in bios

This is a discussion on Brand new seagate barracuda 2tb not spinning or powering on not detected in bios within the Hard Drive Support forums, part of the Tech Support Forum category. Built my new pc yesterday installed windows onto the SSD and then switched off and plugged in the HDD one


Closed Thread
 
Thread Tools Search this Thread
Old 05-16-2018, 01:52 AM   #1
Registered Member
 
Join Date: May 2018
Posts: 1
OS:



Built my new pc yesterday installed windows onto the SSD and then switched off and plugged in the HDD one sata cable in the PSU and one into the mobo, the hdd doesnt spin make any noise or show up in bios ive tried different cables and power cables and other sata ports on th mobo.
My mobo is b350 pc mate
Psu is evga 650 gold
Do i have a dead drive?
georgedys is offline  
Sponsored Links
Advertisement
 
Old 05-16-2018, 04:45 AM   #2
Moderator TSF
Hardware Team Moderator
 
Stancestans's Avatar
 
Join Date: Apr 2009
Posts: 5,137
OS: Windows 10



Welcome to TSF!
Sounds like a dead unit to me. It should spin up as soon as it gets a power supply, with/without a mobo connection. It's best to return it and get a refund or replacement.
Stancestans is offline  
Old 05-16-2018, 11:53 PM   #3
TSF Enthusiast
 
Join Date: Feb 2010
Posts: 831
OS: Win98SE



Could this be your problem?

PSA: Mixing Modular PSU Cables Can Kill Components:
https://www.gamersnexus.net/guides/2...les-dont-do-it
fzabkar is offline  
Sponsored Links
Advertisement
 
Old 05-17-2018, 11:35 AM   #4
TSF Team, Emeritus
 
spunk.funk's Avatar
 
Join Date: May 2010
Location: Los Angeles
Posts: 40,548
OS: Windows 10 64 bit

My System


Quote:
plugged in the HDD one sata cable in the PSU and one into the mobo,
This statement is a little unclear to me. There should be a SATA power plug from the PSU that you are plugging into the back of the HDD, Then you would have a SATA Data cable plugged into the back of the HDD and then go to the Motherboard to one of the SATA ports.
If that is true, then boot into Setup (Bios) go to SATA Ports, make sure the SATA port on the motherboard the drive is plugged into is Enabled in the Bios. Also, try a different Power Plug from the PSU and a different SATA Data cable. Try a different SATA port on the Mobo.
Take the drive out of the computer and attach it to a known working desktop computer internally, or via a USB Adapter, Dock or Enclosure with a power adapter. Hook the power up and listen to the drive and make sure it is spinning. If not, it may have failed.
__________________
Please press the Like link to right of any post you found helpful.
spunk.funk is online now  
Old 05-19-2018, 06:28 PM   #5
Team Manager - Hardware
Acting Manager, Security Center
 
Rich-M's Avatar
 
Join Date: May 2007
Location: NE Pennsylvania
Posts: 14,467
OS: Windows 10 Professional

My System


I stopped using Seagate hard drives a few years ago as so many didn't work new out of the box. I certainly believe the drive is bad.
__________________


All PC's are not the same. Posting your PC specs will help us to assist you quicker and more effectively.
Rich-M is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
BSoD in 10 minutes after startup
Have recently bought a new computer and built it from scratch. I've been having problems with blue screen in the first ten minutes after I cold start it but after that the computer usually works without problem until the next day. I have been running memtest a few times and it havn't found any...
Serpentario BSOD, App Crashes And Hangs 28 11-14-2012 11:09 AM
possibly spyware, adware or what ever else.
Hi all, when i open a browser, it automatically direct me to some random sites. I tried making my default homepage something else but it still does the same thing. I would believe that it is either spyware or adware. Moreover, I have experienced that sometimes when i idol from my computer, it...
kewin118 Resolved HJT Threads 19 10-30-2012 04:49 AM
BSOD Problem
Hi , Im getting this BSOD from few months. Pls help. 1. Windows 7 Ultimate 2. x86 3. Windows 7 Home 4. not OEM 5. 2 years 6 2 years Sony Vaio VPCEA1S1E
Bonehard BSOD, App Crashes And Hangs 6 10-01-2012 12:08 PM
Win Server 2008 R2 BSOD's -- bad hardware?
I'm kind of at a loss. This server as been running ok now for 6 months but after moving it I am having all sorts of problems. Looking for pointers on how to troubleshoot and/or narrow down the source of the error.
bproven BSOD, App Crashes And Hangs 5 09-15-2012 07:12 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 01:11 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts