Go Back   Tech Support Forum > Automotive Center > Talk Car

User Tag List

Left signal indicator light for 1986 Dodge Aries LE

This is a discussion on Left signal indicator light for 1986 Dodge Aries LE within the Talk Car forums, part of the Tech Support Forum category. When I use left signal indicator light for my 1986 Dodge Aries L.E.. It doesn't flash green. It is solid


Closed Thread
 
Thread Tools Search this Thread
Old 08-22-2017, 08:50 PM   #1
TSF Enthusiast
 
Join Date: Aug 2010
Posts: 1,521
OS: Windows XP Pro & Win. 10 Home



When I use left signal indicator light for my 1986 Dodge Aries L.E..
It doesn't flash green. It is solid green light.

The right turn signal works and flashes green.

So what could be wrong ?

I read must be signal flasher or fuse ?

How do I get access to them and know where their locations are ?
How do I test them and determine which is faulty ?


Thanks

Zhong
zhong is offline  
Sponsored Links
Advertisement
 
Old 08-23-2017, 02:17 AM   #2
TSF Enthusiast
 
Wizmo's Avatar
 
Join Date: Apr 2011
Location: Caribbean
Posts: 5,022
OS: WIN7 ULTIMATE - 64 bit (SP1), FIREFOX, ASUS G75 'ROG' laptop(s)



Generally when I had such issues with Dodge/Plymouth vehicles it indicated a defective bulb, either front or back. If one side flashes it will not likely be the flasher unit itself.

The flasher works by the amount of current drawn by the bulbs to heat the bi-metal switch inside to make it flash.

__________________
"The pure and simple truth is rarely pure and never simple." - Oscar Wilde

"First get your facts; then you can distort them at your leisure." - Mark Twain

"Remember - HARDWARE is the part of the computer that can be KICKED!" - WIZMO
Wizmo is offline  
Old 08-24-2017, 09:59 AM   #3
TSF Enthusiast
 
Join Date: Aug 2010
Posts: 1,521
OS: Windows XP Pro & Win. 10 Home



Thanks

I found out that the left signal indicator light bulb on driver's side front is not working. The passenger side signal indicator light is working.

The lights at the back of the car both red lights are working except the one on the left doesn't flash when I use the signal indicator when I pull lever down. The one on the right flashes.

So do I just have to replace light bulb on driver's side left front. In order to get all the signal indicator lights on left hand side on front and back (driver's side) to flash again ?

I think there are special screws that holds the light orange cover to the light bulb. What type of screw driver do I need to unscrew the screws there ?

Thanks


Zhong

Quote:
Originally Posted by Wizmo View Post
Generally when I had such issues with Dodge/Plymouth vehicles it indicated a defective bulb, either front or back. If one side flashes it will not likely be the flasher unit itself.

The flasher works by the amount of current drawn by the bulbs to heat the bi-metal switch inside to make it flash.

zhong is offline  
Sponsored Links
Advertisement
 
Old 08-24-2017, 10:26 AM   #4
TSF Enthusiast
 
Join Date: Aug 2015
Posts: 911
OS: Win 7 HP 64B SP1



Quote:
Originally Posted by zhong View Post
What type of screw driver do I need to unscrew the screws there ?

You're the one looking at them. How would anyone else know? Most likely they're either Phillips or Torx.
Confounded Also is offline  
Old 08-24-2017, 10:33 AM   #5
Administrator
TSF Manager
 
SABL's Avatar
 
Join Date: Jul 2008
Location: Galena, Ohio
Posts: 26,831
OS: WinXP Pro SP3, Vista Home Premium SP2, Windows 10 Home x64



'86 could very well be #2 Phillips......later years would be Torx. Replace the bulb and things should be fine.
__________________
It's a good thing I never had any sanity......I would have lost it by now.
SABL is offline  
Old 08-24-2017, 10:08 PM   #6
TSF Enthusiast
 
Join Date: Aug 2010
Posts: 1,521
OS: Windows XP Pro & Win. 10 Home



I know what the screws look like.
They look like something in between these two-




For the head of the screws seemed to have been worn due to it being used before, so it is hard to describe. I know what phillips screw driver and screws looks like and they are not those type.

Zhong
zhong is offline  
Old 08-24-2017, 10:32 PM   #7
TSF Enthusiast
 
Join Date: Aug 2010
Posts: 1,521
OS: Windows XP Pro & Win. 10 Home



Have to remove orange plastic covering here-

Click image for larger version

Name:	ariesfront.jpg
Views:	8
Size:	58.0 KB
ID:	311953

Looks like I have to remove the torx screws and then pull it out from the front including the bezel to gain access to the light bulb?

Zhong
zhong is offline  
Old 08-24-2017, 10:43 PM   #8
TSF Enthusiast
 
Join Date: Aug 2010
Posts: 1,521
OS: Windows XP Pro & Win. 10 Home



Quote:
Originally Posted by zhong View Post
Have to remove orange plastic covering here-

Attachment 311953

Looks like I have to remove the torx screws and then pull it out from the front including the bezel to gain access to the light bulb?

Zhong
Or do I have to remove the battery from under the hood to get access to it from the opposite direction ?
zhong is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
no left turn signal on 89 probe gl
I have no left turn signal or left side hazard light When the left turn is on the flasher clicks rapidly but no signals front or rear. the same thing happens when the hazard is turned on. the right works fine. I have replaced the bulbs with ones I know are good.
rrknucklehead Automotive Support 2 11-27-2011 12:10 AM
A few Questions
Hey guys I have a few more questions, I have been slowly working on my site and looking for stuff to do it like the software to set up a social site kinda like fb or myspace. well any ways I also wanted to set up a message board for the site for people to get help or talk about stuff, for now it...
Dblanchard1278 Web Design & Development 27 07-25-2011 01:47 AM
[SOLVED] How can I put in a link to my picasa album?
I have about 80 photos I want people to have access to from the website, I thought the best way to do this would be to create a link to the album and add it to one of my web pages. I'm a complete novice and struggling a bit, hoping I can pull it all together! You may well hear from me again
liesbeth Web Design & Development 53 05-20-2011 09:45 PM
Bad exhaust smell on Dodge Aries 1986
There is a bad strong exhaust smell when idling on my Dodge Aries 1986. Better when driving. What could be this due to ? Thanks.
zhong Automotive Support 10 05-11-2011 07:59 AM
self-centering webpage - How do I do it in Dreamweaver?
I have a hobby website that I built a few years back in Dreamweaver. I'd like to update it and put it in what seems to be a very common format of a column that self-centers in the window. I've looked all over the place to learn how to do it, including the Dreamweaver MX help files and I haven't...
EnsignSuder Web Design & Development 18 04-15-2011 05:30 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts