Go Back   Tech Support Forum > Hardware Support > Motherboards, Bios|UEFI & CPU

User Tag List

My screen isnt connecting?

This is a discussion on My screen isnt connecting? within the Motherboards, Bios|UEFI & CPU forums, part of the Tech Support Forum category. Hi i was playing Counter Strike:Source today then my computer suddenly shut off. I turned it on but the screen


Closed Thread
 
Thread Tools Search this Thread
Old 07-27-2008, 08:05 PM   #1
Guest
 
Join Date: Jul 2008
Posts: 1
OS:



Hi i was playing Counter Strike:Source today then my computer suddenly shut off. I turned it on but the screen wasnt connecting. it was like i didnt plug the screen in to the computer (which i did). I'm thinking its because i played CSS and Lineage 2 for like 14 hours straight? im not sure.. could someone help me:
fattony69 is offline  
Sponsored Links
Advertisement
 
Old 07-27-2008, 10:19 PM   #2
TSF Enthusiast
 
magnethead's Avatar
 
Join Date: Mar 2006
Location: Texas, USA
Posts: 4,486
OS: Win7 x64, Raspibian, OSX Yosemite x64

My System

Send a message via AIM to magnethead

please state your system, as outlined in my sig.
magnethead is offline  
Old 07-28-2008, 12:41 AM   #3
Guest
 
Join Date: Jun 2008
Posts: 45
OS:



Your graphic card blew? But please post your specs to be sure.
Enkai is offline  
Sponsored Links
Advertisement
 
Old 07-28-2008, 02:21 AM   #4
Enthusiast
 
Join Date: Jan 2005
Location: UK
Posts: 1,300
OS: Vista SP1, Ultimate

My System


Same thing happened to my graphics card. Was playing C&C tiberian wars and PC shut down and wasn't switching on for more than 2 secs. Thought my PSU had gone as I could smell burning but turned out to be the MOSFET on the GFX card (7800GTX). Lucky I had one from BFG tech and I got a replacement within 5 days with the liftime warranty. Absolute magic customer service.
lazareth1 is offline  
Old 07-28-2008, 02:32 AM   #5
Guest
 
Join Date: Jun 2008
Posts: 45
OS:



Quote:
Originally Posted by lazareth1 View Post
Same thing happened to my graphics card. Was playing C&C tiberian wars and PC shut down and wasn't switching on for more than 2 secs. Thought my PSU had gone as I could smell burning but turned out to be the MOSFET on the GFX card (7800GTX). Lucky I had one from BFG tech and I got a replacement within 5 days with the liftime warranty. Absolute magic customer service.
That is fast. Yea i think when you shop for pc hardware, always go for those with good after purchase support. This will make your purchase worth every penny.
Enkai is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 12:17 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts