Go Back   Tech Support Forum > Networking Forum > Cabling and Network Cards

User Tag List

Faulty Card or Software Issue?

This is a discussion on Faulty Card or Software Issue? within the Cabling and Network Cards forums, part of the Tech Support Forum category. I just purchased a brand new Lenovo Y50 Ultra HD Laptop and I immediately noticed my internet is terrible. My


Closed Thread
 
Thread Tools Search this Thread
Old 10-05-2014, 08:07 PM   #1
Registered Member
 
Join Date: Dec 2012
Posts: 44
OS: Windows 7



I just purchased a brand new Lenovo Y50 Ultra HD Laptop and I immediately noticed my internet is terrible. My brother also has a Lenovo laptop and is connected to the same router and has a very good connection. I contacted Leneovo tech support and they adjusted some settings, but did not fix the issue.

Sometimes download speeds are terrible. Ping randomly spikes.

The Network Card driver is up to date

Running a ping test in cmd shows no packet loss but pingtest.net shows a 6-12% packet loss

Xirrus Wifi Inspector: Gyazo - 27dedacc65af6cb0a4292e33200ccee1.png

Network Card: Intel® Dual Band Wireless-AC 3160

I just got this laptop and the wifi sucks. It has to be a hardware issue, right?
qdeanc is offline  
Sponsored Links
Advertisement
 
Old 10-05-2014, 09:43 PM   #2
Networking Team |Tech
 
DBCooper's Avatar
 
Join Date: Jun 2010
Location: Los Angeles, California
Posts: 4,117
OS: Windows 10



Hi there,

Try un-installing the wifi drivers and re-install the newest drivers by going to Lenovo's site and downloading the latest drivers for your computer wifi. Hope this helps.
__________________
Dan Cooper ---> Nov. 24, 1971 + Flight 305 = $200,000.


DBCooper is offline  
Old 10-05-2014, 10:02 PM   #3
Registered Member
 
Join Date: Dec 2012
Posts: 44
OS: Windows 7



There are no updated drivers for the network card on this laptop. The default is the latest that I could find. I've already re-installed it several times and it did not help.
qdeanc is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problems with staying on line with all Browsers
Hi all, I have a Compaq Microsoft Windows XP Version 2002 Service Pk 3. I checked and it said I have 11.3 GB available. I have downloaded every single Browser, IE keeps saying low on memory, no memory at line 1, 10, 22 etc. freezes up on me & boots me off line.The rest of them seem to all say:...
JoJo62 Motherboards, Bios & CPU 14 06-19-2013 07:43 AM
Repost Per: CatByte Trojan:dos/alureon.e and SmartHDD problem
Trojan:dos/alureon.e and SmartHDD problem Hello, I hope I'm at the right area for help. This pc I'm on was infected with Trojan:dos/alureon.e and SmartHDD. I was able to get to the net somehow and I installed and ran Malwarebytes and got rid of SmartHDD. Then I ran Windows Defender and it found...
mg67 Resolved HJT Threads 23 07-30-2012 06:24 AM
Hotmail Account is sending spam
Hi, Last night it seems that my hotmail account has been spamming all my contacts. I have avast and Malwarebytes and have run this today with no viruses detected. I have read on some of the forums regarding this issues that either there could be a key logger or perhaps my account details...
nathanjrussell General Computer Security 13 10-15-2011 06:58 PM
Windows XP Fix
I have got this intruder on my computer. I cannot access the internet or anything else. I was going to do a system restore, but I cannot get to it. I do have another computer with Vista, but I need the XP computer for work. Please help!
mishamisha Virus/Trojan/Spyware Help 26 07-14-2011 06:36 PM
Looking to get better quality on my scans
I have HP C4180 All-in-one (print, scan, copy) Right now I'm trying to scan a yearbook that I never got myself, back when I was in middle school. I want to scan the whole thing and return it to the owner, who has not had it in months. Only thing is, I don't want the quality to be bad as I probably...
PC person Printer Support 4 06-15-2011 06:02 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 06:26 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts