Go Back   Tech Support Forum > Networking Forum > Cabling and Network Cards

User Tag List

Broadcom 802.11n Network Adapter NOT WORKING properly!? (Screenshots inside)

This is a discussion on Broadcom 802.11n Network Adapter NOT WORKING properly!? (Screenshots inside) within the Cabling and Network Cards forums, part of the Tech Support Forum category. Laptop: Acer Aspire 5820TG Network adapter: Broadcom 802.11n OS: Windows 7 I've had this laptop since 2011 or so. I


Closed Thread
 
Thread Tools Search this Thread
Old 02-13-2016, 03:30 AM   #1
Registered Member
 
Steria's Avatar
 
Join Date: May 2012
Posts: 40
OS: Windows 10


Mistake

Laptop: Acer Aspire 5820TG
Network adapter: Broadcom 802.11n
OS: Windows 7

I've had this laptop since 2011 or so. I cannot recall it having a network adapter problem before. However, earlier yesterday everything was working fine. Then, when I came home from work and opened the laptop there was no wifi-symbol on the taskbar, but a red X over the ethernet-symbol...

I've tried to re-install the driver from the Acer website ( Download Drivers and Manuals | Acer Official Site), but when doing that it tells me to "use the Found New Hardware Wizard to complete the driver installation". I cannot find this...



This is what it looks like under Device Manager:



When I click update driver under Device Manager, it tells me I have the newest updated driver:



How can I fix this issue?
Steria is offline  
Sponsored Links
Advertisement
 
Old 02-13-2016, 06:54 AM   #2
TSF Moderator
Hardware Team
Networking Team
 
SpywareDr's Avatar
 
Join Date: Jun 2013
Location: Maryland, USA
Posts: 6,602
OS: W10P64 10.0.19041.264; W7U64; W7P64; XPP32; Zorin; Slax; Ubuntu; Kali (BackTrack); Android 6.01



Try deleting the Ethernet/LAN adapter in Device Manager, reboot and Windows should do its Scanning for New Hardware routine and re-set it up for you.
SpywareDr is offline  
Old 02-13-2016, 08:39 AM   #3
Registered Member
 
Steria's Avatar
 
Join Date: May 2012
Posts: 40
OS: Windows 10



Quote:
Originally Posted by SpywareDr View Post
Try deleting the Ethernet/LAN adapter in Device Manager, reboot and Windows should do its Scanning for New Hardware routine and re-set it up for you.
There is no problem with my ethernet connection though (as I am using that right now).

I tried to uninstall the Broadcom Network Adapter and "Scan for hardware changes", but this was unsuccessful (see pic):

Steria is offline  
Sponsored Links
Advertisement
 
Old 02-13-2016, 11:30 AM   #4
TSF Moderator
Hardware Team
Networking Team
 
SpywareDr's Avatar
 
Join Date: Jun 2013
Location: Maryland, USA
Posts: 6,602
OS: W10P64 10.0.19041.264; W7U64; W7P64; XPP32; Zorin; Slax; Ubuntu; Kali (BackTrack); Android 6.01



Then you might try using Windows System Restore to roll Windows back to a point in time when your computer was functioning correctly. It allows you to undo system changes without affecting your personal files, such as e-mail, documents, or photos.
Video: Fixing a problem using System Restore
If that doesn't help, try restoring an earlier system image or backup.
SpywareDr is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
BSOD happening frequently
Hello, I bought a laptop recently for my studies and I was a bit reluctant to the idea of having windows 8.1 as I had the "opportunity" to see on friends computers how much I disliked it. But I couldn't really avoid it to get my brand new ASUS ROG JM551 so I finally purchased it. Now I'm having...
TraxXx44 BSOD, App Crashes And Hangs 1 05-19-2015 12:42 AM
BSOD 0x1A running Viber 3.1.1.60 on W7x64
Hello. I've installed Viber for Windows onto my stable system. Now I'm getting occasionally a BSOD 0x1A during first running hour. Now I killed the Viber app after Windows start and work ok for 3 hours. The Viber log.log file says: Product version 3.0.0.133634 The viber.exe file version is...
pieceofbrain BSOD, App Crashes And Hangs 2 09-28-2013 08:43 AM
Slow boot, even during clean boot
For a couple years now my computer has been booting slowly, no matter what I try to do to fix it. Typical boot time is between 81-92 seconds, and even a clean boot took 77 seconds. I know it's not as bad as it could be, but I'm very proud of how clean my computer is, and it's frustrating. One...
Jarius Windows 7 , Windows Vista Support 8 09-20-2013 12:32 PM
Windows 7 freezes at startup (HiJack This Log)
Out of the blue my Windows 7 x64 laptop started having problems. Every time I boot it will get to the desktop and LOOK fine, but if I try to open anything it is completely unresponsive. Eventually it will notify me that Windows is not responding and offer to restart or wait. If I restart the...
slhaas Windows 7 , Windows Vista Support 3 08-01-2011 12:29 PM
[SOLVED] Rootkit problem: hidden boot sector.
Dearest Techies: I have Windows 7 Home Premium on a Dell Inspiron N7010 Notebook. A few days ago the computer would not start and took me to the windows 7 startup repair utility, and it was unsuccessful in repairing the problem. I ended up having to restore the system to factory settings to get...
Raygumm Resolved HJT Threads 60 07-03-2011 09:07 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 01:49 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts