Go Back   Tech Support Forum > Networking Forum > Cabling and Network Cards

User Tag List

Asus USB-AC68 not working in USB 3.1 Gen 1 port

This is a discussion on Asus USB-AC68 not working in USB 3.1 Gen 1 port within the Cabling and Network Cards forums, part of the Tech Support Forum category. I just got myself a new WiFi adapter, the Asus USB-AC68 USB 3.0 adapter. Downloaded the latest driver from Asus


Closed Thread
 
Thread Tools Search this Thread
Old 10-27-2016, 02:48 PM   #1
Registered Member
 
Join Date: Apr 2015
Posts: 80
OS: Windows XP, Windows 7, Windows 10

My System


I just got myself a new WiFi adapter, the Asus USB-AC68 USB 3.0 adapter. Downloaded the latest driver from Asus and hooked it up to the SS USB 3.1 Gen 1 port on the back of my MSI B150 Gaming M3 motherboard.

After the installation it gave me the following message:
"You have connected your device to an Asmedia USB 3.0 port. To improve functionality, upgrade the supported USB 3.0 driver. Do you want to upgrade the USB 3.0 driver?"

As my motherboard don't have any USB drivers on their service site I clicked No and rebooted my PC. After a few minutes of usage the adapter started re-connecting non-stop until I removed it from the port. I tried hooking it up again but the same thing happend over and over again until I decided to try and re-install the driver.

This time I clicked Yes when it asked me to update the USB 3.0 driver. However after another few minutes the adapter started re-connecting again. This time I tried connecting it to the normal USB 3.0 ports on the front panel of my case and now its working as it should and have all night.

I know there is nothing wrong with my USB 3.1 ports on the back of my motherboard as I use those ports very often for my USB 3.0 Corsair GTX drive.

Any advice on this? I would love to use the adapter on the back of my motherboard and not the front panel as the adapter is in the way.
freddiebox is offline  
Sponsored Links
Advertisement
 
Old 10-27-2016, 04:05 PM   #2
Registered Member
 
Join Date: Apr 2015
Posts: 80
OS: Windows XP, Windows 7, Windows 10

My System


Update: So it turns out the adapter won't work in regular USB 3.0 ports neither. Now switching to USB 2.0 and see how it works there for a longer period of time.
freddiebox is offline  
Old 10-30-2016, 06:55 AM   #3
Registered Member
 
Join Date: Apr 2015
Posts: 80
OS: Windows XP, Windows 7, Windows 10

My System


Turns out the adapter don't work on USB 2.0 either - Returned the adapter to my retailer and got a refund, turns out the adapter don't work that well on Windows 10.
freddiebox is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird texture shards in certain games
Hi everyone, I have been having an issue with certain games, namely Battlefield 3, Battlefield 4 and most recently Star Wars Battlefront, where weird flickering texture shards pop up constantly. This problem was a slight nuisance in Battlefield 3 and 4 but when I tried to play Star Wars...
Elphis PC Gaming Support 4 10-13-2015 10:50 AM
Trouble Getting ISO To Thumb Drive
Acer Aspire M1641 Vista Premium SP2 32 bit I have been trying to put Windows10_TechnicalPreview_x32_EN-US_9926.iso on a thumb drive, using the latest version of Rufus. I got an error message while using two perfectly good drives. After getting the error message when trying with a third drive,...
likekinds Removable Media Drives 79 02-19-2015 03:05 PM
Driver Error or Possible Video Card Failure?
First of all, thanks to anyone in advance for all your help. Im pretty sure that my video card is fried, but I just wanted to check with you guys before making the decision to buy a new one. I started having problems a few weeks ago. Noticed when I started up my computer some days the icons on...
theafterglow Driver Support 22 03-16-2012 01:09 PM
ATI radeon x300 series
Recently my computer has started running very slow(7fps on most online games) so i think im at the point where i need to start replacing some parts. I started with the RAM and upgraded this from 500mb to 2.5gb. It runs alot better but its still pretty slow on most games, a friend suggested...
HushoO Video Card Support 35 05-29-2011 12:41 PM
Newbie - Network Flow Analysis
Hi Guys, I am new to analysis of the network flow. I have uploaded the image of the network flow that I need help with analysis. I think it is the case of UDP flooding in which source is sending a large number of UDP packets to random ports on a remote host. Can somebody please look at the...
micky_577 Networking Support 3 04-20-2011 10:16 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 03:05 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts