Go Back   Tech Support Forum > Networking Forum > Modems/Cable/DSL/Satellite

User Tag List

HUAWEI E3276 4G USB Modem

This is a discussion on HUAWEI E3276 4G USB Modem within the Modems/Cable/DSL/Satellite forums, part of the Tech Support Forum category. hello,i'm using Huawei E3276s-920 4G dongle already unlocked for different mobile operators.i would love to know if upgrading the firmware


Closed Thread
 
Thread Tools Search this Thread
Old 06-28-2017, 01:15 PM   #1
Registered Member
 
Join Date: Aug 2014
Posts: 27
OS: win7



hello,i'm using Huawei E3276s-920 4G dongle already unlocked for different mobile operators.i would love to know if upgrading the firmware will add more LTE frequency Band as currently the modem only operates on Band 40 TDD (2300MHz)? i want want to switch to a different operator with different LTE Bands don't wanna buy a new device. thanks for your help
peekay is offline  
Sponsored Links
Advertisement
 
Old 07-27-2017, 05:59 AM   #2
Team Manager - Networking
Moderator - Hardware
 
JimE's Avatar
 
Join Date: Apr 2009
Location: St Louis, MO
Posts: 19,813
OS: Win 7 SP1

My System


I've not dealt with those, but three thoughts:

1) Depending on how it was "unlocked", changing the firmware can undo those changes.

2) Firmware isn't likely to alter basic operation. It's possible the device already supports all of those frequencies, and the firmware simply limited what was available, but I wouldn't expect that is likely.

3) Check what was changed in the new firmware. Unless the new firmware specifically addresses an existing issue which you are trying to resolve, then it's not recommended to upgrade. This applies to ALL hardware. Newer isn't always better.
__________________
Jim

JimE is offline  
Old 07-27-2017, 11:22 AM   #3
Registered Member
 
Join Date: Aug 2014
Posts: 27
OS: win7



Thanks Jim,i did the firmware upgrade nothing changed only support LTE Band 40.i'm thinking for it to support multiple LTE Bands has to do with the Hardware of the Device. what do you think?
peekay is offline  
Sponsored Links
Advertisement
 
Old 07-28-2017, 07:59 AM   #4
Team Manager - Networking
Moderator - Hardware
 
JimE's Avatar
 
Join Date: Apr 2009
Location: St Louis, MO
Posts: 19,813
OS: Win 7 SP1

My System


That would be my guess as well.
__________________
Jim

JimE is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't access internet ..error 651
Because I was having problems getting past an onscreen message to boot up my granddaughter's laptop (Acer AS3810tz) I decided to install windows 7 ultimate over my old windows 7 home version. However, whilst the annoying popup message has now gone, I can't connect to my wifi broadband. I keep...
al shookup Networking Support 37 03-01-2015 04:31 AM
[SOLVED] how can I connect my 3G USB modem with a TP-LINK wireless router(TL-WR702N)
hello guys,i just bought a wireless router TP-link 150mbps wireless N nano router(TL-WR702N).I have a 3G USB modem that I connect to the Internet with my laptop,i want to create a wifi for my wireless devices with the TP-Link Router via ethernet port of my laptop. I have configured the...
peekay Networking Support 9 10-21-2014 10:20 PM
3TB HDD won't format
I recently bought a 3TB 5400RPM hard drive and placed it in an enclosure. I orginially had connected it to my PC via USB 2.0 and formatted the entire drive and everything seemed to be in working order. After that I decided to connect the drive via eSATA because of the speed increase. When...
UhOhOhNo Hard Drive Support 8 09-13-2011 08:22 PM
What version USB do I have?
So the problem started when my first flash drive began transfering data at unusually slow speeds. I would always transfer 700MB or so films from my computer to the flash drive to watch onmy Xbox 360 later but it had recently began copying at slow speeds, under 1MB/sec, which was not what it used to...
Solidify Other Hardware Support 19 05-16-2011 01:34 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 05:53 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts