Go Back   Tech Support Forum > Microsoft Support > Internet Browsers and Email > Other Browsers

User Tag List

On Chrome & FireFox - elements not working

This is a discussion on On Chrome & FireFox - elements not working within the Other Browsers forums, part of the Tech Support Forum category. Hello, I have an unusual situation I need help with. I am in a bad way financially so I am


Reply
 
Thread Tools Search this Thread
Old 01-14-2020, 09:20 PM   #1
Registered Member
 
WndrWmn's Avatar
 
Join Date: Oct 2012
Location: Maywood, NJ, USA
Posts: 17
OS: Windows 10 Insider Beta Previews



Hello,

I have an unusual situation I need help with. I am in a bad way financially so I am forced to have to live with using my 4g LTE unlimited (but always throttled due to prioritization or reaching certain data use thresholds) hotspot on my iPhone 8+ because I cannot afford a normal ISP for my apartment. I use the hotspot for pretty much everything with little to no problems. I stream YT & Amazon Prime vids to my 2 50" & 58" smart TVs with little to no spooling, also for my iPad and lastly my Win10 laptop which is 8 or 9 yrs old but humming like a champ (16GB RAM, 500GB C: barely full for only OS and progs & 1TB data drive both which are internal). All work adequately.

The only probs I'm experiencing are my iPad being slow (I can deal with it so no big whops) and although it takes my pages a little bit longer than I'd prefer on my laptop (again can live with) the problem that is frustrating is that for both Chrome and FireFox (I don't use Edge w/Chromium or MSIE) multiple menus, drop down lists and buttons refuse to work at all for many sites. Just tonight I wanted to use CNET and I could not get the search magnifying glass to activate the search box nor could I get the comment icon link to take me to the comments for an article nor could I get the sign in button to work nor the comments button below an article I wanted to leave a comment about. This has happened for me on numerous sites but the CNET being just tonight was the only one that came to mind to pick as my example. Again, please remember this is happening on both Chrome & FF.

I am uncertain what could be causing this. I also experience many times that I have to repeatedly attempt to load a page even when I am on a legit WiFi signal and additionally I have many times that I cannot get the annoying spinning circle for loading pages on Chrome to stop spinning even when I click the "X" to stop loading the page.

Any suggestions? I am a Level 1 corp computer support person with 25 yrs experience so I have already tried the obvious, tossing cookies/clearing cache and machine has been updated and rebooted.


Thank you for your help.


Sincerely,

Wonder Woman
WndrWmn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-15-2020, 07:31 AM   #2
Team Manager
Microsoft Support
 
Corday's Avatar
 
Join Date: Mar 2010
Location: Midlands of South Carolina
Posts: 25,371
OS: Windows10. In the past CP/M, DOS, Windows 95, 2000, 98SE, ME, Vista & Windows 7

My System


You have to be aware of the amount of data being "transmitted" at any one time. That's the reason for slow downs or lack of "feature" use. Although you're giving up a lot, hopefully your financial situation will improve in the future and you won't have to depend on a Mobile Hotspot.
__________________

The stability of an OS is in direct proportion to the stability of the user.
Corday is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 09:44 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts