Go Back   Tech Support Forum > Hardware Support > Laptop Support

User Tag List

Laptop powersupply issues

This is a discussion on Laptop powersupply issues within the Laptop Support forums, part of the Tech Support Forum category. Hi guys. A few weeks ago whilst on my laptop I accidentally hit the power cord of my laptop (while


Closed Thread
 
Thread Tools Search this Thread
Old 06-12-2011, 06:30 PM   #1
Registered Member
 
Join Date: Jun 2011
Posts: 1
OS: Windows 7



Hi guys.

A few weeks ago whilst on my laptop I accidentally hit the power cord of my laptop (while it was plugged in) and I think I've either damaged the adapter itself or the actual plug (on my laptop). I was just wondering if a) there was a way to turn off power notifications, i.e. when you plug the laptop onto ac power a notification come up on the screen (since the connection is loose it repeatedly turns on and off until I hit the 'sweet spot' and the connection works) and b) If this a problem that can be fixed by taking my laptop in for repairs and how much it might roughly cost? Taking the laptop back to the manufacturer is not really an option as I purchased this laptop in America and am currently living in Australia, although if it is a costly repair I can make the effort to send it overseas.

The laptop itself is fairly new. A link to its make, model and specs can be found below.

Any replies/answers would be greatly appreciated. I would also like to apologize if I've posted in the wrong section. This is my first time on this forum. Thanks guys.

ASUS - Laptop / Intel® Core™ i7 Processor / 17.3" Display / 8GB Memory / 750GB Hard Drive - Black - G73SW-BST6
jjt220 is offline  
Sponsored Links
Advertisement
 
Old 06-12-2011, 07:36 PM   #2
Registered Member
 
Join Date: Jun 2011
Posts: 55
OS: Vista, Windows 7


I would contact the warranty provider if the warranty is still intact
4mattc is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
My laptop turns on but the screen shows nothing / remains off
Hi there, I have a Toshiba Equium A300D-16C laptop. It was fine until now... When I press the power button, my laptop turns on but the screen remains black / off. HDD indicator doesn't flash or anything ... ( in case this helps ) I've also tried to remove the battery, hold the power button...
rejanu Laptop Support 6 08-25-2011 07:46 AM
Issues starting up laptop need help
Dell Inspiron Laptop - I am getting error 0xc01a001d 28391/96392 (\registry\machine\COMPONENTS\DerivedData...) my system wont load but I have a load of pictures on my hard drive that I dont want to loose WHAT CAN I DO TO SOLVE THIS HELP!!!!!!!!!!
Castigerowen Laptop Support 3 06-11-2011 07:39 AM
Odd laptop motherboard/RAM issue
Hello all, I'm a new member here looking for some assistance with an HP laptop that I have. I posted my issues in another forum, so please forgive me for copying and pasting my problem. ORIGINAL ISSUE: Alright, well I've got a really strange laptop problem that I'm looking for some...
bobbylx Laptop Support 1 03-06-2011 10:18 PM
Reformatted Laptop, Internet slow on one laptop, fast on the other
Hey guys, new guy here, been having a bit of a problem with a laptop and its driving me crazy! Was wondering if perhaps somebody can help me out? I recently acquired a laptop from a friend, he was having problems with it and decided to just give it away and buy a new one, I took and it examined...
Dah_jOkA Networking Support 10 03-02-2011 07:30 PM
Laptop running slow/anti-virus software unable to run
Yesterday my laptop started acting up (running very slow, windows explorer not responding). I decided to restart my laptop, and upon restart it did it's normal routine, but when I logged into my user account, it stayed at welcome for a while then went to a black screen with a moveable cursor. After...
travman634 Resolved HJT Threads 1 03-01-2011 04:04 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2
Powered by vBadvanced CMPS v3.2.3


All times are GMT -7. The time now is 10:39 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2001 - 2018, Tech Support Forum

Windows 10 - Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts