Go Back   Tech Support Forum > Alternative Computing > Linux Support

Ndiswrapper help

This is a discussion on Ndiswrapper help within the Linux Support forums, part of the Tech Support Forum category. Hey, im new to ubuntu and have no idea how to work the terminal ect, so im finding it very


Reply
 
Thread Tools Search this Thread
Old 10-27-2008, 06:08 PM   #1
Registered Member
 
Join Date: Dec 2007
Posts: 25
OS: vista/xp/ubuntu



Hey, im new to ubuntu and have no idea how to work the terminal ect, so im finding it very hard to install ndiswrapper for my wireless card, can someone please give me simple step by step commands/instructions on how to do this please!

this is how far i got on my own, im not sure if i made a complete mess or if i actually accomplished something, its copy and pasted from the terminal :

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ urpme ndiswrapper
bash: urpme: command not found
ubuntu@ubuntu:~$ sudo apt-get install ndiswrapper-common ndiswrapper-modules-1.9 ndiswrapper-utils-1.9 ndisgtk
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package ndiswrapper-modules-1.9 is a virtual package provided by:
linux-ubuntu-modules-2.6.22-14-server 2.6.22-14.37
linux-ubuntu-modules-2.6.22-14-generic 2.6.22-14.37
linux-ubuntu-modules-2.6.22-14-386 2.6.22-14.37
You should explicitly select one to install.
E: Package ndiswrapper-modules-1.9 has no installation candidate
ubuntu@ubuntu:~$ ndisgtk
The program 'ndisgtk' is currently not installed. You can install it by typing:
sudo apt-get install ndisgtk
You will have to enable component called 'universe'
bash: ndisgtk: command not found
ubuntu@ubuntu:~$ sudo apt-get install ndisgtk
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package ndisgtk
ubuntu@ubuntu:~$ ndiswrapper -l
The program 'ndiswrapper' is currently not installed. You can install it by typing:
sudo apt-get install ndiswrapper-common
bash: ndiswrapper: command not found
ubuntu@ubuntu:~$ lsusb
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
ubuntu@ubuntu:~$ lsusb
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
ubuntu@ubuntu:~$ lspci -n
00:00.0 0600: 8086:2570 (rev 02)
00:02.0 0300: 8086:2572 (rev 02)
00:1d.0 0c03: 8086:24d2 (rev 02)
00:1d.1 0c03: 8086:24d4 (rev 02)
00:1d.2 0c03: 8086:24d7 (rev 02)
00:1d.3 0c03: 8086:24de (rev 02)
00:1d.7 0c03: 8086:24dd (rev 02)
00:1e.0 0604: 8086:244e (rev c2)
00:1f.0 0601: 8086:24d0 (rev 02)
00:1f.1 0101: 8086:24db (rev 02)
00:1f.2 0101: 8086:24d1 (rev 02)
00:1f.3 0c05: 8086:24d3 (rev 02)
00:1f.5 0401: 8086:24d5 (rev 02)
01:0c.0 0200: 8086:100e (rev 02)
ubuntu@ubuntu:~$ ndiswrapper -i driver.inf
Segmentation fault (core dumped)
ubuntu@ubuntu:~$ ndiswrapper -i driver.inf
The program 'ndiswrapper' is currently not installed. You can install it by typing:
sudo apt-get install ndiswrapper-common
bash: ndiswrapper: command not found
ubuntu@ubuntu:~$ sudo apt-get install ndiswrapper-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
ndiswrapper-source
The following NEW packages will be installed:
ndiswrapper-common
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/19.2kB of archives.
After unpacking 106kB of additional disk space will be used.
Selecting previously deselected package ndiswrapper-common.
(Reading database ... 92004 files and directories currently installed.)
Unpacking ndiswrapper-common (from .../ndiswrapper-common_1.43-1ubuntu2_all.deb) ...
Setting up ndiswrapper-common (1.43-1ubuntu2) ...
ubuntu@ubuntu:~$ lspci -n
00:00.0 0600: 8086:2570 (rev 02)
00:02.0 0300: 8086:2572 (rev 02)
00:1d.0 0c03: 8086:24d2 (rev 02)
00:1d.1 0c03: 8086:24d4 (rev 02)
00:1d.2 0c03: 8086:24d7 (rev 02)
00:1d.3 0c03: 8086:24de (rev 02)
00:1d.7 0c03: 8086:24dd (rev 02)
00:1e.0 0604: 8086:244e (rev c2)
00:1f.0 0601: 8086:24d0 (rev 02)
00:1f.1 0101: 8086:24db (rev 02)
00:1f.2 0101: 8086:24d1 (rev 02)
00:1f.3 0c05: 8086:24d3 (rev 02)
00:1f.5 0401: 8086:24d5 (rev 02)
01:0c.0 0200: 8086:100e (rev 02)
ubuntu@ubuntu:~$ lspci -n
00:00.0 0600: 8086:2570 (rev 02)
00:02.0 0300: 8086:2572 (rev 02)
00:1d.0 0c03: 8086:24d2 (rev 02)
00:1d.1 0c03: 8086:24d4 (rev 02)
00:1d.2 0c03: 8086:24d7 (rev 02)
00:1d.3 0c03: 8086:24de (rev 02)
00:1d.7 0c03: 8086:24dd (rev 02)
00:1e.0 0604: 8086:244e (rev c2)
00:1f.0 0601: 8086:24d0 (rev 02)
00:1f.1 0101: 8086:24db (rev 02)
00:1f.2 0101: 8086:24d1 (rev 02)
00:1f.3 0c05: 8086:24d3 (rev 02)
00:1f.5 0401: 8086:24d5 (rev 02)
01:0c.0 0200: 8086:100e (rev 02)
ubuntu@ubuntu:~$ ndiswrapper -i driver.inf
Error: no ndiswrapper utils found!
ubuntu@ubuntu:~$ ndiswrapper -i driver.inf
Error: no ndiswrapper utils found!
ubuntu@ubuntu:~$ tar zxvf ndiswrapper-version.tar.gz
tar: ndiswrapper-version.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
ubuntu@ubuntu:~$ ndiswrapper -i net8185.inf
Error: no ndiswrapper utils found!
ubuntu@ubuntu:~$ ls /lib/modules/`uname -r`/build
arch Documentation include Kbuild Makefile net sound
block drivers init kernel mm scripts usr
crypto fs ipc lib Module.symvers security
ubuntu@ubuntu:~$ tar zxvf ndiswrapper-version.tar.gz
tar: ndiswrapper-version.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
ubuntu@ubuntu:~$ ls /lib/modules/`uname -r`/build
arch Documentation include Kbuild Makefile net sound
block drivers init kernel mm scripts usr
crypto fs ipc lib Module.symvers security
ubuntu@ubuntu:~$ login
No utmp entry. You must exec "login" from the lowest level "sh"
ubuntu@ubuntu:~$ Login
bash: Login: command not found
ubuntu@ubuntu:~$ Login/root
bash: Login/root: No such file or directory
ubuntu@ubuntu:~$ make install
make: *** No rule to make target `install'. Stop.
ubuntu@ubuntu:~$ make ndiswrapper install
make: *** No rule to make target `ndiswrapper'. Stop.
ubuntu@ubuntu:~$

__________________
pentryn is offline   Reply With Quote
Old 10-27-2008, 10:47 PM   #2
Manager
- Alternative Computing
- Design
 
wmorri's Avatar
 
Join Date: May 2008
Location: New York
Posts: 5,769
OS: Window 7/Ubuntu/Fedora/Backtrack 5

My System

Send a message via AIM to wmorri Send a message via MSN to wmorri

Hi thanks for posting this in the forum!

Try doing it this way:
Code:
sudo apt-get install ndiswrapper
That is all that you should have to do.
Cheers!
__________________



Linux Forever!|html5 boilerplate
wmorri is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 07:42 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts