Go Back   Tech Support Forum > Gaming Forum > PC Gaming Support

Several Games Freezing

This is a discussion on Several Games Freezing within the PC Gaming Support forums, part of the Tech Support Forum category. Hello I just got my new computer this christmas and I am having some probloms when I play the better


Closed Thread
 
Thread Tools Search this Thread
Old 12-29-2004, 05:02 PM   #1
Registered Member
 
Join Date: Dec 2004
Posts: 1
OS: XP



Hello I just got my new computer this christmas and I am having some probloms when I play the better grapic games usualy. For instance after playing The Lord of The Rings The Battle For Middle Earth for only a few minutes it freezes and I have to restart my computer. It has also froze on Doom 3 and Call of Duty. I dont really know all of my specs but I am using a Pentium 4 3.0ghz and an ATI Radeon 9600 XT 256mb and I have 512 mb of ram. If it really matters I can find out all of my specs and edit this post. I just downloaded the Catalyst Control center to get the latest drivers but I got some error about it and now I have to download NET Framework Version 1.1 to get that to work.

Thanks in advance-

__________________
Salska is offline  
Old 01-16-2005, 04:36 PM   #2
Registered Member
 
Join Date: Nov 2004
Posts: 108
OS: Windows Xp Pro


Quote:
Originally Posted by Salska
Hello I just got my new computer this christmas and I am having some probloms when I play the better grapic games usualy. For instance after playing The Lord of The Rings The Battle For Middle Earth for only a few minutes it freezes and I have to restart my computer. It has also froze on Doom 3 and Call of Duty. I dont really know all of my specs but I am using a Pentium 4 3.0ghz and an ATI Radeon 9600 XT 256mb and I have 512 mb of ram. If it really matters I can find out all of my specs and edit this post. I just downloaded the Catalyst Control center to get the latest drivers but I got some error about it and now I have to download NET Framework Version 1.1 to get that to work.

Thanks in advance-


1. Make sure you have the Latest Drivers for your ATI www.ati.com v4.12
2. Make Sure you have the LATEST chipset DRIVERS for your BOARD (this would make a MAJOR difference in performace)
3. make sure you have the LATEST PATCH for all your games. www.3dupdates.com or vist your game's Software company and download it from there.
4. make sure you have Proper Cooling for your System!! very very important.

let me know what's happen after you have tried this

-slick

__________________
notsobizzymofo is offline  
Old 01-21-2005, 02:36 AM   #3
Registered Member
 
Join Date: Aug 2003
Location: Wellingborough, Northamponshire, England
Posts: 348
OS: Windows 7 x86

My System

Send a message via MSN to jamie_Ridler
Also let us know what PSU you have, and how much W it gives.
__________________
jamie_Ridler is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 10:02 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts