Go Back   Tech Support Forum > Gaming Forum > PC Gaming Support

Rise and Fall civilization at war

This is a discussion on Rise and Fall civilization at war within the PC Gaming Support forums, part of the Tech Support Forum category. Hi, I've been trying to launch rise and fall but i failed all the time. First, it asked me to


Reply
 
Thread Tools Search this Thread
Old 08-02-2011, 10:39 AM   #1
Registered Member
 
Join Date: Aug 2011
Posts: 4
OS: win7



Hi, I've been trying to launch rise and fall but i failed all the time. First, it asked me to install additional libraries and i clicked OK, then a message appear "Application installed successfully. Reboot the computer to complete the installation. Continued?" No matter how many times I reboot the computer, once i launch the game, the same message always appear. Please help me.

__________________
Vuth is offline   Reply With Quote
Old 08-02-2011, 10:46 AM   #2
Registered Member
 
Join Date: Aug 2011
Posts: 4
OS: win7


Confused

Quote:
Originally Posted by Xpose View Post
Hello, i got a problem with Rise & Fall civilizations at war. i have innstalled it right and installed patch but problem is, when i try to start it i get a error or massage*

here it is.

Application installed succesfully. reboot the computer to complete the innstallation. Continue?

then i restarted my computer. when i try start the game again
it ask again
and tryed again
and asked again!.
can someone help me solve this ?
I have the same problem as X-pose. Please Help. the game asked me the reboot again and again. HELP :S

__________________
Vuth is offline   Reply With Quote
Old 08-02-2011, 02:51 PM   #3
Team Manager, Gaming
 
RockmasteR's Avatar
 
Join Date: Aug 2007
Location: Lebanon
Posts: 7,194
OS: Windows 7 SP1 64 bit

My System


Hello and welcome to TSF
it seems that the game has issues in Windows 7 because the game installs starforce (starforce is an antipiracy software that is used in several games)

so try this:

download revo uninstaller from my sig and use it to uninstall the game and remove all its remains from the HDD and from the registry when prompted
reboot.

install the game and run it, it will ask you to install starforce driver and then reboot, when you reboot download and install the Starforce driver that is compatible with Windows 7:

http://www.star-force.com/support/sfdrvup.zip

reboot your PC and try the game
__________________



!!Please do not PM me about Tech Support!!
RockmasteR is offline   Reply With Quote
Old 08-03-2011, 11:52 PM   #4
Registered Member
 
Join Date: Aug 2011
Posts: 4
OS: win7



I tried that many times but it still didn't work. What should I do? please help
__________________
Vuth is offline   Reply With Quote
Old 08-05-2011, 02:01 AM   #5
Team Manager, Gaming
 
RockmasteR's Avatar
 
Join Date: Aug 2007
Location: Lebanon
Posts: 7,194
OS: Windows 7 SP1 64 bit

My System


have you updated the game to the latest patch?
also try running the game in compatibility with Windows XP SP3
to do that
right click on the game's shortcut -> properties -> Compatibility

under compatibility mode choose:
tick the box: run this program in...
choose Windows XP SP3
and click OK
__________________



!!Please do not PM me about Tech Support!!
RockmasteR is offline   Reply With Quote
Old 08-10-2011, 07:42 PM   #6
Registered Member
 
Join Date: Aug 2011
Posts: 4
OS: win7



I used compatibility mode Windows XP SP3. But i don't think I had the latest update patch. How can i find that? and what should I do after that?
__________________
Vuth is offline   Reply With Quote
Old 08-31-2011, 11:29 AM   #7
Registered Member
 
Join Date: Aug 2011
Posts: 1
OS: windows 7



I'm having a similar problem with RaF except that it repairs it self when rebooting and ends up deleting itself, not managed to try whats been recommended on here yet. But as for patches Strategy Informer is useful for patches. Not sure if anyone else would recommend it though or if it will work but its possibly worth a try. You can manually install a patch onto the game files if you can't install the patch updates through the game. Usually there is details on how you would install the patch manually. It may require a little research into it. If i find a definite way to get RaF working i will make sure to send you the details on it. Hope i've been of some help to you, sorry about my little essay.

__________________
l16m is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rise & Fall civilizations at war Problem :S
Hello, i got a problem with Rise & Fall civilizations at war. i have innstalled it right and installed patch but problem is, when i try to start it i get a error or massage* here it is. Application installed succesfully. reboot the computer to complete the innstallation. Continue? then i...
Xpose Game Installation Support 14 04-22-2011 02:50 AM
Rise and Fall Installation Windows 7
I just got a new win 7 emachine and i cant install Rise and Fall civilizations at war. If i try to use the discs i get errors saying that files are missing. I tried installing the discs first and it worked but when i reboot the computer( i have to to play the game) the game gets deleted. I tried...
Chugar45 PC Gaming Support 0 03-24-2011 03:53 PM
Rise & Fall Civilizations At War - Can't Play
Hi all, I have had this game fo a few years now but the pc I had was far too poor to run it, so after upgrading pc's I blew the dust off the box and gave it a whirl. The game had issues trying to install especially with creating additional libraries, so patched it up and made sure I had most of the...
Cao_Monk Game Installation Support 2 03-04-2011 04:27 AM
Rise & Fall: Civilizations at War
Rise and fall civilization at war finished downloading and asked to reboot the windows7 system and during the reboot windows fixer pulled up and said windows could not pull up and when it does the game is uninstalled what do i do? Thank you fatman12
fatman12 PC Gaming Support 2 01-28-2011 06:30 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 06:09 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts