Go Back   Tech Support Forum > Microsoft Support > Microsoft Office support

Office XP “open file” very slow

This is a discussion on Office XP “open file” very slow within the Microsoft Office support forums, part of the Tech Support Forum category.


Closed Thread
 
Thread Tools Search this Thread
Old 11-11-2003, 02:44 AM   #1
Registered Member
 
Join Date: Oct 2003
Posts: 37
OS: windows xp



Office XP open file

I have a strange problem With Office XP. When clicking on open file Office takes more than a minute to open the window. This happens only when the computer is NOT connected to my LAN. When it is connected everything just works fine. It is a new computer with a fresh install op windows xp and office xp. I think that I do have the same settings than on my notebook and my old PIII 500 where it works perfectly. It seems to me like it would be looking for some network places. So the problem must be some settings of some kind, but I do not know where to look anymore.

I am thankful for any help

__________________
stevejungen is offline  
Old 11-11-2003, 03:41 PM   #2
Registered Member
 
Join Date: Sep 2003
Location: Hertfordshire England
Posts: 126
OS: Win 9x/2K/XP


Just an idea. In Word go to Tools, Options, File location. Have a look and see what path the Documents are on, is it local disk (C)or is it some other network path (mapped drive or \\ path)

__________________
SuperCub is offline  
Old 11-12-2003, 12:45 AM   #3
Registered Member
 
Join Date: Oct 2003
Posts: 37
OS: windows xp


Thanks but I found the solution myself. So here is the problem: The problem is related to the recent history folder of windows. It must be a bug of some kind because the problem appears on different machines with different hardware but all with Office XP and Windows XP (with default settings). It appears even on my fresh install. Symptoms are slightly different. On my notebook I get the error message not enough memory when trying to open the history even with just one file in it. On my new computer the history opens, but takes as long as the open dialog to do so.
And here is the solution: just disable the recent history and everything runs smoothly.
To do so, open your registry and find the key below.
Create a new DWORD value, or modify the existing value called 'NoRecentDocsHistory' set the value to equal '1' to enable the restriction.
Exit your registry, you may need to restart for the changes to take effect.
Registry Settings
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Value Name: NoRecentDocsHistory
Data Type: REG_DWORD (DWORD Value)
Value Data: (0 = disable restriction, 1 = enable restriction)

You may try if this works for you simply by deleting the folder: D:\Documents and Settings\user_name\Application Data\Microsoft\Office\Recent
If that helps just do the modifications above for a permanent solution.
__________________
stevejungen is offline  
Old 12-01-2003, 03:02 PM   #4
Registered Member
 
Join Date: Dec 2003
Posts: 3
OS: XP


I had this problem of taking ages to bring up the File->Open dialog. In my case it also affected other non-Office apps including Visual Studio 2003.

The solution of deleting the contents of that ...\Microsoft\Office\Recent directory worked, at least for now.

Hard to imagine why that directory, which ostensibly is used only by Office, would affect Visual Studio, but apparently it did.

Note that emptying that directory doesn't affect the recent files that appear in the 'File' menu of the XP apps. It does affect the 'My Recent Documents' that appear when you click on the 'My Places' bar within the file-open dialog.

Also note that I found files up to a year old in that directory, which doesn't fit my definition of 'recent' :-)
__________________
wirwin is offline  
Old 05-15-2007, 01:17 PM   #5
Registered Member
 
Join Date: May 2007
Posts: 1
OS: XP SP2



After having this same nagging problem and reading various posts about "slow" Office XXXX "open-file" issues, I'd like to offer this possible solution. Have not tested it extensively yet, but seems to have improved the "delay/stalling."

Two machines, #1 and #2, on a local network (Gig Switch)

- #1: XP SP2 with Office 2003 (main machine)

- #2: XP SP2 with shared drive configured
* video/development machine
* shared drive configured by standard share and NOT "simple share"

PROBLEM:
- if machine #2, with shared drive is off (not in use)
- if machine #2 in online, then "open file" is fast and behaves normally
- machine #1 will display: "Could Not Connect Networked Drive" (normal)
- "Open File" to default local location is fast, but:
- "Open File" stalls/delays when navigating to OTHER directories

POSSIBLE SOLUTION:
- although the KB below is intended for networked shares, it seems to have help accessing local data by setting DWORD to "0"
- adding the following registry key reduced initial "other directory" delay to <10sec
- subsequent navigation to "other directories" is fast

An Office program is slow or may appear to stop responding (hang) when you open a file from a network location
http://support.microsoft.com/kb/833041

WORKAROUND
To work around this behavior, add the EnableShellDataCaching value to the Microsoft Windows registry.

To do this, follow these steps:
1. Close your Office programs.
2. Click Start, and then click Run.
3. In the Open box, type regedit, and then click OK.
4. Locate, and then click to select the following registry key:

Office 2003
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

Office 2007
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find

5. After you select the key that is specified in step 4, point to New on the Edit menu, and then click DWORD Value.
6. Type EnableShellDataCaching, and then press ENTER.
7. Right-click EnableShellDataCaching, and then click Modify.
8. In the Value data box, type 1, and then click OK.
Note: Any non-zero number in the Value data box will turn on caching.
A zero number or blank (default) will turn off caching.
9. On the File menu, click Exit to quit Registry Editor.


ADDITIONAL INFO:
- appears this has been a known issue by Microsoft:

The program stops responding when you try to open or to save a file in an Office 2002 program,
in an Office 2003 program and in an Office 2007 program
http://support.microsoft.com/kb/313937
__________________
bichi is offline  
Old 07-04-2007, 12:57 PM   #6
Registered Member
 
Join Date: Jul 2007
Posts: 1
OS: XP



I came across a machine with a similar issue and I went through many threads on many forums trying a whole ton of different fixes including those listed here. Plus running "repair" and "reinstall" on Office 2003 didn't fix it either.

Symptoms:
File -> Open would hang for 1+ minutes and after that it would work fine. You only had to do this in one Office app and the symptoms would disappear for all office apps including Outlook's attach a file to an e-mail. If you closed all office apps the next time you opened the problem would happend the first time again.

Note that opening Word in safe mode eliminated the symptoms. (Hold ctrl key while opening Word 2003)

Last Resort Solution:
WARNING! Backup Registry Settings First! Don't blame me if you pooch it!
You may need the install disks for this but in my case I didn't.
What finally worked for me was to delete the following entire registry key branches:
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0
HKEY_USERS\.DEFAULT\Software\Microsoft\Office\11.0

After deleting these keys and attempting to open Word I got a "installing office" message so it had to do some setting up. Outlook also had to do a little automatic rebuilding as well but everything came back up and the problem was gone.
__________________
Daystrom is offline  
Old 09-11-2008, 04:25 PM   #7
Registered Member
 
Join Date: Sep 2008
Posts: 3
OS: XP Pro SP3; Server 2003 R2; Server 2008; Small Business Server Editions Also



I bet I have the solution for all of you... And you're going to crap your pants.

I found it by accident. After doing EVERYTHING that everyone else was trying and finding that nothing was working, I decided to be a jerk and look for her last file that she was working on... So I changed the order the documents were sorted in... Ordered them by Date. WOAH! That was fast! What the???? Then I sort the order by name again. BOOM! LIGHTNING FAST! What the heck is going on???

I closed the "Open Dialog" and opened it again... INSTANTANEOUS OPEN!

Unfrigginbelievable. This is my first post on this site. I hope it helps some, if not all of you.

(I also had them upgrade from Office XP to Office 2003 thinking that would've fixed it and it did not.)

Thanks!
__________________
PCFixerGuy is offline  
Old 09-15-2008, 06:32 PM   #8
Registered Member
 
Join Date: Feb 2006
Posts: 40
OS: XP Pro



It sounds like a great solution but how exactly do I do this?
__________________
Funbrit is offline  
Old 09-16-2008, 06:50 AM   #9
Registered Member
 
Join Date: Sep 2008
Posts: 3
OS: XP Pro SP3; Server 2003 R2; Server 2008; Small Business Server Editions Also



Quote:
Originally Posted by Funbrit View Post
It sounds like a great solution but how exactly do I do this?
When you go to the "Open File" dialog window (let it sit there for as long as it needs to for the files to load) and right click anywhere that there is NOT a file... (the background if you will). The little menu pops up, mouse over "Arrange Icons by" and then select "Name" from the pop-out menu.


Sorry I didn't mention this in the last post.
__________________
PCFixerGuy is offline  
Old 09-18-2008, 07:15 AM   #10
Registered Member
 
Join Date: Feb 2006
Posts: 40
OS: XP Pro



OK thanks, I'll try that.
__________________
Funbrit is offline  
Old 07-16-2009, 03:21 PM   #11
Registered Member
 
Join Date: Jul 2009
Posts: 4
OS: xp



PCFixerGuy: You rock! I've been dealing with this for months and finally gave up on it. Switching the Arrange By totally helped.
__________________
sammy-e is offline  
Old 07-21-2009, 10:25 AM   #12
Registered Member
 
Join Date: Jul 2009
Posts: 4
OS: xp



Nevermind, still a problem. Still, I have hope, trying a few diff combinations...
__________________
sammy-e is offline  
Old 07-23-2009, 10:29 AM   #13
Registered Member
 
Join Date: Sep 2008
Posts: 3
OS: XP Pro SP3; Server 2003 R2; Server 2008; Small Business Server Editions Also



Quote:
Originally Posted by sammy-e View Post
Nevermind, still a problem. Still, I have hope, trying a few diff combinations...
Alright, so sometimes it may revert back to the old setting.

If you open my computer, and go to the C: drive. Then go to View - Details and then Sort the folder by Name A - Z.

(READ EVERYTHING BEFORE PERFORMING ACTIONS)

Once sorted, Click Tools > Folder Options > Click 'View' Tab > Select: "Apply to all folders" at the top. Then click OK.

Now before you do that, please keep in mind that this is how ALL of your folders are going to look on the entire computer including the my pictures folder. But you can go back and individually make folders into the thumbnail view afterwards. Just a small price to pay for getting the Open Dialog to open faster... :o)

So this is really the only solution left that I can think of. You probably sorted the My Documents folder but then opened something from the desktop, so now the default folder is the desktop for the Open Dialog and that one has the same issue.

Give it a shot, let me know.

Thanks!
__________________
PCFixerGuy is offline  
Old 07-27-2009, 09:34 AM   #14
Registered Member
 
Join Date: Jul 2009
Posts: 4
OS: xp



PCFixerGuy:

Thanks for the help, I def'y appreciate the effort. Unfortunately though I am still stuck with the long pause, even after arranging at the C: drive level and applying to all folders with the folder options. I'll continue messing around with it on occasion and post back if I come up with a solution. I friend suggested it might be something in my profile.

If you have any other suggestions, feel free to lob them in my direction. Thanks again.
__________________
sammy-e is offline  
Old 08-04-2009, 12:41 AM   #15
Registered Member
 
Join Date: Aug 2009
Posts: 4
OS: xp



Quote:
Originally Posted by stevejungen View Post
Office XP open file

I have a strange problem With Office XP. When clicking on open file Office takes more than a minute to open the window. This happens only when the computer is NOT connected to my LAN. When it is connected everything just works fine. It is a new computer with a fresh install op windows xp and office xp. I think that I do have the same settings than on my notebook and my old PIII 500 where it works perfectly. It seems to me like it would be looking for some network places. So the problem must be some settings of some kind, but I do not know where to look anymore.

I am thankful for any help
__________________
mohan shimpi is offline  
Old 09-22-2009, 01:17 PM   #16
Registered Member
 
Join Date: Jul 2009
Posts: 4
OS: xp



PCFixerGuy:

Just wanted to say thanks. After walking through your instructions a couple of times, I works just fine most of the time. It doesn't seem to "take" everywhere, but it is definitely improved. Thanks.
__________________
sammy-e is offline  
Old 07-12-2010, 02:38 PM   #17
Registered Member
 
Join Date: Jul 2010
Location: Brussel
Posts: 1
OS: windows 7


Send a message via Skype™ to perco

I there
For info I had a similar problem with open a word document on the network mapping this action take a lot of times before i can select a document.
First reflex open dialogue "%1", reinstall word, look security of mapping, network problems, delay in de regedit.....
I have do everithing that i read here and this is my solution.
It was a lot of corrupt document like ~xxx.doc and xx.tmp files in the lot of folder and subfolders.
I have deleted an direct after that everithing is ok
Thanks for the tips but in my case i never had thing about corrupt files
This my solution
Good luck
Perco
__________________
perco is offline  
Old 10-31-2010, 05:15 AM   #18
Registered Member
 
Join Date: Oct 2010
Posts: 1
OS: XP sp3



I've had the same problem and occasionally, a problem with the normal.dot. Turned out the corrupt file that Perco mentioned in his post above was normal.dot. These are the instructions I followed from http://www.internetfixes.com/readers...ns/IF01959.htm :::

Create a New Normal.dot File For Microsoft Word.

Follow these steps to temporarily rename the Normal.dot template to determine if it is the cause of the problem:

1. Close all programs.
2. Click Start, and then click Search.
3. Click All files and folders.
4. In the All or part of the file name box, type Normal.dot.
5. In the Look In box, click My Computer.
6. Click Search Now.
7. For each instance of Normal.dot, right-click the file, click Rename, and then type OldNormal.dot.
8. Close Search Results, and then start Word.

If Word starts without the error message, the cause of the problem was a corrupted Normal.dot. When Word starts, Word creates a new Normal.dot to replace the renamed file. If you customized your old Normal.dot, you must re-do all the modifications to restore your favorite options.

After doing the above, I went into my start menu and deleted all recent documents. Ran CCleaner to take out the trash. Restarted my computer.

I opened Word from Start - Programs - MS Office. Immediately, a new doc popped up.
I went into Page Setup and customized it for my use, then clicked Default so my settings would be saved in the new normal.dot.

It worked fine for me, cleaned up my normal.dot problem, and fixed all of the delays in opening Office docs in both my personal docs folder and on the desktop. Hope this helps someone.

Larry

__________________
larkru is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 09:35 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts