Go Back   Tech Support Forum > Microsoft Support > Microsoft Office support

Excel - not a valid win32 application

This is a discussion on Excel - not a valid win32 application within the Microsoft Office support forums, part of the Tech Support Forum category. I am unable to open an xlsx file even though I have Excel 07 installed. The error message I get


Closed Thread
 
Thread Tools Search this Thread
Old 03-20-2008, 02:54 PM   #1
r4y
Registered Member
 
Join Date: Mar 2008
Posts: 1
OS: Vista



I am unable to open an xlsx file even though I have Excel 07 installed. The error message I get is "filename" is not a valid win32 application.

I checked the vista file type association and its says xlsx files are associated with "Microsoft Office 2007 Component" instead of "Microsoft Excel 2007" like the previous machines I had. Even though I chose "Microsoft Excel 2007" as the default program, the file type association still says "Microsoft Office 2007 Component."

Also when I create a new excel file, save it, then try to open it, I get the same error message. If I save the file type as "Excel 97-2003" it works fine, but not when I try to save file type as "Excel Workbook."

I tried to repair and reinstall Office but I still can not fix it. Any help would be appreciated.

__________________
r4y is offline  
Old 03-21-2009, 10:43 AM   #2
Registered Member
 
Join Date: May 2007
Posts: 7
OS: server 2003



Did you ever fix this problem? I seem to have the same problem too.

__________________
brian04 is offline  
Old 03-21-2009, 03:33 PM   #3
Team Manager, Articles
Analyst
Rangemaster, TSF Academy
 
Glaswegian's Avatar
 
Join Date: Sep 2005
Location: Glasgow
Posts: 38,522
OS: Win XP Pro SP3 / Win 7 Pro

My System


Hi

This is an old issue and the fix was released in June last year - see here

http://support.microsoft.com/?kbid=952709
__________________
Iain - Defender of the Haggis and all things Scottish.
I don't help by PM - post in the Forums.



PC Safety & Security::PC running a bit slow?::Photographers Corner
Glaswegian is offline  
Old 03-23-2009, 03:49 PM   #4
Registered Member
 
Join Date: May 2007
Posts: 7
OS: server 2003



I already have this update installed. Any other suggestions?

Thanks
__________________
brian04 is offline  
Old 03-31-2010, 12:58 PM   #5
Registered Member
 
Join Date: Mar 2010
Posts: 6
OS: Vista



Is anyone still looking for the solution to this problem? I have figured it out!
__________________
ddb1955 is offline  
Old 03-31-2010, 01:41 PM   #6
Team Manager, Articles
Analyst
Rangemaster, TSF Academy
 
Glaswegian's Avatar
 
Join Date: Sep 2005
Location: Glasgow
Posts: 38,522
OS: Win XP Pro SP3 / Win 7 Pro

My System


Quote:
Originally Posted by ddb1955 View Post
Is anyone still looking for the solution to this problem? I have figured it out!
Hi

Would you be kind enough to share your solution in order that others might benefit?
__________________
Iain - Defender of the Haggis and all things Scottish.
I don't help by PM - post in the Forums.



PC Safety & Security::PC running a bit slow?::Photographers Corner
Glaswegian is offline  
Old 04-01-2010, 07:31 AM   #7
Registered Member
 
Join Date: Mar 2010
Posts: 6
OS: Vista


Thumbs Up

This fix is using Vista and IE explorer. Make sure you have a file saved on your computer that you want to open with Excel. I would suggest deleting Microsoft Office off your computer, then restarting your computer and reloading Microsoft Office and all the updates. Yes I kinow its time consuming but the end results are well worth being able to open an Excel .xlsx file with no hassle.

Next click start and go to your Control Panel. Make sure it is in the Classic View. Scroll down the page to the Folders Options Tab (or Icon). Open it up. Go to the View Tab under Hidden Files and Folders select the radio button for Show Hidden Files and Folders. Select OK and close. You can go back after the FIX and change this back.

Next: I alread had saved a .xlsx file on the desktop that I couldn't open with Excel in its present condition. Right click on the File and go to the bottom of the page to the word Properties. Left click on that. The List Properties will open up. Go down to the "Opens With ....... and select the Change Tab. Go down on this page to the Browse Tab (right hand side) and select that.

At the bottom of this page above the Open - Cancel Tab is a drop down window select this and choose All Files. Scroll down the folders tab to Microsoft Office (left hand side) and double click on it. Scroll down to a folder called Office 12 and double click on this. Scroll down on the right hand side of your page to the EXCEL icon. This will be located under a folder called "Envelope.DLL" and above a folder called "Excel.exe.manifest". Select the Excel Icon and hit the open tab. Close everything and your file will open right up!

ddb1955

__________________
ddb1955 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 02:16 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts