Go Back   Tech Support Forum > Microsoft Support > Internet Browsers and Email > Internet Explorer Forum

Internet Explorer is the only working browser...

This is a discussion on Internet Explorer is the only working browser... within the Internet Explorer Forum forums, part of the Tech Support Forum category. My little brother told me one day shortly after a Mozilla Firefox update that all my browsers stopped working. I


Closed Thread
 
Thread Tools Search this Thread
Old 02-05-2010, 10:22 AM   #1
Registered Member
 
Join Date: Jan 2010
Posts: 11
OS: xp



My little brother told me one day shortly after a Mozilla Firefox update that all my browsers stopped working. I checked it out and sure enough Mozilla, Opera, and Chrome all dont work, on the other hand Internet Explorer works. Can anyone give me any tips on how to fix this problem, thanks in advance.

__________________
chinikaylo is offline  
Old 02-05-2010, 11:22 AM   #2
TSF Enthusiast
 
tallin's Avatar
 
Join Date: Apr 2008
Location: Melbourne Victoria Australia
Posts: 983
OS: Windows XP/SP3 Windows 7 SP/1

My System


Have you got all these browsers installed on your computer? Mozilla, Opera, and Chrome, as well as IE?

Are Mozilla, Opera, and Chrome, all showing in Add and Remove?

Are there shortcuts for them all in your taskbar?

Are they all updated to the latest versions?

What happens when you click on the shortcuts of the three that do not work? Do they load? is there an error message?

More information would help us to help you.

kind regards,

__________________
tallin is offline  
Old 02-05-2010, 10:42 PM   #3
Registered Member
 
Join Date: Jan 2010
Posts: 11
OS: xp



I don't know what u mean by add or remove, but they are all updated. When I try to open it from the shortcut it says cannot load/connect depending on the browser
__________________
chinikaylo is offline  
Old 02-06-2010, 12:56 AM   #4
TSF Enthusiast
 
tallin's Avatar
 
Join Date: Apr 2008
Location: Melbourne Victoria Australia
Posts: 983
OS: Windows XP/SP3 Windows 7 SP/1

My System


Quote:
Originally Posted by chinikaylo View Post
I don't know what u mean by add or remove, but they are all updated. When I try to open it from the shortcut it says cannot load/connect depending on the browser
To find Add and Remove, please click on
  • Start - lower left corner of your desktop
  • Settings
  • Control Panel
  • Add and Remove
Scroll down to find Chrome, Mozilla, & Opera, in alphabetical order. Please tell me if they are all showing in your Add and Remove Applet.

Internet Explorer will be found in
  • Start
  • All Programs
  • Internet Explorer
Are you sure you are connected to the internet, it sounds to me you may not be when you try to open the three browsers that are not responding.

How can they be updated if they will not open for you. Are there any error messages that could help me research or reply to your questions?

When you reply, please give as much information as you can.

kind regards,
__________________
tallin is offline  
Old 02-06-2010, 07:04 AM   #5
Registered Member
 
Join Date: Jan 2010
Posts: 11
OS: xp



Yes, they are all in the add or remove list. I know they are updated bc I kept them up to date before this happened(about a month ago). And heres what it says in each of the browsers when I open them. Mozilla: Unable to connect, Firefox can't establish a connection to the server at en-us.start3.mozilla.com. Opera: Error! Could not connect to Remote Server. So it seems like they cant connect to the internet, idk why. IE works fine though. Oh and thanks for the help so far.
__________________
chinikaylo is offline  
Old 02-06-2010, 10:23 AM   #6
TSF Enthusiast
 
tallin's Avatar
 
Join Date: Apr 2008
Location: Melbourne Victoria Australia
Posts: 983
OS: Windows XP/SP3 Windows 7 SP/1

My System


Leaving IE alone as it works, I would firstly ask why you would need so many browsers installed?

I have only ever heard of folk using their browser of choice, in your case IE, and having a backup browser in case of an emergency. However I understand it is your choice, so let us see if we can get at least one other working for you by doing the following.
  • Download and install Revo uninstaller to your desktop
  • Run it, follow the prompts to uninstall each of the non working browsers one by one
  • Reboot your computer
Choose one of the three to download and install making sure you do not choose added tool bars or anything other than the required browser offered. After installation of the chosen browser, run it, go to the Help tab, scroll to Check for Updates to make sure you have the latest version.

My alternate browser is IE 8.0, but for everyday use I have CometBird which I can highly recommend to you as a working browser of some standing.

Please read about Revo on the link offered so you have a working knowledge why I am suggesting you use it instead of your Add and Remove applet.

Let me know how you proceed.

kind regards,
__________________
tallin is offline  
Old 02-09-2010, 05:26 PM   #7
Registered Member
 
Join Date: Jan 2010
Posts: 11
OS: xp



It stil didnt work, I couldnt check for the latest version bc it cant connect to the internet(althoough it is the latest)
__________________
chinikaylo is offline  
Old 02-09-2010, 05:53 PM   #8
TSF Enthusiast
 
tallin's Avatar
 
Join Date: Apr 2008
Location: Melbourne Victoria Australia
Posts: 983
OS: Windows XP/SP3 Windows 7 SP/1

My System


Did you follow my last post and uninstall the three browsers using Revo uninstaller.

More information is better than not enough so we can help you further.

kind regards,
__________________
tallin is offline  
Old 02-10-2010, 06:40 PM   #9
Registered Member
 
Join Date: Jan 2010
Posts: 11
OS: xp



Yes, i followed the last post exactly. Same problem as before.
__________________
chinikaylo is offline  
Old 02-10-2010, 06:48 PM   #10
TSF Enthusiast
 
tallin's Avatar
 
Join Date: Apr 2008
Location: Melbourne Victoria Australia
Posts: 983
OS: Windows XP/SP3 Windows 7 SP/1

My System


Quote:
Originally Posted by chinikaylo View Post
Yes, i followed the last post exactly. Same problem as before.
Are you Windows updates current?
__________________
tallin is offline  
Old 02-10-2010, 10:40 PM   #11
Registered Member
 
Join Date: Jan 2010
Posts: 11
OS: xp



Yes it is up to date, idk what the problem is, I turned my firewall off completely just to check and that didn't help s idk

__________________
chinikaylo is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 09:56 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts