Go Back   Tech Support Forum > Smart Devices > Smart Devices | General Topics

samsung galaxy s2

This is a discussion on samsung galaxy s2 within the Smart Devices | General Topics forums, part of the Tech Support Forum category. my samsung galaxy s2 keeps turning itself off. I have cleaned the battery and mobile etc It keeps turning off


Reply
 
Thread Tools Search this Thread
Old 06-25-2012, 06:58 AM   #1
Registered Member
 
Join Date: May 2012
Posts: 266
OS: Windows 7 Service Pack 1



my samsung galaxy s2 keeps turning itself off.

I have cleaned the battery and mobile etc

It keeps turning off and i cant turn it on i have to take out the battery and put it back in. Then i can turn it on.

I really need help its getting annoying taking my battery in and out
My firmwire is uptodate
I dont know what to do


Cheers

__________________
redsolja is offline   Reply With Quote
Old 06-26-2012, 04:02 AM   #2
Registered Member
 
Join Date: May 2012
Posts: 266
OS: Windows 7 Service Pack 1


Is there anyone can help me

This problem is getting really annoying

Have i posted it in the right spot if not can yous move it

Thanks

Cheerz

Redsolja

__________________
redsolja is offline   Reply With Quote
Old 06-26-2012, 01:31 PM   #3
Moderator
- Hardware Team
- Articles Team
- Microsoft Support
 
Masterchiefxx17's Avatar
 
Join Date: Feb 2010
Location: Wisconsin, USA
Posts: 23,989
OS: Windows 7 64bit Professional (SP1), Windows 8.1 64bit

My System


Is the device locking up at all? Or overheating?
__________________
I recommend these:
Windows 7 & 8.1, Office 2013, Photoshop CS6, IE11
Security Essentials, Asus, Dell, Samsung,
Intel, NVidia, Xbox One, Android, Gigabyte
Masterchiefxx17 is offline   Reply With Quote
Old 06-26-2012, 01:37 PM   #4
Certifiable Lazy Bum
 
sobeit's Avatar
 
Join Date: Nov 2007
Location: NEAR
Posts: 16,525
OS: win7pro/mint17


Send a message via Yahoo to sobeit

if you upgraded to ics then maybe you have an app that is not compatible with it. Try disabling all of your apps and see if you still have the problem.
__________________
the truth is a three edged sword - your truth, my truth and the real truth.
sobeit is offline   Reply With Quote
Old 06-26-2012, 02:17 PM   #5
Registered Member
 
Join Date: May 2012
Posts: 266
OS: Windows 7 Service Pack 1


Quote:
Originally Posted by sobeit
if you upgraded to ics then maybe you have an app that is not compatible with it. Try disabling all of your apps and see if you still have the problem.
I have over 60 APPS lol so i have no idea which one. any ideas?
Do you want me to restore me mobile or?
__________________
redsolja is offline   Reply With Quote
Old 06-26-2012, 02:28 PM   #6
Certifiable Lazy Bum
 
sobeit's Avatar
 
Join Date: Nov 2007
Location: NEAR
Posts: 16,525
OS: win7pro/mint17


Send a message via Yahoo to sobeit

Quote:
Originally Posted by redsolja View Post
I have over 60 APPS lol so i have no idea which one. any ideas?
Do you want me to restore me mobile or?
as I said, disable every single one of them and see if the problem is solved. If the problem is solved then turn a couple on at a time and see if the problen returns. It may take some time but you do want to solve the problem - dont you. It is not always easy.
__________________
the truth is a three edged sword - your truth, my truth and the real truth.
sobeit is offline   Reply With Quote
Old 06-26-2012, 03:32 PM   #7
Registered Member
 
Join Date: May 2012
Posts: 32
OS: windows 7, 64 bit service pack 1



Unless it was having these problems right out of the box, the best solution is to factory reset the device.
__________________
Kurticus is offline   Reply With Quote
Old 07-01-2012, 05:09 PM   #8
Registered Member
 
Join Date: May 2012
Posts: 266
OS: Windows 7 Service Pack 1


I restored my mobile back to out of the box. factory settings. The problem was the games ..thanks for your help.

Know i have to watch what games im downloading if it crashes my mobile i would know the game is not good.
__________________
redsolja is offline   Reply With Quote
Old 07-12-2012, 05:50 AM   #9
Registered Member
 
Join Date: May 2012
Posts: 266
OS: Windows 7 Service Pack 1


The problem is back. Its not.my apps.
__________________
redsolja is offline   Reply With Quote
Old 07-12-2012, 09:59 PM   #10
Registered Member
 
Join Date: May 2012
Posts: 266
OS: Windows 7 Service Pack 1


My problem is back. I have only 5 apps downloaded on go my phone. And my phone keeps turning off i cant turn it on intil i take the battery out. When i turn it on i loose around 5 per cent of my battery. Look at the pic i uploaded.



Click image for larger version

Name:	ForumRunner_20120713_145849.png
Views:	90
Size:	42.9 KB
ID:	112519
__________________
redsolja is offline   Reply With Quote
Old 07-23-2012, 09:20 AM   #11
Registered Member
 
Join Date: Jul 2012
Posts: 53
OS: Windows 7 SP1


Seems like an upgrade is not fully successful. Go for a repair via pc.
__________________
aureatron is offline   Reply With Quote
Old 07-24-2012, 03:54 AM   #12
Registered Member
 
Join Date: Jul 2012
Posts: 7
OS: xp



I had the same problem, set it to factory settings. It should fix the problem:)
__________________
Bmike80 is offline   Reply With Quote
Old 07-24-2012, 11:50 AM   #13
Registered Member
 
Join Date: May 2012
Posts: 266
OS: Windows 7 Service Pack 1


After doing that my mobile keeps turning off and cant turn back on anless i take the battery out and put it back in..

it that a mobile problem?
__________________
redsolja is offline   Reply With Quote
Old 09-29-2012, 10:12 PM   #14
TSF Enthusiast
 
BrentC's Avatar
 
Join Date: May 2007
Location: British Columbia, Canada
Posts: 787
OS: Vista Home Premium Win7 Home Premium SP1 Debian



Have you tried going to your settings app and setting the time before the phone shuts off?

__________________
BrentC is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 12:18 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts