Go Back   Tech Support Forum > Networking Forum > Networking Support

windows 7 can't access XP - network path not found

This is a discussion on windows 7 can't access XP - network path not found within the Networking Support forums, part of the Tech Support Forum category. Hi, Ever since upgrading my Vista SP1 machine to Win 7, it can't access XP machines on my network. I


Reply
 
Thread Tools Search this Thread
Old 08-22-2009, 05:42 PM   #1
Registered Member
 
Join Date: Aug 2009
Posts: 4
OS: windows 7



Hi,

Ever since upgrading my Vista SP1 machine to Win 7, it can't access XP machines on my network.

I have 2 XP systems and one Vista SP1 system on a network with the Win 7 system.

Everything works except the Win 7 system cannot access the XP systems. It can see them in the networks folder, but double-clicking on one of the XP systems yields the message "Windows cannot access \\server" and if I get the additional info it says the network path was not found.

Win 7 can access the Vista system fine.

Win 7 system can ping the XP systems and remote desktop works fine.

I have seen a dozen questions like this one, but none of the solutions are working for me.

Tantalizing fact is that twice, I was able to access an XP machine, but after I closed and reopened it, i got the "cannot access" message again. Makes me think a service is stopping? All the required ones I know about are running...

Any help would be much appreciated!

Thanks,
Dave

__________________
dave_k is offline   Reply With Quote
Old 08-22-2009, 07:55 PM   #2
Registered Member
 
TechSOS's Avatar
 
Join Date: Nov 2008
Location: Phoenix
Posts: 36
OS: XP service pack 3



As far as I know, Windows 7 will be cut of from XP compatibility (Just like Vista has been for a lot of programs, however). Win 7 is expected to be the new XP, just like Vista is known to be like the ME (Multiple Errors OS, jk). The full version of win7 has not been release yet and Im sure they are working towards many bugs. Since its only a Release Candidate so far... im afraid there is not going to be much for people to do in this case. And to top it off, most have never seen Windows 7 with their own eyes to begin with.

__________________
TechSOS is offline   Reply With Quote
Old 08-23-2009, 06:24 AM   #3
Registered Member
 
Join Date: Aug 2009
Posts: 4
OS: windows 7



Thanks for the reply TechSOS. But Win 7 is released now, and I have a released version (Ultimate, 32-bit). Also, I am quite sure it is intended to be compatible network-wise with XP.

Regards,
Dave
__________________
dave_k is offline   Reply With Quote
Old 08-23-2009, 07:32 AM   #4
Registered Member
 
polishpaul's Avatar
 
Join Date: Oct 2008
Location: Warsaw, Poland / Newark, DE USA
Posts: 169
OS: WIN: XP, XP64, Vista64, Server 2003, Server 2008, 95 (for old games). Linux: vaious flavors


Send a message via AIM to polishpaul Send a message via Yahoo to polishpaul

Dave, have you tried to disable windows firewall (not sure if this covers the advanced part too?). See if you can drop that and test the connection again.
__________________
polishpaul is offline   Reply With Quote
Old 08-23-2009, 01:35 PM   #5
Registered Member
 
Join Date: Aug 2009
Posts: 4
OS: windows 7



Oh, sorry, I didn't give enough info... I tried disabling firewall (only have Windows firewall installed on any of them), uninstalled antivirus, tried simple and password-protected sharing, made sure all have same workgroup (and changed it too), restarted everything, ... :)

Thanks,
Dave
__________________
dave_k is offline   Reply With Quote
Old 08-23-2009, 07:35 PM   #6
Registered Member
 
Join Date: Aug 2009
Location: FL
Posts: 68
OS: Windows Vista Home Premium 64 bit SP1



I would suggest checking your TCP/IP settings on versions 4 and 6 and making sure NetBIOS is turned on. XP uses this for file sharing, but Vista and 7 do not have it enabled by default. I haven't used 7 yet, so I can't guarantee this will work, as what they say may be true and TCP/IP version 4 and/or NetBIOS may have been cut out of 7 completely. It's worth checking out, though.
__________________
jonquilmcd is offline   Reply With Quote
Old 08-24-2009, 06:32 AM   #7
Registered Member
 
Join Date: Aug 2009
Posts: 4
OS: windows 7



Good idea. Windows 7 does have tcp/ip 4 and 6. I couldn't find any settings for netbios in the ver 6 properties, but in ver 4 properties > general tab > advanced button > wins tab there is a netbios setting. It was set on default: "Use NetBIOS setting from the DHCP server. If static IP address is used or if the DHCP server does not provide NetBIOS setting, enable NetBIOS over TCP/IP."

I changed it to "Enable NetBIOS over TCP/IP". (The third option is "Disable NetBIOS over TCP/IP".) Restarted though it didn't say I needed to. But still can't access XP machines. :(

Thanks for the idea!
Dave
__________________
dave_k is offline   Reply With Quote
Old 08-24-2009, 09:22 AM   #8
Registered Member
 
Join Date: Aug 2009
Location: FL
Posts: 68
OS: Windows Vista Home Premium 64 bit SP1



Ok, I couldn't remember if it was in the version 6 properties or not. I do know I had the same problem when sharing with a Linux machine that was using Samba for file sharing with Windows and turning on NetBIOS was what fixed it. I'm sorry to hear that it didn't fix the issue for you. Without having used 7 myself I can't really speculate any further on what could be going on.

Alternatively, if you just so happen to be using wireless connections you can try setting up an ad-hoc network between machines. That may get you past the file sharing problem, although you won't have internet access while using it if you rely completely on the wireless connections.
__________________
jonquilmcd is offline   Reply With Quote
Old 01-31-2010, 07:21 PM   #9
Registered Member
 
Join Date: Jan 2010
Posts: 1
OS: windows 7 Pro x64


Suprised

SOLUTION - test by disabling XP's firewall to see if it resolves the problem.

To disable XP firewall: Click Start, click Run, type Firewall.cpl, and then click OK, select the Off (not recommended) radio button, OK.

If this solves the problem, you may make an exception easily by clicking the Exceptions tab (inside windows firewall window from above), click Add Port, write name of computer for exception, enter port number (I used 23), click Change scope..., select custom list radio button, enter ip address of the computer you are making the exception for (see below if you are unsure how to do this), click OK, OK, OK.

To find the IP address of a windows computer: Click Start, click Run, type cmd, and then click OK. The command prompt window opens. In the command prompt type ipconfig. The ip address is shown above the subnet mask. Do not try to use www.whatismyip.com!

If that doesn't work you can also try this to enable NetBIOS:

1. Open the Network Connections folder.
To do this I used Start -> My Network Places -> View Network Connections (located on left under network tasks)
2. Right click the local area network connection and click Properties.
3. Double click Internet Protocol (TCP/IP) from the list.
4. Click Advanced.
5. Click WINS.
6. Click the Enable NetBIOS Over TCP/IP button.


Hope this works for you!!
__________________
OITGUY is offline   Reply With Quote
Old 02-04-2010, 02:19 PM   #10
Registered Member
 
Join Date: Feb 2010
Posts: 1
OS: XP



I had this problem with my Home Edition of Windows 7 and XP home.

Follow this link and perform the registry change on the XP machine. It fixed my problem immediately after a reboot of the XP.

http://support.microsoft.com/kb/913628

Pingboy...
__________________
Pingboy is offline   Reply With Quote
Old 07-15-2010, 05:35 AM   #11
Registered Member
 
Join Date: Jul 2010
Posts: 1
OS: Windows 7 Home Premium



Thanks for this solution. I have been wrestling with this problem for ages, so it's quite a relief to finally get it working.

__________________
Wolf25 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 08:45 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts