Go Back   Tech Support Forum > Microsoft Support > BSOD, App Crashes And Hangs

BSOD - dxgkrnl.sys

This is a discussion on BSOD - dxgkrnl.sys within the BSOD, App Crashes And Hangs forums, part of the Tech Support Forum category. Hello all, I would appriciate any help on this matter becouse i'am out of ides. I have BSOD at random,


Closed Thread
 
Thread Tools Search this Thread
Old 10-13-2011, 11:25 AM   #1
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



Hello all,

I would appriciate any help on this matter becouse i'am out of ides.

I have BSOD at random, mostly playing games, but sometimes even if the computer is Idle.

Sometimes i can play for hours with no problems and then after starting the same game again after a while, or even after a few days, i have BSOD at random at any point of the game. There is no rule wehn BSOD will happen.

I have check my temperatures and they are OK.
I have done memtest, video card was teste by me and by proffesionals, as was CPU and MB...

I've installed all the latest drivers, and before installing them, i have unistalled the old ones.


I have in the attachemt my dump files...

my specs are:
video card: ati radeon hd 4850 x2
RAM: 4GB kingmax 800mhz
cpu: amd phenom 9600 quad-core 2.31 GHz
MB: ga-ma90fx-dq6
Power: Corsair tx850 v2
OS: win 7 64 bit
DX: 10.1

I've done stress test, and every kind of test i colud think of..they all passed...
I'am new to dump files...so maybe it is problem in some drivers...i don't know... i hope you can help me...
i'am still just a noob :-(

Thank you
Attached Files
File Type: zip Dump.zip (59.9 KB, 93 views)

__________________
Sarmica is offline  
Old 10-14-2011, 09:19 AM   #2
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



just had onther one..this time dueo to the dxgmms1.sys...

__________________
Sarmica is offline  
Old 10-14-2011, 05:24 PM   #3
TSF Team Emeritus
Microsoft MVP
 
usasma's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2009
Location: Southeastern CT, USA
Posts: 7,450
OS: Win7



NOTE: I have severe eye problems. If I do not respond to your postings, please PM another staff member for assistance.

NOTE: Please provide the following information for a more detailed response: http://www.techsupportforum.com/foru...ta-452654.html

The one uploaded dump file shows a STOP 0x116 error in your ATI drivers. Please follow the directions in this post to troubleshoot STOP 0x116 errors: STOP 0x116: VIDEO_TDR_ERROR troubleshooting - Windows 7 Forums

You have the troublesome sptd.sys driver installed - this usually belongs to Daemon Tools or the Alcohol % software. Please uninstall the program, then use this free tool to ensure that the troublesome sptd.sys driver is removed from your system: DuplexSecure - FAQ

You also have older drivers on your system that could be causing problems, please update these drivers (pay particular attention to those highlighted in RED):
OLDER DRIVERS PRESENT IN THE DUMP FILES
- Create a System Restore Point prior to doing any of this. DO NOT mess with the drivers themselves - leave the Windows\System32\drivers directory alone unless we specifically direct you to it!
- Please update these drivers from the device manufacturer's website - or uninstall them from your system. Reference links are included below.
- DO NOT use Windows Update or the Update Drivers function of Device Manager.
- Please feel free to post back about any drivers that you are having difficulty locating.
- Windows Update exceptions may be noted below for Windows drivers:
Quote:
Code:

vmbus.sys      Sat Nov 20 04:57:29 2010 (4CE79B89)
winhv.sys      Sat Nov 20 04:20:02 2010 (4CE792C2)
amdxata.sys    Fri Mar 19 12:18:18 2010 (4BA3A3CA)
PxHlpa64.sys   Tue Jun 23 19:16:35 2009 (4A416253)
sptd.sys       Sun Oct 11 16:55:14 2009 (4AD24632)
ehdrv.sys      Mon Apr 19 02:47:01 2010 (4BCBFC65)
epfwwfpr.sys   Mon Apr 19 02:43:18 2010 (4BCBFB86)
vcd10bus.sys   Mon Jun 16 03:36:31 2008 (485617FF)
SCDEmu.SYS     Mon Apr 12 04:52:25 2010 (4BC2DF49)
Afc.sys        Wed Jul 12 01:48:20 2006 (44B48D24)
amdiox64.sys   Thu Feb 18 10:17:53 2010 (4B7D5A21)
eamonm.sys     Wed Jun 16 10:39:33 2010 (4C18E225)
KMWDFILTER.sys Wed Apr 29 02:20:48 2009 (49F7F1C0)
http://www.carrona.org/dvrref.html#vmbus.sys
http://www.carrona.org/dvrref.html#winhv.sys
http://www.carrona.org/dvrref.html#amdxata.sys
http://www.carrona.org/dvrref.html#PxHlpa64.sys
http://www.carrona.org/dvrref.html#sptd.sys
http://www.carrona.org/dvrref.html#ehdrv.sys
http://www.carrona.org/dvrref.html#epfwwfpr.sys
http://www.carrona.org/dvrref.html#SCDEmu.SYS
http://www.carrona.org/dvrref.html#Afc.sys
http://www.carrona.org/dvrref.html#amdiox64.sys
http://www.carrona.org/dvrref.html#eamonm.sys
http://www.carrona.org/dvrref.html#KMWDFILTER.sys
Post back if the BSOD's continue and include any new memory dumps that have been generated.


BSOD BUGCHECK SUMMARY
Code:

Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\101311-23836-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Thu Oct 13 05:33:23.624 2011 (UTC - 4:00)
System Uptime: 0 days 2:54:23.762
*** WARNING: Unable to verify timestamp for atikmpag.sys
*** ERROR: Module load completed but symbols could not be loaded for atikmpag.sys
Probably caused by : atikmpag.sys ( atikmpag+7ba8 )
DEFAULT_BUCKET_ID:  GRAPHICS_DRIVER_TDR_FAULT
BUGCHECK_STR:  0x116
PROCESS_NAME:  csrss.exe
FAILURE_BUCKET_ID:  X64_0x116_IMAGE_atikmpag.sys
Bugcheck code 00000116
Arguments fffffa80`064e0010 fffff880`04407ba8 00000000`00000000 00000000`00000002
BiosVersion = F6
BiosReleaseDate = 01/13/2009
จจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจ``
  
  
__________________
John Carrona, Microsoft MVP - Windows Expert - Consumer
Driver Reference Table ` ` BSOD Index
usasma is offline  
Old 10-15-2011, 06:10 AM   #4
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



thank you for the reply..

i will update drivesr.. if i have any question..i'll pst them here...
__________________
Sarmica is offline  
Old 10-16-2011, 07:38 AM   #5
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



i have tried to update all the drivs... first two is colored red, thus cant be updatet but via win update??

amdiox64.sys - could not fine a never version than that installed on my machine v.1.0.0.15

amdxata and pxlpa64 i could not find a way to update them...

other dirves are updated...

I did not have any BSOD for now...
__________________
Sarmica is offline  
Old 10-16-2011, 08:34 AM   #6
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



i had another BSOD..here are my dump files
Attached Files
File Type: zip Dump.zip (44.9 KB, 46 views)
__________________
Sarmica is offline  
Old 10-16-2011, 11:22 AM   #7
TSF Team Emeritus
Microsoft MVP
 
usasma's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2009
Location: Southeastern CT, USA
Posts: 7,450
OS: Win7



You must follow the steps at this link (not just updating drivers).
For example, you must check to be sure that the fans are working, that the case and coolers are free of dust, and that there is sufficient power going to the video card.

http://www.sevenforums.com/crash-loc...eshooting.html

Afc.sys must be removed. It belongs to an older CD/DVD program on your system. Please uninstall this program and check in C:\Windows\System32\drivers to make sure that it's gone.

BSOD BUGCHECK SUMMARY
Code:

Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\101611-34569-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Sun Oct 16 10:28:37.288 2011 (UTC - 4:00)
System Uptime: 0 days 1:08:23.053
*** WARNING: Unable to verify timestamp for atikmpag.sys
*** ERROR: Module load completed but symbols could not be loaded for atikmpag.sys
Probably caused by : atikmpag.sys ( atikmpag+7ba8 )
DEFAULT_BUCKET_ID:  GRAPHICS_DRIVER_TDR_FAULT
BUGCHECK_STR:  0x116
PROCESS_NAME:  System
FAILURE_BUCKET_ID:  X64_0x116_IMAGE_atikmpag.sys
Bugcheck code 00000116
Arguments fffffa80`0413a010 fffff880`042e8ba8 00000000`00000000 00000000`00000002
BiosVersion = F6
BiosReleaseDate = 01/13/2009
จจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจ``
  
  
__________________
John Carrona, Microsoft MVP - Windows Expert - Consumer
Driver Reference Table ` ` BSOD Index
usasma is offline  
Old 10-16-2011, 11:46 AM   #8
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



i have tryed all the test mentioned in the link...everything from memtest to prome95 have passed with no errosrs...tempetures where chedcked with everest and are in normal parameters....
I have bought a new PSU unit (listet in first post) and i hope that is enough for my system?
Computer was cleaned thoroughly, my side panel is opet so i can monitor overheating my hand.


I tought that Afc.sys from arconis file like it was pointetd in the link:
Driver Reference
as of arconis i only had one program... TV media..witch i have deleted... the driver is still there but i dont know what else is using that driver..
arc.sys propertis have this: adaptec raid storport driver.. i dont know hot to uninstall this?
Only dvd/cd program i use is power iso everything else is uninstalled...can i just delete that file?
__________________
Sarmica is offline  
Old 10-16-2011, 12:12 PM   #9
TSF Team Emeritus
Microsoft MVP
 
usasma's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2009
Location: Southeastern CT, USA
Posts: 7,450
OS: Win7



Afc.sys is a part of Arcsoft(R) ASPI Shell (CD/DVD program)
It is one (1) line away from the Acronis drivers in my table - so it's easy to get confused.

We're concerned about Afc.sys because it dates from before Windows 7 came out. Uninstalling the old CD/DVD program is the way to get rid of it (there are other ways, but they can render your system unbootable - so we save them for last). Uninstall PowerISO and see if the driver goes away.

I'm not concerned with arc.sys at this time. Don't worry about it.

Another possibility is that the video card or the motherboard has physical problems. You can test the video card by tryihng another one - but testing the motherboard isn't very easy (and is fairly expensive). We're just guessing here, so don't buy any new parts unless you can return them for a full refund.
__________________
John Carrona, Microsoft MVP - Windows Expert - Consumer
Driver Reference Table ` ` BSOD Index
usasma is offline  
Old 10-16-2011, 12:40 PM   #10
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



i have deleted power Iso but the driver is still there
__________________
Sarmica is offline  
Old 10-16-2011, 01:34 PM   #11
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



and i forgot..my video card was tested by 2 different IT services...and was check out OK...
__________________
Sarmica is offline  
Old 10-16-2011, 02:18 PM   #12
TSF Team Emeritus
Microsoft MVP
 
usasma's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2009
Location: Southeastern CT, USA
Posts: 7,450
OS: Win7



How did the IT people test the card? I test cards at work and am aware that most tests don't test the entire card - the only full test is by trying another card.

Be very, very careful trying this. There is no guarantee that it won't hose your system - but it's all we've got left.

1 - make sure that you have your recovery disks handy
2 - backup your data
3 - set a System Restore point and ensure that you have the Startup Repair disk for your system (you make them from the Maintenance menu)
4 - use Autoruns (which you were supposed to use in collecting the information that I requested) to disable (NOT delete) the entries for Afc.sys (use the Search function to find all of them)
5 - rename Afc.sys to Afc.BAD
6 - Reboot the system and hope that it boots into Windows. If it doesn't, use the Startup Repair disk to run System Restore and restore the system to the point that you made in step 3
__________________
John Carrona, Microsoft MVP - Windows Expert - Consumer
Driver Reference Table ` ` BSOD Index
usasma is offline  
Old 10-16-2011, 03:05 PM   #13
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



I don't know hot they tested it...

i' will try renaming the Afc.sys ...don't know will i'll be able to do it now becouse it is late..
In the meantime..i have uninstalled amd display drivers and control catalyst and just installed the display drivers...becouse i have read that control catalyst can also couse this problem? So just to be sure...
__________________
Sarmica is offline  
Old 10-16-2011, 03:43 PM   #14
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



windows booted up normaly after renaming Afc.sys to Afc.BAD
__________________
Sarmica is offline  
Old 10-17-2011, 04:30 AM   #15
TSF Team Emeritus
Microsoft MVP
 
usasma's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2009
Location: Southeastern CT, USA
Posts: 7,450
OS: Win7



w00t! That's great!!! :0)
Keep an eye out for a CD/DVD program not working - that'll be the one that used Afc.sys. If that does happen, just uninstall that program.

We had problems with the CCC about 9 months ago, but it seems to have cleared up since then. I have read of issues with the ATI drivers recenlty, but have only experienced it once myself (and that one was on my own system). But those issues weren't BSOD issues.

So, now we wait and see if that also fixed the other issues......
Good luck!
__________________
John Carrona, Microsoft MVP - Windows Expert - Consumer
Driver Reference Table ` ` BSOD Index
usasma is offline  
Old 10-17-2011, 05:46 AM   #16
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



i'am afarid i just had another crash....
here is my mini dump file :-(
Attached Files
File Type: zip 101711-26301-01.zip (32.4 KB, 26 views)
__________________
Sarmica is offline  
Old 10-17-2011, 06:33 AM   #17
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



and one more BSOD...both accured while trying to play a game...

but this time atikmpag.sys seems to be the troublesome one...
__________________
Sarmica is offline  
Old 10-17-2011, 06:49 AM   #18
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



system seems to be less stable
__________________
Sarmica is offline  
Old 10-17-2011, 09:31 AM   #19
TSF Team Emeritus
Microsoft MVP
 
usasma's Avatar

Microsoft Most Valuable Professional
 
Join Date: Apr 2009
Location: Southeastern CT, USA
Posts: 7,450
OS: Win7



Need all the memory dumps....We use them all in an attempt to establish a pattern.

I'm going to have a friend take a look at this topic also.

We're seeing a constant display of video errors. If you've done the STOP 0x116 troubleshooting then it's time to try another video card (DO NOT buy one unless you can return it for your money back).

BIOS dates from 2009 - I'd have to wonder if there were any BIOS updaes released for this system (DON'T install the new BIOS until you post back here)

BSOD BUGCHECK SUMMARY
Code:

Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\101711-26301-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Mon Oct 17 07:40:50.459 2011 (UTC - 4:00)
System Uptime: 0 days 5:12:28.224
*** WARNING: Unable to verify timestamp for atikmpag.sys
*** ERROR: Module load completed but symbols could not be loaded for atikmpag.sys
Probably caused by : atikmpag.sys ( atikmpag+7ba8 )
DEFAULT_BUCKET_ID:  GRAPHICS_DRIVER_TDR_FAULT
BUGCHECK_STR:  0x116
PROCESS_NAME:  System
FAILURE_BUCKET_ID:  X64_0x116_IMAGE_atikmpag.sys
Bugcheck code 00000116
Arguments fffffa80`04479460 fffff880`04056ba8 00000000`00000000 00000000`00000002
BiosVersion = F6
BiosReleaseDate = 01/13/2009
จจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจจ``
  
  
__________________
John Carrona, Microsoft MVP - Windows Expert - Consumer
Driver Reference Table ` ` BSOD Index
usasma is offline  
Old 10-17-2011, 11:06 AM   #20
Registered Member
 
Join Date: Oct 2011
Posts: 23
OS: win 7



There are no new versions of bios since then...

What i have done till now:

*cleaned all the fans and check for sdust buildup (entire computer)
*2 diferent IT services tested the card, passed
*1 IT service tested entire computer...passed
*I have tested memory with memtest86+ overnight, all ram tiles in all slots at least 3 runs each time - passed
*Run prime95 strest test + benchmark test...dont' remeber wich one exacly...simmilar to furmar - passed -
*Run 3DMark benchmark few times - passed
*While test where runing i've check the temperatures with Everest..all where in normal limits...GPUm CPU, HD and MB
Tried installing diferent drivers (not sure if older ones where unsintalled properly becouse i have only unninstalled old ones via uninstall in control panel - program and features)
*Run driver sweeper fot ati display...unplug internet cable..install ONLY DRIVERS lates versions...
*My side panel is open for futher cooling and to check with my hand if box is hot - it is not...
*Bought new power supply becouse old one was only 600W and my video card alone needs 600W of power... i now have 850W power supply...stabillity has improved since then.
*Driver upgrades, and renaming of drivers listed in above posts


Video card is not under quarantee anymore..and i don't have any money for new one anyhow...

my suspicion is that the issue is probably due to incompatible or old drivers
or maybe ram..i have 4 sticks of ram in 4 slots each stick of ram is the SAME so i dont see the issue there but still...

Unfortunately i do not have acces to any other computer so i colud replace viedo ro MB or anything becouse my friend eithe have laptops or uncompatible computer or reallly really old ones.

I'am gonna try to perform a clean startup to determine whether background programs are interfering with your game or program...

And another clean video driver install...

not sure about Driect X adn how to unistall or reinstall that..i've just downloaded lates version and installed it over the old version..

last attachment includes lates BSOD wich i have mentioned
Attached Files
File Type: zip 101711-107593-01.zip (31.2 KB, 18 views)

__________________
Sarmica is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] BSOD Due to dxgkrnl.sys
Hi, As the title suggests, I have recently been plagued by random reboots and it appears to be the fault of dxgkrnl.sys. I have included a link to an image that has a simple breakdown of the minidumps generated. I am running Windows 7 64bit and have a GeForce GTS 450 graphics card. The...
mryumyum BSOD, App Crashes And Hangs 19 11-09-2011 01:28 AM
HP G7000 Notebook runs slow always hangs
Hi, I am a long suffering HP user fed up with a notebook that always hangs and crashes (2 years worth). Its also really slow and i've noticed its running over 30 processes and i 've no idea what they all are, it seems too many! I have tried cleaning up registry and updated security to Norton...
Issi Noho BSOD, App Crashes And Hangs 10 04-24-2011 02:26 AM
BSOD Problems, IQRL_Not_Less_Or_Equal; PFN_List_Corrupt; Ntfs.sys etc.
Over the past 2 months I've been having problems with BSOD's. First I tought it was just a one time thing but after five times I started to think different. I used Ccleaner and Comodo cleaner to clean up the registry but nothing helped. The one thing I did noticed was that the BSOD's were different...
Pytrik BSOD, App Crashes And Hangs 9 02-28-2011 05:41 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 11:00 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts