Go Back   Tech Support Forum > Home Support > Electronics

Vizio 42in LCD VU42L FHDTV10A no picture no sound

This is a discussion on Vizio 42in LCD VU42L FHDTV10A no picture no sound within the Electronics forums, part of the Tech Support Forum category. I have a 42in LCD VU42L FHDTV10A and here is my problem The TV will turn on and the vizio


Reply
 
Thread Tools Search this Thread
Old 04-20-2010, 04:58 PM   #1
Registered Member
 
Join Date: Apr 2010
Posts: 3
OS: vista



I have a 42in LCD VU42L FHDTV10A and here is my problem
The TV will turn on and the vizio emblem lights up white but the screen is a blank dark grey screen and there is no sound
I can see the backlights on through the vents up top, I hit the menu button nothing happens, and to turn it off I have to unplug it. Any help on diagnosing this problem would be greatly appreciated.

__________________
Jonny Vette is offline   Reply With Quote
Old 04-20-2010, 07:02 PM   #2
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



Hi johnny Vette


One of the power boards in the set has given out, the problem is that the boards can be pricey to replace. You have to contact the company to see if any boards are available for your set, then have it replaced by a qualified service technician.


Note: If your set died before the warranty expiration date and if it was purchased at costco or walmart, bring back the set and ask for refund.

__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 04-21-2010, 10:07 AM   #3
Registered Member
 
Join Date: Apr 2010
Posts: 3
OS: vista



The TV is defiantly out of warranty and from what I have read in other post with the similar problem I am guessing it would be the power supply board or the main board but I would like to try to narrow it down to which one and if anyone knows where I could find them for cheap. The cheapest main board I found was $150 and the # didn’t match exactly all I can find are 3642-0122-0395 or 3642-0212-0150 does anyone know if these are interchangeable my main board # is 3642-0112-0510
__________________
Jonny Vette is offline   Reply With Quote
Old 04-21-2010, 06:05 PM   #4
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



Johnny

Ebay has the main board and power boards.

Here's the link: http://electronics.shop.ebay.ca/Elec...D&_kw=FHDTV10A
__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 10-23-2010, 02:48 PM   #5
Registered Member
 
Join Date: Oct 2010
Posts: 1
OS: Windows 7



Quote:
Originally Posted by Jonny Vette View Post
I have a 42in LCD VU42L FHDTV10A and here is my problem
The TV will turn on and the vizio emblem lights up white but the screen is a blank dark grey screen and there is no sound
I can see the backlights on through the vents up top, I hit the menu button nothing happens, and to turn it off I have to unplug it. Any help on diagnosing this problem would be greatly appreciated.

I'm having this exact same problem. I checked the ebay link suggested but its changed since it was first posted. can anyone point me to a solution?
__________________
HobbyHorse is offline   Reply With Quote
Old 10-25-2010, 08:53 PM   #6
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



HobbyHorse


I re-checked the link and it is working, the power board is still up for grabs on e-bay.


Here's the time stamp on it :

Vizio GV42L FHDTV10A LCD TV Power Board 0500-0507-0410
Location: USA Feedback: 262 | 100% C $51.01 +C $25.64 Time left:13d 23h 42m


Time left: Nov 08, 2010 22:31:38 EST
__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 11-11-2010, 12:34 PM   #7
Registered Member
 
Join Date: Apr 2010
Posts: 3
OS: vista



Hobby horse please let me know if you are able to fix your TV I have yet to fix mine because I was told that it was most likely power supply but then it could be the main board and I have not been able to find one for a reasonable price

__________________
Jonny Vette is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 05:09 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts