Go Back   Tech Support Forum > Automotive Center > Small Engines

4.3 GM Marine Engin e

This is a discussion on 4.3 GM Marine Engin e within the Small Engines forums, part of the Tech Support Forum category. My engine recently over heated as the water pump impeller disintegrated. I installed a new impeller, but now there is


Reply
 
Thread Tools Search this Thread
Old 07-26-2011, 01:34 PM   #1
Registered Member
 
Join Date: Jul 2011
Location: Minnesota
Posts: 3
OS: windows 7



My engine recently over heated as the water pump impeller disintegrated. I installed a new impeller, but now there is clicking sound in the engine, heard both in the engine itself and in back where the exhaust comes out. Also the engine is not running smoothly as before. Now there is a vibration that can be felt in the floor and also while holding on to the side of the boat.
Please give some suggestions as to what I should do next.
Thanks

__________________
tvorwerk is offline   Reply With Quote
Old 07-26-2011, 01:48 PM   #2
Administrator
Automotive Team Manager
 
Midnight Tech's Avatar
 
Join Date: Dec 2001
Location: Hunting the next geocache
Posts: 4,597
OS: Windows 7/Windows XP Home/Pro SP3/Windows 98SE/Fedora Core 6/RH 7.2 with Autopoint/TAMS II



How badly did it overheat - peg the gauge or just above normal?

__________________

Please post all questions in the appropriate forum. Questions sent by email or PM will not be answered.
Interested in Trek gaming? Check out the Dynaverse!
Proud supporter of the Carolinas Aviation Museum - the final home of Flight 1549.
Confession might be good for the soul, but it hurts the heart like hell.
Midnight Tech is offline   Reply With Quote
Old 07-26-2011, 02:18 PM   #3
Registered Member
 
Join Date: Jul 2011
Location: Minnesota
Posts: 3
OS: windows 7



It pegged the gage....my son was driving and he said the engine started to slow down, and then he smelled smoke, so he shut it off.
__________________
tvorwerk is offline   Reply With Quote
Old 07-26-2011, 02:28 PM   #4
Team Manager, Gaming
Team Manager, Microsoft Support
Team Manager, Hardware Team
Microsoft MVP
 
Wrench97's Avatar

Microsoft Most Valuable Professional
 
Join Date: May 2008
Location: S.E. Pennsylvania
Posts: 48,923
OS: Win7



Pull the spark plugs and do a Compression test.
Wrench97 is offline   Reply With Quote
Old 07-26-2011, 02:53 PM   #5
Registered Member
 
Join Date: Jul 2011
Location: Minnesota
Posts: 3
OS: windows 7



I did a compression check on each cylinder...here are the results
right side of engine 25, 75, 112
left side of engine 100, 125, 60
__________________
tvorwerk is offline   Reply With Quote
Old 07-26-2011, 03:02 PM   #6
Team Manager, Gaming
Team Manager, Microsoft Support
Team Manager, Hardware Team
Microsoft MVP
 
Wrench97's Avatar

Microsoft Most Valuable Professional
 
Join Date: May 2008
Location: S.E. Pennsylvania
Posts: 48,923
OS: Win7



It's hurt, do you have access to a air compressor?
There is a adapter that screws into the spark plug hole, if you remove all the plugs then either loosen the rocker arms or position the piston on bottom dead center with both valves closed, screw in the adapter and put air into the cylinder that will tell you if a valve is bad, or a head gasket/cylinder head(for example if you put air in #1 and it comes out of #3 plug hole the head gasket between the 2 is blown.

Out school is to squirt oil in the cylinders and recheck the compression if it comes up considerably the rings/piston is bad, if not head gasket/valve/head is bad.
Wrench97 is offline   Reply With Quote
Old 07-26-2011, 03:02 PM   #7
Moderator Offline
 
Basementgeek's Avatar
 
Join Date: Feb 2005
Location: Ohio, USA
Posts: 11,561
OS: XP Pro SP3/Vista Ultimate SP2/Win7 64 bit



Does not sound at all good to me.

BG

__________________

ASAP member since 2006

Four boxes keep us free: the soap box, the ballot box, the jury box, and the cartridge box.

Basementgeek is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
powerful v6 4.3
:rippedhan:4-fart::4-fart:ok hi every one i have a v6 4.3 vortec in a rail buggy its stock but full of life its starting to leak i went to the parts store and got a rebuild kit gaskets ring ,piston crank ok just leaks the gasket kit they gave me was wrong i noictest right awayi dont have any...
rednecks813 Talk Car 2 08-07-2011 02:55 PM
Zoo Tycoon 2: Marine Mania- Missing Files?
Okay, so I have Zoo Tycoon 2: Zookeeper Edition on my laptop(Win7) and just got Marine Mania for my little brother. I installed it and everything seemed fine... Until I went through the tutorial and tried showing him how to train the sea animals. I compared it to the Marine Mania Demo and I'm...
Hydrakat PC Gaming Support 0 04-23-2011 11:51 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 06:07 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts