Go Back   Tech Support Forum > Hardware Support > Other Hardware Support

pc wont start

This is a discussion on pc wont start within the Other Hardware Support forums, part of the Tech Support Forum category. my friend asked me to look at his emachines desktop pc, it won't switch on, i took the power supply


Reply
 
Thread Tools Search this Thread
Old 04-17-2009, 03:07 AM   #1
Registered Member
 
Join Date: Apr 2009
Posts: 3
OS: vista



my friend asked me to look at his emachines desktop pc, it won't switch on, i took the power supply out and checked it, it wasn't working at all, i've replaced it and the pc still won't start up, it's getting power because the halo is on around the switch but it just won't power up.

any help would be greatly appreciated.

__________________
dirtydave01 is offline   Reply With Quote
Old 04-17-2009, 03:32 AM   #2
Registered Member
 
Join Date: Apr 2009
Location: Denver, CO
Posts: 382
OS: Win 8.1 64-bit Ultimate

My System

Send a message via Skype™ to thedarkwolf25

Are the lights lighting up on the motherboard? Is the CPU fan spinning up? Are the hard drives spinning?

__________________
thedarkwolf25 is offline   Reply With Quote
Old 04-17-2009, 03:59 AM   #3
Registered Member
 
Join Date: Apr 2009
Posts: 3
OS: vista



nothing is working at all, the only light that appears to be on is the halo round the wsitch but the motherboard lights are off and nothing welse is starting up at all.
__________________
dirtydave01 is offline   Reply With Quote
Old 04-18-2009, 08:04 AM   #4
Registered Member
 
Join Date: Apr 2009
Location: Denver, CO
Posts: 382
OS: Win 8.1 64-bit Ultimate

My System

Send a message via Skype™ to thedarkwolf25

Sounds like the motherboard is dead. If the power supply is working but nothing else is getting power than it has to be the motherboard.
__________________
thedarkwolf25 is offline   Reply With Quote
Old 04-18-2009, 10:45 AM   #5
Registered Member
 
SANAFABICH's Avatar
 
Join Date: Mar 2009
Posts: 6
OS: Windows XP SP3



seems like the mobo is shortcutting with the pc case. Try taking it out of the case and try switching it on. You may need to use copper screws

__________________
SANAFABICH is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 10:07 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts