Go Back   Tech Support Forum > Hardware Support > Other Hardware Support

My Dell Inspiron E1505 Won't Boot Up!

This is a discussion on My Dell Inspiron E1505 Won't Boot Up! within the Other Hardware Support forums, part of the Tech Support Forum category. I'm looking for some help, I've had my laptop for about 4 years and worked fine until last night, I


Reply
 
Thread Tools Search this Thread
Old 02-29-2012, 05:45 AM   #1
Registered Member
 
Join Date: Feb 2012
Posts: 1
OS: Windows Vista


Evil

I'm looking for some help,
I've had my laptop for about 4 years and worked fine until last night, I went to turn it on, and NOTHING happened. I took our the battery and power cord, press the power button for 30 secondes, and did all that, still nothing. The power "light" turned on everytime I would push the power button, but it's about it.

I did the CapLock test to see if I could get any signal of life, still nothing.

I read on a couple of different sites that it would be the CMOS battery of my laptop.

I just want more information as to what I can do, I don't want to replace the motherboard or anything too expensive because in fact, it is 4 years old..

Thanks for all your help!

__________________
Janie007 is offline   Reply With Quote
Old 02-29-2012, 03:13 PM   #2
Moderator,
- Hardware
- Networking
 
JimE's Avatar
 
Join Date: Apr 2009
Location: St Louis, MO
Posts: 16,230
OS: Win 7 SP1

My System


There isn't much that the average user can do to troubleshoot. I doubt it's the CMOS battery. If that were the problem, it would/should boot but give you an error about settings have changed or the date is incorrect.

The next step would be a different power pack and battery...which isn't something most people have available.
__________________

Google is your Friend!
JimE is offline   Reply With Quote
Reply
Gear in this thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] My xbox360 wrecks my discs and makes a buzzing sound
Hi, I bought an Xbox360 slim just under 1 year ago and when i turn it on there is no problem but if i insert a disc it makes a large buzzing sound and scratches the discs. I did get the Disk drive replaced but the problem is still there, can anyone help me?
coopern Console Gaming Support 11 03-28-2012 03:09 AM
Dell inspiron e1705 xp service pack 3
Thanks for keeping this forum active everyone. My dell computer upon start up gives me about 5-10 minutes of ok computer speed. Then after, I takes up to 1-2 minutes to run anything. No pop-ups. just a very very slow computer. Love ideas.. thanks again . DDS (Ver_2011-08-26.01) - NTFSx86 ...
axlmed Virus/Trojan/Spyware Help 15 03-24-2012 11:08 PM
[SOLVED] New Sony gt56uix stereo has power but won't turn on
Hi, I have installed a sony cdx gt56uiw in a 2003 ford focus (baupunkt). I have power to the stereo as it will accept cds and will eject them if i hit the eject button. However the display and sound will not come on. I have held down every button. Any experience with this stereo?
Ksilvey10 Car Audio and Alarms 8 03-04-2012 10:03 AM
[SOLVED] Unpartitioned space - now Windows won't load
Hi all I have a user with a Dell Optiplex desktop on Windows XP. He was complaining about poor performance lately, so after doing the usual steps of cleaning up temp folders and general junk, I attempted a defrag and chkdsk. Neither would run, with the chkdsk returning an error about "the type...
elgaz Hard Drive Support 5 03-02-2012 01:33 AM
[SOLVED] Computer Won't Boot Up
Hi everyone. I am wondering if my computer is even salvagable. It is an older ASUS with an AMD 2000+ CPU. I got a terrible virus I could not get rid of without formatting the hard drive & reinstalling Windows XP. Then I could not get the on-board sound to work. After repeated attempts at driver...
guysmiley Motherboards, Bios & CPU 6 02-28-2012 09:24 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question

Gear in this thread


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 10:40 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts