Go Back   Tech Support Forum > Microsoft Support > Windows 7 Support, Windows Vista Support

Windows 7: slow and glitchy

This is a discussion on Windows 7: slow and glitchy within the Windows 7 Support, Windows Vista Support forums, part of the Tech Support Forum category. Upgraded a bunch of hardware - pretty much everything but the HDs. Decided to go to Win 7 64 to


Closed Thread
 
Thread Tools Search this Thread
Old 11-16-2010, 08:04 PM   #1
Registered Member
 
Join Date: Mar 2008
Location: Rochester, NY
Posts: 112
OS: XP



Upgraded a bunch of hardware - pretty much everything but the HDs.

Decided to go to Win 7 64 to be able to take advantage of extra RAM. I wasa expecting a snappy, fun experience and it's been well...not that.

It takes a good 4 minutes to go from the welcome screen to the desktop. Pages load slow and spotty. I get a bunch of stuck pages.

My rig:

i5 750
ASUS p55p7d
Corsair tx 650
4gig Mushkin 1600 (128) RAM

My kids laptop (which looks like it went through a war) gets to the desktop in about 20 seconds.

Somethin' ain't right.

Any ideas?

__________________
redddog is offline  
Old 11-16-2010, 08:13 PM   #2
TSF Enthusiast
 
1 g0t 0wn3d's Avatar
 
Join Date: Jan 2007
Location: Sedona, az
Posts: 7,308
OS: Windows 7 Ultimate

My System


When you upgraded the motherboard did you do a repair install of windows?

1 g0t 0wn3d is offline  
Old 11-16-2010, 08:20 PM   #3
Registered Member
 
Join Date: Mar 2008
Location: Rochester, NY
Posts: 112
OS: XP



Yes. I reinstalled XP but then went to win 7.
__________________
redddog is offline  
Old 11-16-2010, 08:29 PM   #4
TSF Enthusiast
 
1 g0t 0wn3d's Avatar
 
Join Date: Jan 2007
Location: Sedona, az
Posts: 7,308
OS: Windows 7 Ultimate

My System


Did you install the drivers that came with it?
http://www.cpuid.com/softwares/hwmonitor.html
Post your temps and voltages
1 g0t 0wn3d is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 01:53 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts