Go Back   Tech Support Forum > Microsoft Support > Windows 7 Support, Windows Vista Support

[SOLVED] Some programs cannot access the internet

This is a discussion on [SOLVED] Some programs cannot access the internet within the Windows 7 Support, Windows Vista Support forums, part of the Tech Support Forum category. Its a problem that has persisted for some time, over different internet networks (From China to the UK). What has


Closed Thread
 
Thread Tools Search this Thread
Old 03-13-2010, 03:35 AM   #1
Registered Member
 
Join Date: Mar 2010
Posts: 20
OS: Vista



Its a problem that has persisted for some time, over different internet networks (From China to the UK).

What has happened, is that several programs, such as 'Steam' don't seem to be able to connect to the internet, while everything else can.

I have disabled Windows firewall, and the wireless network I use does not have a proxy server of any kind.

I do remember seeing at one point that the error may have something to do with ''the socket is closed' or something.

Is there a way to reset all the configurations I may have made in the past to do with letting programs use the internet, etc etc. I have already exhausted many options, and all I think will work now is a general setting reset, but I'm not sure how to do it, unless anyone does have an alternative option.

Here are some of the errors I get:

'Steam.exe (main exception): To run Steam, you must first connect to the Internet'

When steam stopped working, I decided after futile efforts to make it work, to reinstall it completely. However once I had uninstalled it, when I attempted to use the installer, it gave the above error.

So pretty much my questions are:

1) What is the most likely cause of the problem
2) How do I fix it
3) How can I completely reset everything if the above two fail.

Thanks!

__________________
Danni111111 is offline  
Old 03-13-2010, 04:40 AM   #2
Team Manager, Microsoft Support
Microsoft MVP
BSOD Kernel Dump Expert
 
jcgriff2's Avatar

Microsoft Most Valuable Professional
 
Join Date: Sep 2007
Location: BSOD CENTRAL
Posts: 30,492
OS: Windows 8.1, 7 + Windbg :)



Is there another firewall besides the WIndows Firewall that is currently installed or one that was previously installed?

Boot into SAFEMODE w/ Netorking - tap F8 key during boot-up

Can you access sites there?

Regards. . .

jcgriff2

.

jcgriff2 is offline  
Old 03-13-2010, 06:24 AM   #3
Registered Member
 
Join Date: Mar 2010
Posts: 20
OS: Vista



I can't remember if I ever installed other firewalls- I certainly didn't when the problem started.

I tried accessing the internet with safe mode w/ Netwroking, and I am completely unable to do so, no programs can connect, including my internet browser.
__________________
Danni111111 is offline  
Old 03-13-2010, 08:00 AM   #4
Registered Member
 
Join Date: Mar 2010
Posts: 20
OS: Vista



I've been downloading several programs today, and every one could not access the internet. It seems that programs installed before a certain point are able to connect, but after that, they cant :(
__________________
Danni111111 is offline  
Old 03-13-2010, 10:41 AM   #5
Registered Member
 
Join Date: Mar 2010
Posts: 20
OS: Vista



Ok- I spent 2 hours on this, finally managed to fix it-

apparently When my Norton Anti-Virus software expired, it stopped any new porgrams from using the network. Even though it was 'disabled' it was stopping everything. Completely uninstalling it and rebooting worked.

Thanks anyway!
__________________
Danni111111 is offline  
Old 03-13-2010, 02:24 PM   #6
Team Manager, Microsoft Support
Microsoft MVP
BSOD Kernel Dump Expert
 
jcgriff2's Avatar

Microsoft Most Valuable Professional
 
Join Date: Sep 2007
Location: BSOD CENTRAL
Posts: 30,492
OS: Windows 8.1, 7 + Windbg :)



Make sure to use the Norton Removal Tool -->
NRT - ftp://ftp.symantec.com/public/englis...moval_Tool.exe

jcgriff2

.

jcgriff2 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 12:01 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts