Go Back   Tech Support Forum > Microsoft Support > Windows 7 Support, Windows Vista Support

Notepad: Gibberish Instead of Hebrew

This is a discussion on Notepad: Gibberish Instead of Hebrew within the Windows 7 Support, Windows Vista Support forums, part of the Tech Support Forum category.


Closed Thread
 
Thread Tools Search this Thread
Old 02-08-2011, 04:31 PM   #1
Registered Member
 
Join Date: Dec 2010
Location: Canada
Posts: 5
OS: Vista



Hi, I'm currently trying to add subtitles (.srt file) into a movie. when i open the .srt file gibberish is the only thing i see instead of Hebrew font. I can type in Hebrew though. When i open the file on another computer (an Israeli one) notepad opens and Hebrew font does show. Does this mean i need to install something for Hebrew font to show on notepad? What can i do? I appreciate the help.


Example of what shows in my laptop (Gibberish) : , .
Instead of : עליך לאפשר לי להגיע לכל מקום

ps: The hebrew language, like a lot of Middle Eastern languages, writes from right to left and not left to right. I have also tried saving the file as a different encoding. it seems that VirtualDub (the program i am using to burn the subtitles into the .avi file) only opens the encoding ANSI.

__________________
VanChester1234 is offline  
Old 02-08-2011, 05:20 PM   #2
Windows Tech Team
BSOD Kernel Dump Expert
 
Join Date: Jun 2010
Posts: 2,208
OS: Windows 7 SP1



Notepad has a pretty limited support of different formats and encodings. You'll probably want a free open source version that will meet your needs better, perhaps Notepad++.

If you want though, check under Font options to see if the script as well as the font are correct. Also make sure when you go to save it to change encoding as well.

__________________
VirGnarus is offline  
Old 02-08-2011, 07:14 PM   #3
Registered Member
 
Join Date: Dec 2010
Location: Canada
Posts: 5
OS: Vista



I did download and use Notepad++ but it seems that VirtualDub only opens from the original notepad. But how come does the Israeli computer see the hebrew font and not mine? If I can find that out it will solve the problem and im going to be able to open the .srt file on VirtualDub
__________________
VanChester1234 is offline  
Old 02-08-2011, 07:56 PM   #4
Windows Tech Team
BSOD Kernel Dump Expert
 
Join Date: Jun 2010
Posts: 2,208
OS: Windows 7 SP1



I'm not sure what you mean "only opens from". Do you have notepad associated with .srt files? If so, just change association using "Open with..."

If need be, perhaps change region and language for Windows in the control panel.
__________________
VirGnarus is offline  
Old 03-04-2011, 12:46 AM   #5
Registered Member
 
Join Date: Mar 2011
Posts: 1
OS: windows 7



In windows 7 (perhaps other systems as well) you need to set the system locale - regional settings > administrative tab > change system locale to the language of your choice. This solved the problem for me.
__________________
nomadsolo is offline  
Old 03-04-2011, 02:33 AM   #6
TSF Team, Emeritus
 
spunk.funk's Avatar
 
Join Date: May 2010
Location: Los Angeles
Posts: 28,808
OS: Windows 8 64, Windows 7 64 Bit SP1, XP SP3, Mac OSX

My System


You have to install Language Packs for Windows:
There are two types of language files:
  • Windows 7 language packs.* Windows 7 language packs provide a translated version of most of the user interface.
    Note

    • Language packs are available in Windows 7 Ultimate through Windows Update as optional updates. They aren't installed automatically. If you're using Windows 7 Enterprise, contact your system administrator for information about installing additional languages.

    [IMG]mshelp://Help/?id=Microsoft.Windows.Resources.CollapseArrow[/IMG][IMG]mshelp://Help/?id=Microsoft.Windows.Resources.ExpandArrow[/IMG] To get additional language packs by using Windows Update

    1. Language packs are available through Windows Update as optional updates. They aren't installed automatically.
    2. [IMG]mshelp://help/?id=Microsoft.Windows.Resources.ShellExecuteTopicIcon[/IMG]Click to open Windows Update.
    3. In the left pane, click Check for updates, and then wait while Windows looks for the latest updates for your computer.
    4. If any updates are found, click Select optional updates.
    5. Select the language pack that you want, and then click OK.
    6. Click Install updates. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
      Note

      • If Windows doesn't find any updates when you click Check for updates, wait a day and then try again.
  • Windows 7 Language Interface Pack (LIP).* Windows 7 LIPs provide a translated version of the most widely used areas of the user interface. LIPs are freely available to download. Because not all of the user interface is translated, LIPs require at least one parent language. The parts of the user interface that aren't translated into the LIP language are displayed in the parent language. When you download the LIP, you get the parent language requirements for that language. The parent language pack needs to be installed before the LIP can be installed. For more information, including a list of available languages, go to Download languages for Windows on Windows online.

spunk.funk is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 09:02 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts