Go Back   Tech Support Forum > Microsoft Support > Windows 7 Support, Windows Vista Support

Destination Folder Access Denied

This is a discussion on Destination Folder Access Denied within the Windows 7 Support, Windows Vista Support forums, part of the Tech Support Forum category. My wife has just gotten a new computer with Windows Vista on it. I'm a little uncomfortable with the "Easy


Closed Thread
 
Thread Tools Search this Thread
Old 02-08-2007, 08:03 PM   #1
Registered Member
 
Join Date: Jan 2007
Posts: 60
OS: Windows Vista Home Preimum



My wife has just gotten a new computer with Windows Vista on it. I'm a little uncomfortable with the "Easy Transfer" so I mapped her "My Documents" folder from the old computer as a drive on the new computer. I then started trying to copy some of the files to the new computer. I am continually getting a "Destination Folder Access Denied" on many of the files. The strange thing is that some of the files will copy, yet others will not. I have full admin privileges on both computers. Any thoughts.

Thanks,

Britt

__________________
mbrittb00 is offline  
Old 02-08-2007, 10:22 PM   #2
Registered Member
 
Join Date: Jan 2007
Posts: 60
OS: Windows Vista Home Preimum


Ok, I've discovered something. I am looking at the folder on the old computer (running XP Home) from the new computer (running Vista Home Premium). When I right click the files and go to properties->Security, the files that I can't copy say "You do not have permission to view or edit this object's permission setting". While the files I can copy show me a list of Groups or user names and a permissions box. My guess is that somehow the permissions on the SOME of the files on XP got a security set to them, but I have no idea how or how to change it.

Thanks,

__________________
mbrittb00 is offline  
Old 02-09-2007, 02:29 AM   #3
Registered Member
 
DeathHawk's Avatar
 
Join Date: Oct 2005
Location: London
Posts: 382
OS: Windows XP Pro


Hi,

I had the same problem and solved the majority of mine with the following method:

right click on file
click properties
click security
click advanced
click owner in top tabs
click edit
highlight the user you want and click apply/ok

I still have some problems but this seemed to solve the majority of them

Let us know how you go!
__________________
DeathHawk is offline  
Old 02-09-2007, 07:21 AM   #4
Registered Member
 
Join Date: Jan 2007
Posts: 60
OS: Windows Vista Home Preimum


I do this on the XP machine correct?

One other possible problem. The OS is XP Home, I don't know if I have the Security options like in XP Pro. If not, is there a setting in XP Home to give me these same options?

I'm at work right now, but I can check when I get home.
__________________
mbrittb00 is offline  
Old 02-10-2007, 09:12 AM   #5
Registered Member
 
DeathHawk's Avatar
 
Join Date: Oct 2005
Location: London
Posts: 382
OS: Windows XP Pro


I had a look on xp but it seems it does not have the extreme security set up as vista-unless an expert can give more help here

on my pc, i have both a vista and a xp pro so that i can boot from either.

When in vista, i tried to go into MY COMPUTER and then the d: drive(XP) to transfer files to C:(VISTA)which is when i was refused permission. That is when i worked out that i had to open the other drive (D:), find the files i wanted and carry out the procedure i mentioned-then just drop and drag into vista-so in effect i was in the xp pro but carried out the operation whilst i was booted in vista.

I tried to transfer files from XP to Vista and had no problems-it appears Vista is trying to stop me transferring-unless you do the procedure i mentioned

I am still trying to solve some problems but hope this helps a bit
__________________
DeathHawk is offline  
Old 08-04-2007, 10:07 AM   #6
Registered Member
 
Join Date: Aug 2007
Posts: 2
OS: vista



Hello, I've resolved the problem giving reading-writing permissions on the folder in the source computer.
__________________
tufla is offline  
Old 08-04-2007, 10:23 AM   #7
Registered Member
 
Join Date: Jan 2007
Posts: 60
OS: Windows Vista Home Preimum



Could you please elaborate a little more on how you did it?
__________________
mbrittb00 is offline  
Old 08-04-2007, 10:47 AM   #8
Registered Member
 
Join Date: Aug 2007
Posts: 2
OS: vista



Of course...

The OS in my source computer is XP Professional.

In the folder in the source computer I did the following:

right click over folder
click on properties
click on share tab
into sharing and security network group check the option "let other users change my files"
click on apply

after that I could copy files without restrictions.

NOTE: The texts that I've mentioned into the process could be different because I have that OS in Spanish language, but should be something similar to that.
__________________
tufla is offline  
Old 08-04-2007, 11:08 AM   #9
Registered Member
 
Join Date: Jan 2007
Posts: 60
OS: Windows Vista Home Preimum



Yes, if anyone knows how to solve this issue on XP Home I am still looking for a solution.
__________________
mbrittb00 is offline  
Old 12-30-2007, 11:33 PM   #10
Registered Member
 
Join Date: Dec 2007
Posts: 1
OS: windows vista



Dear MbrittB00, In windows XP Home you have to go to My Computer => TOOLS =>FOLDER OPTIONS = VIEW TAB=> IN ADVANCED CONFIGURATION => you have to dissable the option that says Use simple file sharing (Recommended),

Once you have done that, you can then have complete access to the sharing menu when you right click the shared folder.

Please refer to:

http://techpaul.wordpress.com/2007/0...curity-part-3/

You can send me an email if you do not understand.

Deepak
__________________
DIPI44 is offline  
Old 12-31-2007, 01:26 AM   #11
Registered Member
 
Join Date: Jan 2007
Posts: 60
OS: Windows Vista Home Preimum



Thanks. I checked out the link you provided, however I am missing the "Use Simple File Sharing (Recommended)" Option. I am running Windows XP Home. Is there something I need to do to enable this option?

Thanks,
__________________
mbrittb00 is offline  
Old 07-17-2008, 06:17 PM   #12
Registered Member
 
Join Date: Jul 2008
Posts: 2
OS: vista



It Worked!!! I just had this trouble also, trying to copy from my old XP Home laptop to this new Vista machine.

On the XP machine, right click the folder, click the "Sharing" tab and click the "Allow network users to change my files". Then I was able to copy to the Vista machine. I had also enabled simple file sharing on the vista
machine (not sure if this is important here or not).

Edit: Ok I just got the error again. I made a copy of the file (on the xp machine) then I was able to drag it to the Vista machine. Will continue trying...
__________________
Veile is offline  
Old 07-18-2008, 05:54 AM   #13
Registered Member
 
Join Date: Jul 2008
Posts: 2
OS: vista



Something occurred to me so I did a test. The computer Im having trouble copying files from is XPHome. This one I noticed the problem on is Vista. I have the *same* problem getting the files from the XPHome PC to a third PC running XP pro. In fact I've had this problem many times before.

I was very ready to blame vista as I've never run it before, but this is an issue that seems to appear with copying *from* XP home.

In all cases now I've been able to resolve it by making a copy of the files. The "allow users to change my files" may be helping, but not sure it is the thing making the difference. Hope this helps someone out there.
__________________
Veile is offline  
Old 10-04-2008, 05:43 PM   #14
Registered Member
 
Join Date: Oct 2008
Posts: 1
OS: Vista



I was having the same problem - Some files copy fine from a shared folder on my XP machine to my VISTA machine and some get the "Destination Folder Access Denied" message.

After I turned on Advanced Security per the earlier post in this thread, I figured out that the problem I was having is that not all of the files in the Shared folder have the "Everyone" user configured to access the file in the NTFS file permissions.

The way you can see this is: you right click on the file giving you trouble and click the Security tab. You'll see a list of users and one of them should include Everyone. The file I was having trouble with didn't - it only included users on the XP system. Compare it to a file that does copy okay.

There are probably more surgical ways to fix this, but adding Everyone to every file you in the folder, opens it up to anyone on the local network which is what I wanted when I shared it (no big security risk as long as you are on a local network behind a router). I fixed all of the file permissions in the shared folder at once by:
  • Opening Properties on the Shared Folder
  • Clicking Security Tab
  • Make sure there is an "Everyone" with Full Control configured on the shared folder (should be)
  • Clicking Advanced
  • Clicking the checkbox that says "Replace permission entries all child objects..."

What this does is make all of the files in and sub-folders have identical permissions to the parent (shared folder).
__________________
mwoolley is offline  
Old 10-04-2008, 08:29 PM   #15
Moderator
- Microsoft Support
 
jenae's Avatar
 
Join Date: Jun 2008
Location: Sydney
Posts: 5,987
OS: XP, Vista, Seven, & a whole host you would never have heard of.



Hi, you can copy almost anything from XP into the "Public " folder in Vista then copy out of that. Now if permissions is the problem this little reg hack will place a right click option to take ownership of any file or folder. In vista it runs without input, in XP it asks which user you wish to apply it to. Copy and paste the below code into notepad, in notepad click on file select "save as" save as ownership.Reg and save to desktop. Double click on the saved file and merge into registry.


Code:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Take Ownership"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrators:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Take Ownership"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrators:F /t"
If you wish to undo this (security stop others from gaining access)
repeat the above this time copy and paste this will undo the above. Call it remownership.Reg


Code:
Windows Registry Editor Version 5.00


[-HKEY_CLASSES_ROOT\*\shell\runas]

[-HKEY_CLASSES_ROOT\Directory\shell\runas]
__________________

jenae is offline  
Old 01-12-2009, 05:50 PM   #16
Registered Member
 
Join Date: Jan 2009
Posts: 2
OS: vista service pack 1



I use windows vista .
__________________
getincrazy is offline  
Old 02-28-2009, 09:36 AM   #17
Registered Member
 
Join Date: Feb 2009
Posts: 10
OS: XP SP3



Quote:
Originally Posted by getincrazy View Post
I use windows vista .

now that's a problem

__________________
guangjen is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 12:38 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts