Go Back   Tech Support Forum > Hardware Support > Driver Support

TSST Corp cd/dvdw TS-H653L missing driver

This is a discussion on TSST Corp cd/dvdw TS-H653L missing driver within the Driver Support forums, part of the Tech Support Forum category. I need help please! Yesterday my cd/dvd drive was working fine...today I purchased an epson printer and when I went


Closed Thread
 
Thread Tools Search this Thread
Old 02-29-2008, 10:45 PM   #1
Registered Member
 
Join Date: Feb 2008
Posts: 2
OS: vista 32-bit



I need help please! Yesterday my cd/dvd drive was working fine...today I purchased an epson printer and when I went to install it I found out I had to go download updated drivers for vista...which I have had to do before, but any how...the printer still did not operate properly, so I uninstalled it and packed it back up. Later when I went to play a cd my drive would not work. I tried system restore and this did not work...so I went into device manager and there was a yellow exclaimation mark beside it. When I double clicked it I had a message that said "windows can not load the device driver for this hardware. The driver maybe corrupted or missing (code 39) I tried "check for solutions" but got nothing.

I can't believe just uninstalling a printer could have caused this...but I need help please.

I have an HP Pavilion Slimline
Vista 32-bit

Thanks, Jane

__________________
Jane Cox is offline  
Old 02-29-2008, 11:54 PM   #2
I helped the forums.
 
mattlock's Avatar
 
Join Date: Dec 2005
Location: Ohio
Posts: 4,200
OS: XP SP2, Win 7 Beta, Win 7 RC

My System


HI Jane and Welcome to TSF

Follow the steps listed at http://support.microsoft.com/kb/314060/en-us

Post back with your results.

mattlock is offline  
Old 03-01-2008, 07:00 AM   #3
Registered Member
 
Join Date: Feb 2008
Posts: 2
OS: vista 32-bit



Thank you so much Matt...I can now play my cd/dvd ...but when I opened Roxio to copy a cd...it says that my drive can not be found. And as of yesterday it was working fine...boy I have really messed things up!! I noticed when I went into device manager to make sure the exclaimation mark was no longer on my cd device...that there was an exclaimation mark down at network adaptors...isatap.{8E27221E-4373-448F-A4A0-AB8E87E036D4} with a message of "This device is not working properly because windows can not load the drivers required for this device." (code 31)

Do you have any sugguestions for these problelms. If so I will try them as soon as I get home from work.

Thank you so much for getting my cd/dvd drive playing again.

Jane
__________________
Jane Cox is offline  
Old 03-01-2008, 08:55 AM   #4
I helped the forums.
 
mattlock's Avatar
 
Join Date: Dec 2005
Location: Ohio
Posts: 4,200
OS: XP SP2, Win 7 Beta, Win 7 RC

My System


Glad I could help.

As for Roxio, did you uninstall it before reomving the registry key, as the guide suggested? If not try uninstalling and reinstalling now.

If the error 31 is for the Microsoft ISATAP adapter then don't worry about that one.
http://support.microsoft.com/kb/932520
mattlock is offline  
Old 06-18-2009, 08:12 AM   #5
Registered Member
 
Join Date: Jun 2009
Posts: 1
OS: Vista



My computer says the Regedit has been blocked by the administrator. I am the administrator, and I don't know how this happened. How do I unblock this? Mr Fixit didn't work on my DVD player.
__________________
nursejay04 is offline  
Old 06-18-2009, 09:34 AM   #6
I helped the forums.
 
mattlock's Avatar
 
Join Date: Dec 2005
Location: Ohio
Posts: 4,200
OS: XP SP2, Win 7 Beta, Win 7 RC

My System


Unfortunately, I can't help with your issue. There is know way for me to verify that you are the admin, and it is against TSF rules to assist in circumventing admin settings, passwords, etc.

mattlock is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 08:53 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts