Go Back   Tech Support Forum > Hardware Support > Driver Support

Packard Bell Imedia x2415 windows vista to XP PRO SP2 drivers

This is a discussion on Packard Bell Imedia x2415 windows vista to XP PRO SP2 drivers within the Driver Support forums, part of the Tech Support Forum category. Well...i downgraded from the Dreaded Vista to Windows XP PRO but i cant find the Audio Drivers, Video Drivers, sm


Closed Thread
 
Thread Tools Search this Thread
Old 05-12-2009, 11:17 AM   #1
Registered Member
 
Join Date: May 2009
Location: london
Posts: 2
OS: windows xp pro service pack 2



Well...i downgraded from the Dreaded Vista to Windows XP PRO but i cant find the Audio Drivers, Video Drivers, sm bus controller drivers anywhere.....my pc specs:

Packard Bell Imedia x2415 windows XP PRO SP2, MotherBoard = BV-MCP73VT-PM .

The PC in question is not online and it looks like whenever you start searching for drivers you get these adverts wanting you to download a software which scans your pc....All i need is a compatable driver..why is it soo difficult?
Can somebody help??

Rich

__________________
Ricchh is offline  
Old 05-12-2009, 03:54 PM   #2
TSF Enthusiast
 
TriggerFinger's Avatar
 
Join Date: Jan 2008
Location: USA
Posts: 12,250
OS: XP SP3, PCLinuxOS2007, Win 7 Ultimate


Send a message via MSN to TriggerFinger Send a message via Yahoo to TriggerFinger

Hi Rich,

Is this a laptop?

Also check Device Manager for any unknown devices and/or devices with yellow or red marks. Include their DEVICE INSTANCE ID in your next post.

TriggerFinger is offline  
Old 05-13-2009, 11:58 AM   #3
Registered Member
 
Join Date: May 2009
Location: london
Posts: 2
OS: windows xp pro service pack 2



Triggerfinger,

Its a PC but guess what.................??????
After searching for months ive just finally made a break through...!
It looks like the manufacturer of that motherboard is not packard bell, its BY a company called ECS (www.ecsusa.com)and the code is different from the one on the motherboard! why do these manufacturers not tell people the proper things, why??The new code ive been given is ECS -GF7050VT-M Motherboard which is a far cry from BV- MCP73VT-PM which was actually visible on the motherboard when i opened the PC. Try looking for BV- MCP73VT-PM and you will get nowhere....instead everybody directs you to the packard bell website and all you find are tons of VISTA Drivers and NOT XP drivers.My persistance paid off and thanks to this support guy who mentioned that most of the manufacturers like toshiba, packard bell, etc do not produce their own motherboards....and motherboards for Packard bell Pcs are often made by ECS...
RICCHH
__________________
Ricchh is offline  
Old 05-13-2009, 02:16 PM   #4
TSF Enthusiast
 
TriggerFinger's Avatar
 
Join Date: Jan 2008
Location: USA
Posts: 12,250
OS: XP SP3, PCLinuxOS2007, Win 7 Ultimate


Send a message via MSN to TriggerFinger Send a message via Yahoo to TriggerFinger

If this is a PC desktop then you posted in a wrong section of the forum . Anyways, am I correct to say that you have fixed this already?

Btw, moving this to right section...
TriggerFinger is offline  
Old 06-03-2009, 06:53 AM   #5
TSF Enthusiast
 
Riskyone101's Avatar
 
Join Date: Oct 2008
Location: Chicago, IL.
Posts: 4,410
OS: XP Pro SP3, MCE 2005 sp3, Vista Ultimate SP2, Windows 7 Ultimate

My System


Hello and Welcome to TSF topeson,

You need to start your own thread topeson.
__________________
Riskyone101 is offline  
Old 10-23-2009, 04:47 PM   #6
Registered Member
 
Join Date: Oct 2009
Posts: 1
OS: vista basic



Quote:
Originally Posted by Ricchh View Post
Triggerfinger,

Its a PC but guess what.................??????
After searching for months ive just finally made a break through...!
It looks like the manufacturer of that motherboard is not packard bell, its BY a company called ECS (www.ecsusa.com)and the code is different from the one on the motherboard! why do these manufacturers not tell people the proper things, why??The new code ive been given is ECS -GF7050VT-M Motherboard which is a far cry from BV- MCP73VT-PM which was actually visible on the motherboard when i opened the PC. Try looking for BV- MCP73VT-PM and you will get nowhere....instead everybody directs you to the packard bell website and all you find are tons of VISTA Drivers and NOT XP drivers.My persistance paid off and thanks to this support guy who mentioned that most of the manufacturers like toshiba, packard bell, etc do not produce their own motherboards....and motherboards for Packard bell Pcs are often made by ECS...
RICCHH
wel i used to have te same problem for my drivers not any more thanks to your tread tx
i just wanted to ask if you encounterd any more of these mislabeld parts or if you came across any info on the "imedia d4129 be" while you did your reschearch .(same motherbourds though) so thx for the info

__________________
Debba^^ is offline  
Closed Thread
Gear in this thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question

Gear in this thread


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 07:31 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts