Go Back   Tech Support Forum > Hardware Support > Driver Support

Need driver (Easycap USB 2.0 Capture Device)

This is a discussion on Need driver (Easycap USB 2.0 Capture Device) within the Driver Support forums, part of the Tech Support Forum category. Okay, hello and thank you for taking your time to read this. I am running windows 7 64-bit, and i


Closed Thread
 
Thread Tools Search this Thread
Old 03-15-2010, 03:12 PM   #1
Registered Member
 
Join Date: Mar 2010
Posts: 4
OS: win 7



Okay, hello and thank you for taking your time to read this.

I am running windows 7 64-bit, and i just bought a Easycap capture card, i bought this on amazon, and it is a capture card for gaming consoles/cameras. I have installed the driver from the Cd, but it seems no good, it does not seem to work. I really need help on finding a new driver for this device, PLEASE help

__________________
Proxify is offline  
Old 03-15-2010, 03:22 PM   #2
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 52,356
OS: win 7 pro/ultimate/xp vm



Hi and welcome to TSF this is all I could find for drivers
http://www.usbeasycap.info/support.html

__________________









Eliminate all other factors, and the one which remains must be the truth.
joeten is offline  
Old 03-18-2010, 03:55 PM   #3
Registered Member
 
Join Date: Mar 2010
Posts: 4
OS: win 7



will not let me download anything
__________________
Proxify is offline  
Old 03-18-2010, 04:13 PM   #4
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 52,356
OS: win 7 pro/ultimate/xp vm



ok sorry do not know what has happend there try here http://www.szforwardvideo.com/support/index.html
__________________









Eliminate all other factors, and the one which remains must be the truth.
joeten is offline  
Old 10-02-2010, 09:16 PM   #5
Registered Member
 
Join Date: Oct 2010
Location: Australia
Posts: 1
OS: Windows 7 64-bit



Quote:
Originally Posted by joeten View Post
ok sorry do not know what has happend there try here http://www.szforwardvideo.com/support/index.html
Spybot rejects driver as being "malicious" software??

__________________
burkie67 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 12:07 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts