Go Back   Tech Support Forum > Hardware Support > Driver Support

Ethernet Controller Error Code 28

This is a discussion on Ethernet Controller Error Code 28 within the Driver Support forums, part of the Tech Support Forum category. Hi All, I'm by no means computer savvy, but I've managed to google my way here. I really need help


Reply
 
Thread Tools Search this Thread
Old 08-31-2012, 02:03 PM   #1
Registered Member
 
Join Date: Aug 2012
Posts: 4
OS: Windows XP SP 3


Mistake

Hi All,

I'm by no means computer savvy, but I've managed to google my way here. I really need help -- totally way in over my head!

I just did a factory recovery on my dad's HP Pavilion a1640n desktop and though everything is nice, pretty, and virus free, there's a problem. I tried connecting to our wireless network at home, but that icon doesn't even show in the network connection folder.

After doing some digging, I hop into windows' device manager and find a little exclamation mark next to the ethernet controller. After clicking properties, it shows an error code 28.

I went through the HP website to try and install/update both the original LAN and modem drivers. No luck.

Software & Driver Downloads HP Pavilion Media Center a1640n Desktop PC - HP Customer Care (United States - English)

I then uninstalled it and rebooted it. At start-up it prompts me to install new hardware (ethernet controller) but I don't have the disk/software to install it.

I am about wit's end. I appreciate any and all help you can offer a very sad and desperate gal.


Thanks,
Robin

__________________
gnueynibor is offline   Reply With Quote
Old 08-31-2012, 04:12 PM   #2
TSF Enthusiast
 
Join Date: Dec 2011
Location: North East England
Posts: 5,919
OS: Win 7 Home Premium SP1 64bit



What do you mean by "no luck" when you tried to download the ethernet driver from HP ?

__________________
Tomken15 is offline   Reply With Quote
Old 08-31-2012, 04:23 PM   #3
Registered Member
 
Join Date: Aug 2012
Posts: 4
OS: Windows XP SP 3



Hi Tomken15,

I installed the LAN drive from the HP website and restarted my computer after prompted. After the reboot, I'm still being asked to install the device driver for the ethernet controller. Same error code 28 when checked in the device manager.

My network card is an Intel (R) 82563V 10/100 -- if that helps?? I assumed that once I was prompted to install the ethernet controller, I could direct it to where the driver for my network card is installed (in the system32 folder) but I can't even select it as an option in the drop menu.

Oiy, I feel like I'm running around in circles with my head cut off.

Thank you.
__________________
gnueynibor is offline   Reply With Quote
Old 08-31-2012, 04:39 PM   #4
TSF Enthusiast
 
Join Date: Dec 2011
Location: North East England
Posts: 5,919
OS: Win 7 Home Premium SP1 64bit



Download the driver again and select Save, this should put it into Downloads.

After the download is complete, you should get the prompt to Run and that will take you to the .zip, click on to Extract which will auto show files when extracted.

From those, locate and right click on the setup Application icon to Run as Administrator then follow the prompts.

Programs/drivers usually know where to download to, so you don't have to direct them anywhere and if you changed the location then it may not have know where to find it.
__________________
Tomken15 is offline   Reply With Quote
Old 08-31-2012, 04:47 PM   #5
Registered Member
 
Join Date: Aug 2012
Posts: 4
OS: Windows XP SP 3



Hi,

I don't have internet access on that computer, so I'm downloading them on my desktop and saving it onto a flash drive.

I'm dragging the file onto the desktop and extracting and downloading from there. Once it's done downloading, I'm prompted to restart. But after the reboot, it's asking me to do the same thing all over again --to install the driver for the ethernet controller.

I've tried downloading the network adapter driver directly from intel (http://downloadcenter.intel.com/Deta...adType=Drivers) and going through the same installation process. But after reboot, the same prompt comes back up to install the driver for the ethernet controller. GUH, frustrating!

All of this is really just to solve the lack of internet issue. Are there other alternatives?

Thanks.
__________________
gnueynibor is offline   Reply With Quote
Old 08-31-2012, 04:52 PM   #6
Registered Member
 
Join Date: Aug 2012
Posts: 4
OS: Windows XP SP 3



I'm also considering re-installing the motherboard driver, but I guess my motherboard's too old because I can't find the correct driver for my specific motherboard.

Asus Buckeye P5BW-LA -- any help pointing me in the right direction will be very much appreciated.


Thanks guys.
__________________
gnueynibor is offline   Reply With Quote
Old 08-31-2012, 05:19 PM   #7
TSF Enthusiast
 
Join Date: Dec 2011
Location: North East England
Posts: 5,919
OS: Win 7 Home Premium SP1 64bit



Try the download from these sites (depending on 32 or 64bit OS) and see if it will install when you copy it across.

The first one is a later release than than the second, but I don't know if it is generic for both systems but if it's the wrong version then it won't install.

|MG| Intel Network Adapter Driver for Windows XP 17.3 Download

Intel Network Adapter Driver 16.8.1 for Windows XP 32-bit - TechSpot Drivers

If neither install then you may have to consider doing the reset again and if you still get the alert against the adapter, then at least you'll be able to ID the VEN number.
__________________
Tomken15 is offline   Reply With Quote
Old 08-31-2012, 06:01 PM   #8
TSF Enthusiast
 
Join Date: Dec 2011
Location: North East England
Posts: 5,919
OS: Win 7 Home Premium SP1 64bit



As you will have OEM drivers on there, it isn't advisable to go "shopping around" for those types of drivers and you should only download them from your computer's support site if available, but I've found this driver program reliable for finding the correct drivers SlimDrivers DriverUpdate - Update Drivers for Windows 7, XP, and Vista which you could copy across.

The freebie download button is the one on the left.

__________________
Tomken15 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows Xp slow boot after splash screen
After the Windows Xp splash screen I get about 30 to 40 seconds of blackness (could be more) before the cursor appears. When I start in Safe Mode it takes a long time to load mup.sys but that could just be because it's the last one to load. Here's by most recent ntbtlog.txt: Service...
Sulla Windows XP Support 5 06-17-2013 10:29 AM
Help with blue screen and bug check
My machine bug checked tonight, it has been freezing for a long time but finally generated a dmp file tonight, so I am happy about that. Windbg says the following, can anyone help me determine what is causing this, or translate the windbg file? System specs are at the bottom, thank you.
gte BSOD, App Crashes And Hangs 27 04-18-2012 10:19 PM
Plese help me friends i cant find drivers for my system .I am going to use windows XP
THIS IS MY SYSTEM DEVICE LIST: Device Information Listing for jeeva@FGH-EB4E4A240EF - 2/16/2012 10:25:07 PM Realtek RTL8139 Family PCI Fast Ethernet NIC Chip: Realtek Semiconductor RTL8139/810x Fast Ethernet Adapter Detail PnpID VEN_10EC&DEV_8139&SUBSYS_813910EC&REV_10
jeeva2012 Driver Support 8 02-18-2012 12:48 PM
HP Compaq NC6230 chipset problem
hello, i have a problem with my HP compaq NC6230 notebook. i`m trying to fix it since a week, i`m going to describe what i actually did: 1 it did`nt want to work with the HDD (i think its got a very picky motherboard) and its always showed an error message "1782-disk controller failure" and...
Zs0lt Motherboards, Bios & CPU 7 07-18-2011 02:02 PM
[SOLVED] Rootkit problem: hidden boot sector.
Dearest Techies: I have Windows 7 Home Premium on a Dell Inspiron N7010 Notebook. A few days ago the computer would not start and took me to the windows 7 startup repair utility, and it was unsuccessful in repairing the problem. I ended up having to restore the system to factory settings to get...
Raygumm Resolved HJT Threads 60 07-03-2011 09:07 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 01:33 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts