Go Back   Tech Support Forum > Hardware Support > Driver Support

Drivers for MSI MS-7025VER:1 motherboard

This is a discussion on Drivers for MSI MS-7025VER:1 motherboard within the Driver Support forums, part of the Tech Support Forum category. Hi guys. I was hoping maybe someone can help me with my problem. My son gave me his old, custom


Closed Thread
 
Thread Tools Search this Thread
Old 08-17-2009, 07:29 PM   #1
azl
Registered Member
 
Join Date: Aug 2009
Posts: 2
OS: xp



Hi guys. I was hoping maybe someone can help me with my problem. My son gave me his old, custom build desktop (mine died suddenly), so i swap hard drives, hoping it would work fine. However, i wasnt even able to even get online because I am missing all driver, particulary the one for ethernet card which is build in to the mother bord. I went to MSI website from my laptop to download drivers but wasnt able to because they dont have a driver download section. Im not techie person, so I was hoping maybe some one could help me with that. Thanks in advance

__________________
azl is offline  
Old 08-17-2009, 08:35 PM   #2
TSF Enthusiast
 
bhahar84's Avatar
 
Join Date: Jan 2008
Location: Malaysia
Posts: 1,382
OS: Windows XP SP2, Vista Ultimate

My System


Hi azl

Welcome to TSF

Just as an additional information for you, your MSI MS-7025 VER:1 motherboard also called as K8N Neo2 Platinum.

I have look into the driver link for this motherboard in MSI websites. This will be the link to the website driver page:

K8N Neo2 Platinum Driver's Page

Hopefully this helps you out

__________________
<<Please post a forum on the issue instead of pm me, since I am not really active here for quite some time>>.:CPU-Z::Power Supply::Recuva::Unlocker::SensorsView::PSU Calculator::Everest:.
bhahar84 is offline  
Old 08-18-2009, 06:58 PM   #3
azl
Registered Member
 
Join Date: Aug 2009
Posts: 2
OS: xp



Hi bhahar84,

Thank you for your answer.

I downloaded all drivers, unzipped files, but may be I missed an important step, because I still can't get online.

Thanks in advance.
azl
__________________
azl is offline  
Old 08-21-2009, 11:02 AM   #4
TSF Enthusiast
 
bhahar84's Avatar
 
Join Date: Jan 2008
Location: Malaysia
Posts: 1,382
OS: Windows XP SP2, Vista Ultimate

My System


Hi again azl

What exactly happened after you extracted the driver file? Did you already install the driver on your computer?

Can you try to post the Device Manager screenshot for better picture here.

**You may access the Device Manager this way:
- Right click on the My Computer, choose Properties
- Click on Hardware tab on Properties windows
- Click on Device Manager button
__________________
<<Please post a forum on the issue instead of pm me, since I am not really active here for quite some time>>.:CPU-Z::Power Supply::Recuva::Unlocker::SensorsView::PSU Calculator::Everest:.
bhahar84 is offline  
Old 08-22-2009, 03:16 AM   #5
TSF Enthusiast
 
Riskyone101's Avatar
 
Join Date: Oct 2008
Location: Chicago, IL.
Posts: 4,410
OS: XP Pro SP3, MCE 2005 sp3, Vista Ultimate SP2, Windows 7 Ultimate

My System


Did you install the chipset driver first?

Chipset driver: NVIDIA nForce3 System Drivers?

You can go here for a newer one:
http://www.nvidia.com/object/nforce_winxp_15.16.html

Install this chipset driver and reboot the pc...and tada online again!

__________________
Riskyone101 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 03:12 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts