Go Back   Tech Support Forum > Hardware Support > Driver Support

Driver for Premiere MA88 Microscope Digital Camera

This is a discussion on Driver for Premiere MA88 Microscope Digital Camera within the Driver Support forums, part of the Tech Support Forum category. Hello! I have a Premiere MA88 Microscope Digital Camera. Manufacturer: C&A Scientific. I need a driver. I use WinXP. Thanks


Closed Thread
 
Thread Tools Search this Thread
Old 08-06-2009, 01:17 AM   #1
Registered Member
 
Join Date: Apr 2007
Posts: 2
OS: xp



Hello!


I have a Premiere MA88 Microscope Digital Camera. Manufacturer: C&A Scientific.
I need a driver. I use WinXP.


Thanks

__________________
molngab is offline  
Old 09-14-2009, 08:46 PM   #2
Registered Member
 
Join Date: Sep 2009
Posts: 1
OS: Windows XP



I have exactly the same need and operating system as the above. No answers after one month posting?

__________________
Jay Barnhart Jr is offline  
Old 09-28-2009, 06:01 AM   #3
Registered Member
 
Join Date: Sep 2009
Posts: 2
OS: vista, linux


Send a message via MSN to saavedra29

i have the same camera and vista, and vista cannot recognise the camera
__________________
saavedra29 is offline  
Old 09-28-2009, 06:28 AM   #4
TSF Enthusiast
 
BCCOMP's Avatar
 
Join Date: Jul 2007
Location: New York
Posts: 9,286
OS: Win XP SP3 / Windows 7 Beta / Open Suse

My System


Try this link:
http://www.youding.com/asp/english_index/index.asp

MA88 Driver (NEW)
MA88 Driver (OLD)

Can not confirm these drivers though or what OS's they support
It only contains a Setup exe. file

I have run an AVG Virus scan and it comes up clean.

Bill
__________________
BCCOMP is offline  
Old 10-01-2009, 08:49 AM   #5
Registered Member
 
Join Date: Sep 2009
Posts: 2
OS: vista, linux


Send a message via MSN to saavedra29

BCComp i sent the camera already back.
But thanks for the link!
__________________
saavedra29 is offline  
Old 10-01-2009, 11:59 AM   #6
TSF Enthusiast
 
BCCOMP's Avatar
 
Join Date: Jul 2007
Location: New York
Posts: 9,286
OS: Win XP SP3 / Windows 7 Beta / Open Suse

My System


I am sorry for the late reply, but it was just posted when I came acrossed it.
Like I said in my previous post, I can not confirm the drivers would have worked, but as you know there is not alot of drivers for this out there.
Bill
__________________
BCCOMP is offline  
Old 04-30-2010, 01:48 AM   #7
Registered Member
 
Join Date: Apr 2010
Posts: 1
OS: Mac Os 10.6.1



I have a Premiere binoculate microscope supplied with the MA88 digital eyepiece. I use a Mac running OS 10.61. I run Parallels 5.0 to use the Mac in Windows XP. The driver supplied will not install in emulation [XP]mode. It does install on a dedicated Wintel machine. Is there a driver that will install in emulation mode?
__________________
andyatkc is offline  
Old 03-15-2011, 08:11 AM   #8
Registered Member
 
Join Date: Mar 2011
Posts: 3
OS: windows 64bit Vista



I know most of the previous posts are very old.
I had the same camera, I couldn't get it to work with Vista, I called 703-330-1413 and talked to someone. He sent me a new camera and new software. I then sent the old one back, this was done within one year of original purchase. The new software works great on the microscope but it has overridden a file for my photoshop program. I am now searching for a way to fix Adobe Photoshop elements 7 editor mode. I may have to make another phone call.
__________________
cindyg493 is offline  
Old 03-15-2011, 09:15 AM   #9
Microsoft-Team Manager
Hardware - Team Manager
 
joeten's Avatar
 
Join Date: Dec 2008
Location: Glasgow Scotland
Posts: 53,629
OS: win 7 pro/ultimate/xp vm



Hi and welcome to TSF please make a new thread and someone will try to assist you with your issue try the vista\win 7 area

__________________









Eliminate all other factors, and the one which remains must be the truth.
joeten is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 08:13 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts