Go Back   Tech Support Forum > Hardware Support > Hard Drive Support

my passport wd10tmvw-11zsms1 problem

This is a discussion on my passport wd10tmvw-11zsms1 problem within the Hard Drive Support forums, part of the Tech Support Forum category. Hi i have a WD Passport 1TB external hard drive that was dropped, when plugged in it is being seen


Reply
 
Thread Tools Search this Thread
Old 07-16-2012, 05:47 PM   #1
Registered Member
 
Join Date: Jul 2012
Posts: 3
OS: xp



Hi i have a WD Passport 1TB external hard drive that was dropped, when plugged in it is being seen in device manager and it says its working properly. It shows up in my computer as a local drive and in the properties it shows 0 bytes, before the drop it showed up as my passport. The light on the drive blinks constantly. The drive has a ton of family pictures that i would like to get. Is this drive junk or can I retrieve my files.

__________________
mikerod61 is offline   Reply With Quote
Old 07-16-2012, 05:53 PM   #2
TSF Team, Emeritus
 
spunk.funk's Avatar
 
Join Date: May 2010
Location: Los Angeles
Posts: 27,674
OS: Windows 8 64, Windows 7 64 Bit SP1, XP SP3, Mac OSX

My System


Quote:
i have a WD Passport 1TB external hard drive that was dropped
You probably damaged the USB controller inside the enclosure. You can remove the HDD from the enclosure and either attach it Internally to a desktop computer, using a USB adapter or put it in another USB Enclosure with a power adapter.
You can try and recover your files using GetDataBack NTFS. You will need another drive of the same size or larger to restore your files to.

spunk.funk is offline   Reply With Quote
Old 07-26-2012, 06:24 PM   #3
Registered Member
 
Join Date: Jul 2012
Posts: 3
OS: xp



opened my drive and found the usb connector is soldered on the drive it does not have a small circuit board that you unplug is there somthing else i could try.
__________________
mikerod61 is offline   Reply With Quote
Old 07-26-2012, 07:57 PM   #4
TSF Team, Emeritus
 
spunk.funk's Avatar
 
Join Date: May 2010
Location: Los Angeles
Posts: 27,674
OS: Windows 8 64, Windows 7 64 Bit SP1, XP SP3, Mac OSX

My System


This is a new fangled drive that WD has introduced lately with different connectors.
The Drop has probably damaged the drive anyways. You might want to contact WD support and see if they can provide an adapter or something. Contact Us
spunk.funk is offline   Reply With Quote
Old 07-26-2012, 11:41 PM   #5
Registered Member
 
Join Date: Jul 2012
Posts: 3
OS: xp



Thanks for the help
__________________
mikerod61 is offline   Reply With Quote
Old 07-27-2012, 07:04 AM   #6
Registered Member
 
Join Date: Jul 2012
Posts: 55
OS: .



Hi

Did you drop it while it was connected to the computer and powered on?

We can run some tests that are gentle and might help you determine what to do next.

James
__________________
NeverSayDie is offline   Reply With Quote
Old 07-27-2012, 07:36 PM   #7
Registered Member
 
Join Date: Jul 2012
Posts: 12
OS: Win7



WD won't help. Not a chance, they don't care and don't do anything like this. Besides, there is no adapter to use. If you dropped it and it stopped working, even though USB connection looks fine - there is mechanical damage. If you don't care about data - RMA it or sell on eBay (will get a good buck for that, still)

__________________
hddsupplier is offline   Reply With Quote
Reply
Gear in this thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speaker Problem -- HK Soundsticks II not working
Hi all, First post here so sorry if I missed some rules. I bought HK Soundsticks II a few years ago, and recently they stopped working. The speakers would turn on, the sub would glow its usual blue light, but the input cable -- the green-tipped one which connects to the audio device -- didn't...
willrobin1 Sound Cards 6 03-25-2013 01:46 AM
Weird Monitor Problem
Hello Ladies and Gents, First time posting here as i can usually troubleshoot an issue and solve it on my own or find the same problem somewhere on the net. However, I have run into an issue that I cannot figure out, nor can I find someone who had a similar issue. I am working on a system...
Slylok Video Card Support 3 12-09-2011 04:36 PM
Physical Memory Dump Problem
Hi..i have a Dell Inspiron N5010 laptop which i purchased last month..it was working fine until yesterday when i got a blue screen saying "Physical Memory Dump" . Ans since yesterday i have faced this problem 3 times and every time the problem appears i have to restart my laptop. This is the...
ygssoni BSOD, App Crashes And Hangs 6 10-29-2011 04:21 AM
Limited Connectivity Problem (after few time of successfull network establishment)
Dear All, Hope u all will be f9. Now a days i m in hell of trouble i think due to my OS problem. I m using Window Vista 32-bit SP2 Home Premium. I am using Dell Studio 1537. I am facing this problem recently and i dont know what is the cause behind it. The problem is...
ushahzad Windows 7 Support, Windows Vista Support 5 01-28-2011 09:31 AM
Problem after problem, xp repair install
OS: XP Pro GPU: Asus Radeon HD 3850 CPU: AMD Athlon 64 X2 5000+ 2.6GHz Dual-Core Black Edition Processor MoBo: Foxconn A7GM-S RAM: OCZ SLI 2GB (X1) DDR2 800 SDRAM 2.1V; Crucial Ballistix Tracer 2GB (2 x 1GB) DDR2 800 SDRAM 2.2V. (btw just noticed they run dif timing doh) Power Supply: RAIDMAX...
komayaka Windows XP Support 2 01-25-2011 03:22 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question

Gear in this thread


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 11:57 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts