Go Back   Tech Support Forum > Automotive Center > Automotive Support

[SOLVED] Dodge Neon 2003 Medium leak in evaporative system?

This is a discussion on [SOLVED] Dodge Neon 2003 Medium leak in evaporative system? within the Automotive Support forums, part of the Tech Support Forum category. My Check engine light is now on solid, and I stopped by a shade tree mechanic who has the machine


Closed Thread
 
Thread Tools Search this Thread
Old 08-15-2007, 03:44 PM   #1
Registered Member
 
Join Date: Aug 2007
Location: Tennessee
Posts: 4
OS: MacOS



My Check engine light is now on solid, and I stopped by a shade tree mechanic who has the machine to diagnose the codes and told me that I have a medium leak in my evaporative system, which he just said was part of the emissions system and that I'd need to take it to a dealer to fix.

What exactly does this mean, and is it an expensive fix?

The car is running fine.

__________________
KrK007 is offline  
Old 08-15-2007, 06:11 PM   #2
TSF Gearhead
 
Join Date: Mar 2007
Location: Brisbane Australia.
Posts: 592
OS: All Systems, mainly Linux



Good Morning KrK007, the evap system is generally a fuel tank vapour storage system that allows reuse of vapours one way or another without and venting to atmosphere.
These systems can be quite complex and contain various components that may fail of give odd effects.

It may be worth checking your fuel tank cap sealing ("o" ring) and the valve located in it for operation or replace the tank cap, this can give that kind of error.

Disconnecting the battery for a short period may extinguish the light, but the code will remain stored.

Further to this carefully examine the piping from the tank to the carbon collector and all those connections for integrity.

A service manual for that vehicle should be avaiable from your motor supermarket at relatively cheap cost that will ellucidate on the system operation and componentry.

Others will have different ideas.

Cheers, qldit.

__________________
qldit is offline  
Old 04-14-2008, 02:14 AM   #3
Registered Member
 
Join Date: Aug 2007
Location: Tennessee
Posts: 4
OS: MacOS



The problem may have been the gasoline tank cap. Ironically, someone stole mine and discarded their old cap while my car was parked at work. This meant I bought a new cap for the Neon. Since using this new cap, the Check engine light has not re-lit....

... case of misfortune being good fortune, it seems.
__________________
KrK007 is offline  
Old 04-14-2008, 04:20 AM   #4
TSF Gearhead
 
Join Date: Mar 2007
Location: Brisbane Australia.
Posts: 592
OS: All Systems, mainly Linux



Good Evening KrK007, yes it would appear that may have most likely been your problem, modern cars can be very fickle, not like the old days.

In view of the problem appearing to have been addressed I suggest we can consider case closed.

Well done there, congrats on light out, thankyou for the feedback.

That code will remain in the computer indefinitely and may be read at some future time so ensure you remember this circumstance.
This does not present a problem, but at some time if those codes are read with a reader you might clear that one from the computer memory, to avoid chasing non existent faults.
Removing battery power for a period simply unlatches the warning lamp indication, it doesn't clear memory.

Cheers, qldit.
__________________
qldit is offline  
Old 08-08-2008, 10:02 PM   #5
Registered Member
 
Join Date: Aug 2007
Location: Tennessee
Posts: 4
OS: MacOS



Well, here it is months later and the problem has returned.

I'm getting Evap system leak - Small (P 0456) now.

Had the code read, cleared, 2 weeks later the Check engine light came back on, same code.

It feels to me like the car seems to be suffering from a power loss too... but that could just be the air-conditioning. Wow it's strong and cold but man it chops 5-7 mpg off my mileage when I use it.... even so though it feels like just recently the car's power and acceleration have dropped off.
__________________
KrK007 is offline  
Old 08-10-2008, 11:55 AM   #6
Administrator
Automotive Team Manager
 
Midnight Tech's Avatar
 
Join Date: Dec 2001
Location: Hunting the next geocache
Posts: 4,628
OS: Windows 7/Windows XP Home/Pro SP3/Windows 98SE/Fedora Core 6/RH 7.2 with Autopoint/TAMS II



Set back to "unsolved" status.....
__________________

Please post all questions in the appropriate forum. Questions sent by email or PM will not be answered.
Interested in Trek gaming? Check out the Dynaverse!
Proud supporter of the Carolinas Aviation Museum - the final home of Flight 1549.
Confession might be good for the soul, but it hurts the heart like hell.
Midnight Tech is offline  
Old 09-14-2009, 01:14 AM   #7
Registered Member
 
Join Date: Aug 2007
Location: Tennessee
Posts: 4
OS: MacOS



Ah, I forgot about this thread. :D It turns out it was the gas cap all along. The light stayed out after the code was cleared and the cap was kept tight. :D
__________________
KrK007 is offline  
Old 09-14-2009, 10:02 AM   #8
Administrator
Automotive Team Manager
 
Midnight Tech's Avatar
 
Join Date: Dec 2001
Location: Hunting the next geocache
Posts: 4,628
OS: Windows 7/Windows XP Home/Pro SP3/Windows 98SE/Fedora Core 6/RH 7.2 with Autopoint/TAMS II



Gonna mark this one solved and close it!

__________________

Please post all questions in the appropriate forum. Questions sent by email or PM will not be answered.
Interested in Trek gaming? Check out the Dynaverse!
Proud supporter of the Carolinas Aviation Museum - the final home of Flight 1549.
Confession might be good for the soul, but it hurts the heart like hell.
Midnight Tech is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
system crashes
i keep gettin sysyem crashes for some time now but i cant get to the bottom of them. i saved the xml file and this is wot it says anyone got any ideas wot is causin them cheers :rolleyes: <?xml version="1.0" encoding="Unicode" ?> - <SYSTEMINFO> - <SYSTEM> <OSNAME>Microsoft Windows XP...
dexyweescot Windows XP Support 2 03-16-2008 01:39 AM
Acer Aspire 9410 Runs very slow and all audio stuters
I have had my laptop for almost a year now, and i started having problem after about three months. All audio stutters like it is skipping, run very slowly, all programs take a long time to start up, When I turn it on it takes about twenty minutes to fully boot up. I called acer and they said that...
mw39er0 Windows XP Support 18 08-25-2007 03:40 AM
Keep losing some internet facilities
Hi there I have tried posting this elsewhere and have had no replies so I thought I would post my hijackthis logs and see if anyone can help me here. Symptoms I am trying to overcome: About twice a day my computer (connected to NTL broadband via a router) ceases to gain access to ftp,...
Struggling_here Inactive Malware Help Topics 16 10-20-2005 04:39 AM
Cool Web Search/New Strain
I knew I had problems when I walked into the compuer room and saw my compter trying to set up the virtual mail server. I promptly shut it down and did a htl and it showed up in 23 as tcp, did not save that log. I ran every possible program that I have even did a Pandora and Micro Trend on line...
pope1901 Resolved HJT Threads 8 07-12-2005 10:48 AM
My PC and I am losing it. Hijacker log. THANKS ahead
:4-dontkno My norton and free adaware did not detect yet in another scan for last weeks...2 embedded Trojan Horses: Downloader.Agent.2.AA & 2.AS I can not get rid of..and have tried every source available. PC now is getting worse everyday. Locking up more and more. Can not pull up pages. Have to...
Amberss Inactive Malware Help Topics 36 01-25-2005 09:01 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 07:28 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts