Go Back   Tech Support Forum > Automotive Center > Automotive Support

93 jeep grand cherokee rear windows wont work!?

This is a discussion on 93 jeep grand cherokee rear windows wont work!? within the Automotive Support forums, part of the Tech Support Forum category. I have a 93 jeep grand Cherokee limited and the rear windows wont work at all and the passenger window


Reply
 
Thread Tools Search this Thread
Old 07-02-2008, 02:47 PM   #1
Registered Member
 
Join Date: Jul 2008
Posts: 2
OS: win98


Question

I have a 93 jeep grand Cherokee limited and the rear windows wont work at all and the passenger window only works from driver controls. I took the door panels off and checked for power to the switch but there wasn't any.

I WOULD APPRECIATE IT IF SOMEONE COULD HELP ME OUT IN FINDING THE PROBLEM??????

__________________
93jeep2008 is offline   Reply With Quote
Old 07-03-2008, 07:15 AM   #2
Registered Member
 
Join Date: Jul 2008
Posts: 21
OS: vista



i have worked on two grand cherokees with the same exact problem. open you drivers door. look where the hinges for the door is and you will see a flexible rubber tube that the power wires for you windows and locks runs through. See if that rubber tube is damaged. For some reason on those jeep grand cherokees that tube gets damaged and the wires inside get cut. if you do find damaged wires just a simple repair of those wires and to the tube will fix it. That tube may not always look damaged. so you may have to look inside the tube to see any wire damage. I think the problem comes from a bad angle of those wires when the door closes and from years of opening and closing the doors the wires get bent back and forth and break in two.

__________________
ColinRyan2 is offline   Reply With Quote
Old 07-04-2008, 09:48 AM   #3
Registered Member
 
Join Date: Jul 2008
Posts: 2
OS: win98



thanks man i will check them out
__________________
93jeep2008 is offline   Reply With Quote
Old 05-05-2009, 08:37 AM   #4
Registered Member
 
Join Date: May 2009
Posts: 1
OS: xp



Thank you ColinRyan2. I have a '93 Jeep GCL. I thought about the possibility of the wires in the boot, but noticed the boot was in great condition and quickly dismissed that option. I of course did the usual of checking the fuses, the contacts in the switch itself, etc. I looked inside the boot and at least 3 wires were completely snapped. Bingo.
__________________
TheEraser is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 05:51 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts