Go Back   Tech Support Forum > Automotive Center > Automotive Support

2000 Mitsubishi eclipse rs 2.4 will not start

This is a discussion on 2000 Mitsubishi eclipse rs 2.4 will not start within the Automotive Support forums, part of the Tech Support Forum category. While starting the engine, saw small flash and smoke from steering column. Engine will not start or even turn over


Reply
 
Thread Tools Search this Thread
Old 09-26-2011, 09:56 AM   #1
Registered Member
 
Join Date: Sep 2011
Posts: 4
OS: winxp 2002 edition service pack 3



While starting the engine, saw small flash and smoke from steering column. Engine will not start or even turn over now. Found ignition switch burnt up. Replaced the ignition switch and it will now crank over but will not run.

In the under hood fuse and relay panel there are three relays grouped together toward the front of the car. One is marked AT the others are only identified by an engine symbol. I'm sure one is the MFI relay. If I jump the contact side of all the relays on the relay sockets, engine will crank over and start. Seems to run OK.

Checked coils in relays and they all read about 74 ohms. With key on there is power to one side of the contact sockets on all relays and to one side of the coil on all relays.

What do I need to check now? Thanks for any help.

Jerry

__________________
VNVet67 is offline   Reply With Quote
Old 09-26-2011, 02:38 PM   #2
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



Hi VNVet67


You will need a wiring diagram to trace the wires to the fuse/relay box, but having no power to all three there is definitely something wrong with the ignition relay or the harness. I'm guessing that there is a fusible link that burnt out to have knocked out the relay panel, the thing is a short circuit of that magnitude travels along the harness fusing wires together. You need to probe all the power wires that go to the ignition relay, if there is power then the relay isn't switching. Take relay cover off by prying it with a very fine screwdriver, inspect the contacts if they looked burned out carefully clean them with soft emery paper. Do a continuity test using your DVOM and test the trigger side of the relay not the coil by opening and closing the contact points manually. If there is no continuity on the trigger side replace the relay.



post back your findings.

__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 09-26-2011, 03:19 PM   #3
Registered Member
 
Join Date: Sep 2011
Posts: 4
OS: winxp 2002 edition service pack 3



thanks for the reply

there is power to the fuse and relay panel. the switching side of the relays goes to ground through a ECM. But haven't found an ignition relay. I was also thinking about a fuseable link but was not sure where it would be located.
__________________
VNVet67 is offline   Reply With Quote
Old 09-26-2011, 03:31 PM   #4
TSF Enthusiast
 
Join Date: Dec 2007
Posts: 730
OS: Windows 2000



So you put those relays to ground yourself, effectively bypassing the ECU? With a nasty little electrical arc like you experienced, I wouldn't be surprised if it got fried. Check your wiring and fuses first, but I'd think about ordering another ECU (used or from a yard) to have as a backup.
__________________
Troy_Jollimore is offline   Reply With Quote
Old 09-26-2011, 03:45 PM   #5
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



Mitsubishi have joint connectors that are on a bus line, these bus lines inter-connect every system on the car are those ok ?


Quick question: Do you hear the relay switch when you turn the key ?
__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 09-27-2011, 11:35 AM   #6
Registered Member
 
Join Date: Sep 2011
Posts: 4
OS: winxp 2002 edition service pack 3



Hey Troy

Yes that's right just bypassing it. Still looking, i'm old so it takes awhile.
__________________
VNVet67 is offline   Reply With Quote
Old 09-27-2011, 11:45 AM   #7
Registered Member
 
Join Date: Sep 2011
Posts: 4
OS: winxp 2002 edition service pack 3



Hey Octaneman

Only one of them clicks. the other two does not. Thanks for all the info you have given me.
__________________
VNVet67 is offline   Reply With Quote
Old 09-28-2011, 08:51 AM   #8
TSF Enthusiast
 
Join Date: Dec 2007
Posts: 730
OS: Windows 2000



It's not because we're old. It's because we take the time to do QUALITY work! ;)

__________________
Troy_Jollimore is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't see the C & D drive in disk management! Please help.
Disk manager can't locate C & D drive, only DVD/CD drive. Win Explorer shows both drives are OK. I think it is possibly infected with a virus as i also encountered a few Blue Screen of Deaths (BSOD). I wanted to do a full reformat, but could not do so as i can't locate my C & D drives. The...
seanfoo2005 Resolved HJT Threads 33 03-21-2011 05:16 AM
Plug and Play Causes Services to run 100%
About i week ago I booted my computer and noticed that it was running extremly slow. I opened task manager and found that services.exe was running up my CPU. After going through msconfig and using trial and error, i found that it wouldn't drive it up if i had Plug and Play unchecked. So my...
logicalman Resolved HJT Threads 46 02-09-2011 04:51 AM
Virus redirecting all of my pages.
My computer is completely screwed! First no sound now this! Almost every time I try to do something on the internet my page is getting redirected to something else! I always have to rush to click the X button to stop the page from loading. But I want a permanent fix! Please help.
TheresMoreToMe Resolved HJT Threads 26 01-26-2011 04:48 PM
REMOTE Hacker - Bank Accounts, Email, Facebook and Administration Control
Hello Tech Support Members. This is long, though it is a culmination of past (solved threads, that aren't) information all in one as well as an all around plea to the selfless experts. I am creating this final last ditch thread to help shed some light on a real enigma that has been cloaking my...
fiLmNut Virus/Trojan/Spyware Help 4 01-21-2011 05:33 AM
Need some help. Virus/malware Thanks!
:upset: Tons of popup windows saying this file is infected and that file is infected, do I want to open up my security software (and this isn't my CA security suite doing this). Even if I'm using Firefox random windows in IE will open with (******.com/porno.com/adult.com). Hardly any...
R_Willis Inactive Malware Help Topics 7 01-20-2011 09:50 AM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 09:24 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts