Go Back   Tech Support Forum > Automotive Center > Automotive Support

1997 S10 HELP!! Turns over but dont start!

This is a discussion on 1997 S10 HELP!! Turns over but dont start! within the Automotive Support forums, part of the Tech Support Forum category. I need some help!! I have a 97 S 10 pickup extended cab with a v6 vortec engine. Truck will


Reply
 
Thread Tools Search this Thread
Old 09-14-2011, 01:59 PM   #1
Registered Member
 
Join Date: Sep 2011
Posts: 5
OS: xp



I need some help!! I have a 97 S 10 pickup extended cab with a v6 vortec engine. Truck will spin over like it wants to crank but it will go back dead and wont bust off and start. It acts like it is not getting enough fuel to it.
First thing I tried was replacing the map sensor which was the code it was throwing at first, ended up replacing that twice. Didnt help it. Still same problem.
Next replaced the fuel pump with a brand new one and a fuel filter. Still same problem, replaced rotory button, and all new spark plugs, put it on the computer and it is giving no codes at all. Has good compression, good fuel pressure, good fire but cannot figure out what the issue is! Need some help please!!!
I have been working on this truck for months here and there trying to figure out what the problem is and have tried everything I know to do and or try with having no codes to go by and have gotten no where. any help alt all would be greatly appreciated !!

__________________
S10HelpMe is offline   Reply With Quote
Old 09-14-2011, 04:50 PM   #2
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



Hi S10helpMe


Sounds like there's no fuel going through the injectors, hook up a node light to check for injector pulse, do that for all the injectors. Follow the injector plug harness look for any broken or loose grounds to the computer. The next thing to check is injectors themselves, use a DVOM to check their resistance if you have a stethoscope have an assistant crank the engine while you listen for injectors clicking on/off. Remove one or two spark plugs, if they are dry it means there's no fuel going into the cylinder.


Note: Inspect the EGR by pushing the diaphragm with your fingers, if its open the engine will never start.


post back your findings.

__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 09-15-2011, 05:57 AM   #3
Registered Member
 
Join Date: Sep 2011
Posts: 5
OS: xp



Thank you for your reply! I took the fuel injectors off yesterday because I had tried getting someone to turn key on while i pulled them loose to see if any fuel was coming out of them. There wasnt so I took it off to try and clean it out to see if it helped any. Plan to replace it if that is indeed the problem. I just know I hate to keep putting money into it to get the same result. But hopefully this will be the problem and will fix it! I hope!! Let me ask this when I took the injectors out and had someone turn key over it should have sprayed fuel out the injectors right?
__________________
S10HelpMe is offline   Reply With Quote
Old 09-15-2011, 05:58 AM   #4
Registered Member
 
Join Date: Sep 2011
Posts: 5
OS: xp



I would have done the other that you said first but I had already taken it off and tried cleaning it before I got your response. However I plan to put it back on today and then I can try your suggestions as well but I was sure it should spray fuel when the key is turned to the on position? Is this accurate?
__________________
S10HelpMe is offline   Reply With Quote
Old 09-15-2011, 07:15 AM   #5
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



The moment the key is turned on the computer turns the pump on for 3 seconds to pressurize the fuel line its called the 3 second delay. When the engine cranks over and the computer sends the pulse to open the injector is where the injector sprays fuel, if there is no pulse the injector won't open. Don't start replacing injectors if you haven't tested them or you're not sure if there's a pulse, the problem could be coming from the computer not the injectors.
__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 09-15-2011, 10:51 AM   #6
Registered Member
 
Join Date: Sep 2011
Posts: 5
OS: xp



Would all this happen and not throw any codes?
__________________
S10HelpMe is offline   Reply With Quote
Old 09-15-2011, 01:16 PM   #7
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



Yes, injectors do not have sensors to set off a code when pulse is cut off. The only way to know if an injector is bad is when the computer sets off a series of codes of a too lean or rich mixture on the emission side from the O2 or Map sensor.
__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 09-15-2011, 05:16 PM   #8
Registered Member
 
Join Date: Sep 2011
Posts: 5
OS: xp



Well I am at a standstill until I can go buy the new injectors, the cleaner I left them in to soak overnight ate away at the hoses! Go figure! What was i thinking?!?!

I am going to try and get one in the next few days put it on and maybe that will fix it.

I will post back to let you know if that fixes it or not.
__________________
S10HelpMe is offline   Reply With Quote
Old 09-16-2011, 05:46 AM   #9
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



If your truck has the spider injection system when replacing injectors replace the fuel regulator. GM has modified the injection kit because on the 4.3's and 5.7's the fuel regulator leaks.
__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 09-21-2011, 03:10 PM   #10
TSF Enthusiast
 
Join Date: Dec 2007
Posts: 730
OS: Windows 2000



If you want to test it in the meantime, pull the fuse for the fuel pump relay (and the injectors if you know where it is, maybe even unplug their electrical connections). If you just crank the engine to see the injectors fire, you'll get doused in a HUGE cloud of fuel vapour. Not only off-putting, but VERY DANGEROUS if it ignites!

With no chance for the injectors to puff gasoline (since they're not inserted in your head), take out your spark plugs and pour a tablespoon or so of gas directly into the cylinders. Replace the sparkplugs and try to start the truck. If everything is good, it should sputter and run for a second or so before stopping. If it doesn't start, or is a hard start, then most likely something is wrong with your timing.

__________________
Troy_Jollimore is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
XP PRO no start when I push start button
I have recently formatted my primary hard drive and reloaded XP Pro. I then had issues with it wanting to start from the CD at one point but after a few reboots a second format / reinstall and numerous windows updates it seems to be working fine with the exception of ... if I turn the machine off...
cmorejava Motherboards, Bios & CPU 8 01-29-2011 10:51 AM
Virus redirecting all of my pages.
My computer is completely screwed! First no sound now this! Almost every time I try to do something on the internet my page is getting redirected to something else! I always have to rush to click the X button to stop the page from loading. But I want a permanent fix! Please help.
TheresMoreToMe Resolved HJT Threads 26 01-26-2011 04:48 PM
REMOTE Hacker - Bank Accounts, Email, Facebook and Administration Control
Hello Tech Support Members. This is long, though it is a culmination of past (solved threads, that aren't) information all in one as well as an all around plea to the selfless experts. I am creating this final last ditch thread to help shed some light on a real enigma that has been cloaking my...
fiLmNut Virus/Trojan/Spyware Help 4 01-21-2011 05:33 AM
Need some help. Virus/malware Thanks!
:upset: Tons of popup windows saying this file is infected and that file is infected, do I want to open up my security software (and this isn't my CA security suite doing this). Even if I'm using Firefox random windows in IE will open with (******.com/porno.com/adult.com). Hardly any...
R_Willis Inactive Malware Help Topics 7 01-20-2011 09:50 AM
Viper 5901 REMOTE START HELP ASAP PLZ
Ok i have a viper 5901 installed in my 99 civic ex 5 speed manual transmission. everything works real good and great, im having a hard time figuring why my remote start doesnt work at all. When i have the brain programmed for automatic transmission, the remote start doesnt give me an error and i...
ek souljah Car Audio and Alarms 5 01-01-2011 08:32 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 06:00 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts