Go Back   Tech Support Forum > Automotive Center > Automotive Support

1990 Chevy 1500 4.3l V6

This is a discussion on 1990 Chevy 1500 4.3l V6 within the Automotive Support forums, part of the Tech Support Forum category. Hi I am working on a 1990 Chevy truck with a 4.3l V6 TBI. I have rebuild the TBI and


Reply
 
Thread Tools Search this Thread
Old 03-28-2012, 11:48 AM   #1
Registered Member
 
Join Date: Mar 2012
Posts: 1
OS: Mac



Hi I am working on a 1990 Chevy truck with a 4.3l V6 TBI. I have rebuild the TBI and replaced the distributor cap and rotor, but that has not fixed the problem. It starts but dies after its started you can pump the gas pedal to keep it running but it will not idle up it dies when you give it any gas. While its running there is fuel spraying from the injectors down the venturies so it's getting fuel. The truck has been sitting for awhile and I have put fresh fuel in it. Any help would be great. Thanks Sam

__________________
76dodge is offline   Reply With Quote
Old 03-28-2012, 04:50 PM   #2
Automotive Team
Moderator
 
wolfen1086's Avatar
 
Join Date: Oct 2007
Location: Rainey, Virginia Beach, Virginia
Posts: 10,404
OS: Ubuntu 14.04.1



Hows the fuel pump?theres a difference between spraying fuel and spraying ENOUGH fuel,and, pumping the gas pedal on a TBI unit is useless theres no fuel bowl in that thing, is the map sensor hooked up?
are there any engine codes? If you don't have a scanner use a paper clip to read them jump A and B and turn the ign key to the on position and record the codes and post them on here. Also check the maf sensor too, either of those two will ruin your day.


4.3 V6 TBI GM......been there done that

__________________

Hampton Roads Virginia, I've been around the rock three times and this place was NOT on my top ten list of places to live
wolfen1086 is offline   Reply With Quote
Old 03-28-2012, 05:33 PM   #3
Moderator Automotive Center
 
octaneman's Avatar
 
Join Date: May 2009
Posts: 2,723
OS: WINXP



Hi 76dodge


Hook up a fuel pressure gage and see where the pressure is at. Fuel thats been rotting in the tank longer than 6 months without conditioner will gum up the fuel pump and fuel filter and chances are good you will have to replace both.
__________________



" What were dealing with is the battle between the future and the past, between the powers that were and the powers that have yet to be. " --- John Perry Barlow
octaneman is offline   Reply With Quote
Old 03-28-2012, 07:55 PM   #4
Automotive Team
Moderator
 
wolfen1086's Avatar
 
Join Date: Oct 2007
Location: Rainey, Virginia Beach, Virginia
Posts: 10,404
OS: Ubuntu 14.04.1



Fuel in the tank longer than six months can be used to thin Varnish out a little too. that is after ya strain the chunks out
__________________

Hampton Roads Virginia, I've been around the rock three times and this place was NOT on my top ten list of places to live
wolfen1086 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
03 chevy malibu
Hi the problem I am having is my gas/temp gage fuse under the hood keeps blowing out when I turn on the heat or ac fan. I have replaced my blower motor resistor and this continues to happen! any ideas or suggestions? Thank you:4-dontkno
mncas Automotive Support 27 05-22-2014 03:31 AM
Dell Vostro 1500 Issues
Ok, so I've been communicating with another part of this forum because earlier it was just a problem with BSODs. Now, I've been told to post in the hardware forum, and I hope I'm posting in the correct section. I've gone over what's happened with my laptop for the most part here. For the...
Whitechaco Laptop Support 11 03-19-2012 07:58 PM
CAr problem. Mazda Tribute V6
I am having a problem with my Mazda Tribute V6 engine. It uses the same engine with Ford Escape V6. Two plugs are not firing well. I have even removed the top cylinder of that side and have changed the valves and have also grinded it yet the problem have continued. Out of six plugs, only four are...
Frank Akubue Automotive Support 2 03-16-2012 03:52 AM
chevy cavalier CPS?
yes me and my uncle picked up a cavalier and we are haveing trouble finding theCPS everywhere we look online says in the front and the books say in the back of the motor but we can not find it anywhere on the motor so any insite on this delemia would be helpfull
tony dubz Automotive Support 3 03-10-2012 05:19 AM
[SOLVED] 96 Chevy won't start
I have a 96 Chevy Silverado, Vortec 5.7 factory setup. I worked in a dealership and used a fuel injection service on my truck not knowing that model engine wouldnt take it well. The truck ran fine but surged and died when stopping (red lights, stop signs). Accelerating and normal driving were fine....
ghenry Automotive Support 5 03-07-2012 08:10 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 06:38 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts