Go Back   Tech Support Forum > Hardware Support > Removable Media Drives

[SOLVED] MATSHITA DVD-RAM UJ-850S ATA Device driver error Code 39.

This is a discussion on [SOLVED] MATSHITA DVD-RAM UJ-850S ATA Device driver error Code 39. within the Removable Media Drives forums, part of the Tech Support Forum category. I have Windows Vista Home Premium as originally installed in my ACER Aspire 4720Z, furnished with MATSHITA DVD-RAM UJ-850S ATA


Closed Thread
 
Thread Tools Search this Thread
Old 01-17-2008, 09:14 PM   #1
Registered Member
 
Join Date: Jan 2008
Posts: 4
OS: Windows Vista


Question

I have Windows Vista Home Premium as originally installed in my ACER Aspire 4720Z, furnished with MATSHITA DVD-RAM UJ-850S ATA Device.

My daughter has an ACER Aspire 5520-5334, furnished with Optiarc DVD RW AD-7560A ATA Device.

They both were purchased same date. Both produced the same problem today (after around 2 months):
"Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

I realized many persons with this same hardwares and Vista have this "Code 39" problem, and so far I can't find a solution (not even at the ACER website)...
I am NOT a computer expert, and I live in Costa Rica. But I can follow instructions.
Please your help.
Please your advise.

__________________
hmunozg is offline  
Old 01-17-2008, 10:11 PM   #2
Registered Member
 
Join Date: Jan 2008
Posts: 4
OS: Windows Vista



I was able to fix the problem by following the advise of Mr. TECHPRO5238 as described for a friend (Mr.Dabit) and his Nec drive. Great advise, great website. Thanks a lot.
Now, just one additional question....why the DVD-RAM driver is fixed by removing the "upper filter" and "lower filter" in HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Class \ {4D36E965-E325-11CE-BFC1-08002BE10318}
Thanks for your time...

__________________
hmunozg is offline  
Old 01-18-2008, 05:54 AM   #3
TSF Enthusiast
 
bhahar84's Avatar
 
Join Date: Jan 2008
Location: Malaysia
Posts: 1,382
OS: Windows XP SP2, Vista Ultimate

My System


Hi hmunozg!!

My name is bhahar. Glad to hear that you solved your issue

By the way, the deletion of upper filter and lower filter is important because these particular registry string did cause a problem to the cd/dvd drive. There are many reason for this to happen, such as installing the iTunes. It will create a string on your registry, which is the upper filter and lower filter, that proven to cause problem to drive.


Hope this descriptions help you
__________________
<<Please post a forum on the issue instead of pm me, since I am not really active here for quite some time>>.:CPU-Z::Power Supply::Recuva::Unlocker::SensorsView::PSU Calculator::Everest:.
bhahar84 is offline  
Old 01-18-2008, 07:01 AM   #4
Registered Member
 
Join Date: Jan 2008
Posts: 4
OS: Windows Vista



Thanks!!!
Quite interesting...
Nevertheless, I have not installed iTunes in these 2 laptops... ...It was really weird, as it worked fine last week and all of the sudden it quit.... but what is funnier is that it quit in both laptops the same day...
I wonder if it has to do with the installation of a new Scanner from Epson, directly connected to a third laptop, and then linking the other 2 through the wireless network at home.... what do you think?
Rgds
Hmunozg
__________________
hmunozg is offline  
Old 01-18-2008, 07:55 PM   #5
TSF Enthusiast
 
bhahar84's Avatar
 
Join Date: Jan 2008
Location: Malaysia
Posts: 1,382
OS: Windows XP SP2, Vista Ultimate

My System


Hi hmunozg!!

It might be because of the installation of the printer, or any other software's or other hardware's

Otherwise, did you run any iTunes update on that particular day?
__________________
<<Please post a forum on the issue instead of pm me, since I am not really active here for quite some time>>.:CPU-Z::Power Supply::Recuva::Unlocker::SensorsView::PSU Calculator::Everest:.
bhahar84 is offline  
Old 01-19-2008, 03:49 PM   #6
Registered Member
 
Join Date: Jan 2008
Posts: 4
OS: Windows Vista



Thanks.
No iTunes in these 2 laptops.
Actually, I have spent several hours trying to get my Word 2003 to recognize the printer/scanner...it says "The printer has not yet responded, but Microsoft Office may be able to proceed without printer information. Do you want to continue to wait for the printer?"
And if you hit "yes", it takes a long time (a minute or more) to finally start listening to the printer, and it prints. However, with Excel is perfect, it simply goes and prints fast.
The funny thing is that the other laptop that is wirelessly conected to the network, prints perfect in Word (fast enough, no message)...
I checked the printer settings, properties, and for both machines show the same...just mine is very slow.
Ideas?
hmunozg
__________________
hmunozg is offline  
Old 01-19-2008, 04:36 PM   #7
Registered Member
 
Join Date: Jan 2008
Posts: 1
OS: Vista Home Basic



Hi there i have had same problem "Windows cannot load the device driver for this hardware.The driver may be corrupted or missing(Code 39)"
Could you please tell me how u solved this issue? thanx!
__________________
fatboy007 is offline  
Old 01-20-2008, 01:02 AM   #8
TSF Enthusiast
 
bhahar84's Avatar
 
Join Date: Jan 2008
Location: Malaysia
Posts: 1,382
OS: Windows XP SP2, Vista Ultimate

My System


Hi again hmunozg!!

And hi fatboy007!!




Quote:
Originally Posted by hmunozg
Thanks.
No iTunes in these 2 laptops.
Actually, I have spent several hours trying to get my Word 2003 to recognize the printer/scanner...it says "The printer has not yet responded, but Microsoft Office may be able to proceed without printer information. Do you want to continue to wait for the printer?"
And if you hit "yes", it takes a long time (a minute or more) to finally start listening to the printer, and it prints. However, with Excel is perfect, it simply goes and prints fast.
The funny thing is that the other laptop that is wirelessly conected to the network, prints perfect in Word (fast enough, no message)...
I checked the printer settings, properties, and for both machines show the same...just mine is very slow.
Ideas?
hmunozg
Hmm...this is quite tricky
I'll let you know about this if I came across any documentation on this issue.









Quote:
Hi there i have had same problem "Windows cannot load the device driver for this hardware.The driver may be corrupted or missing(Code 39)"
Could you please tell me how u solved this issue? thanx!
So, you may want to refer to this document, fatboy007

Upper Filter/Lower Filter Deletion
__________________
<<Please post a forum on the issue instead of pm me, since I am not really active here for quite some time>>.:CPU-Z::Power Supply::Recuva::Unlocker::SensorsView::PSU Calculator::Everest:.
bhahar84 is offline  
Old 07-28-2008, 04:37 AM   #9
Registered Member
 
Join Date: Jul 2008
Posts: 1
OS: XP



Thank you! Guys!
I've just got a similar problem and the clue from your thread solved it.
Great!
__________________
minnwint is offline  
Old 09-09-2008, 11:54 AM   #10
Registered Member
 
Join Date: Sep 2008
Posts: 1
OS: vista



Thanks alot. I had the same problem and would never have been able to fix it without your guys' help!


Thanks again.
__________________
Souke is offline  
Old 09-13-2008, 01:18 AM   #11
Registered Member
 
Join Date: Sep 2008
Posts: 2
OS: xp



I have the same problem but cannot find the upper filter and lower filter on the right hand side panel can anybody please help
__________________
Russell2305 is offline  
Old 09-18-2008, 06:26 PM   #12
Registered Member
 
Join Date: Sep 2008
Posts: 2
OS: vista



I have the same problem but cannot find the upper filter and lower filter on the right hand side panel can anybody please help
__________________
strawberrie is offline  
Old 09-18-2008, 06:26 PM   #13
Registered Member
 
Join Date: Sep 2008
Posts: 2
OS: vista



I have the same problem but cannot find the upper filter and lower filter on the right hand side panel can anybody please help
__________________
strawberrie is offline  
Old 09-19-2008, 06:33 AM   #14
Registered Member
 
Join Date: Sep 2008
Posts: 2
OS: vista



hi the MATSHITA driver got corrupted and the error is code39. If anyone can help me out with this ? Probably coz yesterday i uninstalled i tunes form my laptop.
__________________
Tayyaba is offline  
Old 10-19-2008, 07:50 PM   #15
Registered Member
 
Join Date: Oct 2008
Posts: 1
OS: windows vista



i need the driver.. how can i find this???
__________________
Patri is offline  
Old 10-21-2008, 04:23 PM   #16
TSF Enthusiast
 
bhahar84's Avatar
 
Join Date: Jan 2008
Location: Malaysia
Posts: 1,382
OS: Windows XP SP2, Vista Ultimate

My System


Hi Patri...could you create a new thread, since this thread already marked as solved

And please try to download the device driver from your manufacturer website? Do you searching for the dvd driver? Please post in more detail about your issues in the new thread so that we can guide you further
__________________
<<Please post a forum on the issue instead of pm me, since I am not really active here for quite some time>>.:CPU-Z::Power Supply::Recuva::Unlocker::SensorsView::PSU Calculator::Everest:.
bhahar84 is offline  
Old 10-22-2008, 05:47 PM   #17
Registered Member
 
Join Date: Oct 2008
Posts: 1
OS: Vista Home Premium



Hi bhahar84 - you saved my behind. That driver problem code 39 had me stumped. Your solution worked.

Thank you, Thank you, Thank you!
__________________
GETSMART is offline  
Old 11-02-2008, 03:57 PM   #18
Registered Member
 
Join Date: Nov 2008
Posts: 1
OS: Windows Vista


Grin

Thank you so much. Just last night I discovered that my DVD was not recognized by my Satellite A135-S4527. After read your post I can suspect of an iTunes update.
I followed-up your instructions and I can see it again when I get into "Computer".
Thanks so much Bhahar.



Quote:
Originally Posted by bhahar84 View Post
Hi hmunozg!!

My name is bhahar. Glad to hear that you solved your issue

By the way, the deletion of upper filter and lower filter is important because these particular registry string did cause a problem to the cd/dvd drive. There are many reason for this to happen, such as installing the iTunes. It will create a string on your registry, which is the upper filter and lower filter, that proven to cause problem to drive.


Hope this descriptions help you
__________________
roscracast is offline  
Old 08-13-2009, 08:09 PM   #19
Registered Member
 
Join Date: Aug 2009
Posts: 1
OS: Vista



Quote:
Originally Posted by bhahar84 View Post
Hi again hmunozg!!

And hi fatboy007!!






Hmm...this is quite tricky
I'll let you know about this if I came across any documentation on this issue.











So, you may want to refer to this document, fatboy007

Upper Filter/Lower Filter Deletion
__________________
rehauser is offline  
Old 01-06-2010, 10:42 AM   #20
Registered Member
 
Join Date: Jan 2010
Posts: 1
OS: xp sp3


Smile

thank you very much for this tip.
100%!!!


__________________
pedreatiger is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 08:19 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts