Go Back   Tech Support Forum > Hardware Support > Removable Media Drives

[SOLVED] Kingston DataTraveler 8GB Flash Drive Not Working

This is a discussion on [SOLVED] Kingston DataTraveler 8GB Flash Drive Not Working within the Removable Media Drives forums, part of the Tech Support Forum category. For the most recent Christmas, I received an 8GB Kingston DataTraveler Flash Drive. It seemed like a very useful gift


Closed Thread
 
Thread Tools Search this Thread
Old 02-03-2009, 02:51 PM   #1
Registered Member
 
ntarelix's Avatar
 
Join Date: Dec 2006
Location: Minnesota
Posts: 25
OS: Windows 7 Ultimate x86



For the most recent Christmas, I received an 8GB Kingston DataTraveler Flash Drive. It seemed like a very useful gift and I only had a 1GB flash drive. The first time I tried putting files onto it, it didn't quite work. It would say the files were done being copied but I would refresh the explorer window and there were about 5 1KB files for every file I copied with file names that were just random characters. It only did this for files above 1GB. I would have to format the drive and try again. It would take about 3 or 4 tries per large file to finally get it successfully.
That is not my current problem. I haven't used it for like 2 weeks. It was just sitting on my desk. Now, when I plug it in, sometimes it will randomly say my USB device was not recognized and I need to reinsert it or replace it, and the rest of the times it will detect it as a USB mass storage device but I am not able to access it from 'My Computer'. I have tried it on 3 computers, each with a different operating system and it does the same thing for each one so it is most likely not a driver problem.
OS's:
1- Windows Vista Ultimate SP1 64bit
2- Windows XP Home SP3 32bit
3- Windows XP Professional SP3 32bit

I have opened the flash drive and I see absolutely no damage. I have also tried using my old 1GB flash drive on each of these computers and it works fine.
I'm thinking it's probably just broken and it needs to be replaced.
If there are any applications or anything else I could use to possibly repair it if it is a software problem or formatting issue then please provide some information about that. If these are symptoms of a broken flash drive or you think it's most likely broken, please tell me and also give some suggestions as to what brand might be better than Kingston. Any information like that would be useful.
Any questions?

__________________
ntarelix is offline  
Old 03-24-2009, 01:43 PM   #2
Registered Member
 
Join Date: Mar 2009
Posts: 3
OS: Windows XP



It sounds like your USB flash drive is broken, you should be able to return it for a warranty swap out (you would have to find out what shop you got it from) though you might have voided the warranty by opening it, i am facing the same problem, except that after falling out my pocket whilst driving my 8gb flash drive just stopped working.. only i refuse to accept that

__________________
diabsiniman is offline  
Old 03-28-2009, 01:14 AM   #3
Registered Member
 
Join Date: Mar 2009
Posts: 1
OS: xp sp2



my pendrive is not getting detected . some times its being detected bt with a strange sign and clicking on that respond "unable usage". help?
__________________
fehzaan is offline  
Old 03-29-2009, 07:10 PM   #4
Registered Member
 
Join Date: Mar 2009
Posts: 3
OS: Windows XP



I think these 8 GB drive's are a bit very sensitive, tend to break for no reason whatsoever... oh well, you win some you lose some (guess im back to carrying copous [suppose i spelled this wrong] amounts of cds around with me [im a pc tech by trade]).
__________________
diabsiniman is offline  
Old 08-13-2009, 12:40 AM   #5
Registered Member
 
ntarelix's Avatar
 
Join Date: Dec 2006
Location: Minnesota
Posts: 25
OS: Windows 7 Ultimate x86



I just replaced it with a different 8GB on from newegg for $20. I have recycled the old one.

__________________
ntarelix is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 03:45 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts