Go Back   Tech Support Forum > Hardware Support > Removable Media Drives

[SOLVED] Code 19 Error with Slimtype DVD A DS8A4S ATA

This is a discussion on [SOLVED] Code 19 Error with Slimtype DVD A DS8A4S ATA within the Removable Media Drives forums, part of the Tech Support Forum category. My computer suddenly stopped recognising my CD drive and I get the error code; Windows cannot start this hardware device


Reply
 
Thread Tools Search this Thread
Old 12-23-2010, 12:30 PM   #1
Registered Member
 
Join Date: Dec 2010
Location: England, UK
Posts: 71
OS: Windows 7 Home Premium SP1 x64



My computer suddenly stopped recognising my CD drive and I get the error code;

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

The CD drive I am using is a Slimtype DVD A DS8A4S ATA device

I have searched all over the internet for a solution but can't find anything.

I have tried uninstalling and rebooting my computer, but it says that windows failed to install the driver.

I would be really grateful if sombody could help me out

Thanks

__________________
OneFourOne is offline   Reply With Quote
Old 12-23-2010, 01:05 PM   #2
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,727
OS: windows 7

My System

hi oneforone welcome to tsf,

try this out see how it goes
http://support.microsoft.com/kb/982116

was thinking about your problem, can you delete it then reboot it will install driver upon restart. if that doesn't work. try a system restore to a date that it was working.

__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now   Reply With Quote
Old 12-24-2010, 04:48 AM   #3
Registered Member
 
Join Date: Dec 2010
Location: England, UK
Posts: 71
OS: Windows 7 Home Premium SP1 x64



Thanks for the reply oscer1, I followed your instructions and performed a system restore to the earliest date possible, but no luck, the CD drive still doesn't work.

Any other suggestions?
__________________
OneFourOne is offline   Reply With Quote
Old 12-24-2010, 04:52 AM   #4
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,727
OS: windows 7

My System


did you try uninstalling it and reboot? did you try the link i gave you?
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now   Reply With Quote
Old 12-24-2010, 07:34 AM   #5
Registered Member
 
Join Date: Dec 2010
Location: England, UK
Posts: 71
OS: Windows 7 Home Premium SP1 x64



yes i've tried everything you said
__________________
OneFourOne is offline   Reply With Quote
Old 12-24-2010, 09:09 AM   #6
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,727
OS: windows 7

My System


ok try everything thats under code 19 here
http://support.microsoft.com/kb/310123
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now   Reply With Quote
Old 12-24-2010, 09:31 AM   #7
Registered Member
 
Join Date: Dec 2010
Location: England, UK
Posts: 71
OS: Windows 7 Home Premium SP1 x64



I've done all of that, except for editing the registry which I wouldn't be able to do as it is too advanced.

Is there any hope left?
__________________
OneFourOne is offline   Reply With Quote
Old 12-24-2010, 12:21 PM   #8
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,727
OS: windows 7

My System


are you able to boot to a bootable disk like installation disk for operating system. does the drive show up in bios? to see if it will boot from a disk you will need to change boot order in bios to cd/dvd rom drive
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now   Reply With Quote
Old 06-25-2011, 04:07 PM   #9
Registered Member
 
Join Date: Jun 2011
Posts: 2
OS: Windows 7 x64 Home Basic



Hi Oscer1. I have the same problem with my DVD drive as OneFourOne. The registry entries they said to delete in the link you gave are not there in my registry, and the DVD drive does not show up in BIOS as a boot option. The drive does show in My Computer, though it does not read any disc put into it. I've tried looking for driver software on the Lenovo website and generally via Google without success. Have you got any other ideas as to how our problem can be fixed? Thanks
__________________
Bakerbakura is offline   Reply With Quote
Old 06-26-2011, 01:28 AM   #10
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,727
OS: windows 7

My System


hi Bakerbakure welcome to TSF,

Does the drive show in device manager? if so try uninstalling it and restart computer.
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now   Reply With Quote
Old 06-27-2011, 01:08 AM   #11
Registered Member
 
Join Date: Dec 2010
Location: England, UK
Posts: 71
OS: Windows 7 Home Premium SP1 x64


Thumbs Up

Guys, i solved this.

Heres the solution:

1. Goto RegEdit.exe

2. Expand HKEY_LOCAL_MACHINE

3. Expand SYSTEM

4. Expand CurrentControlSet

5. Expand Control

6. Expand Class

7. Expand the folder starting with {4D36E965...}

8. If any of these files are shown, delete them;
UpperFilters
LowerFilters
UpperFilters.bak
LowerFilters.bak

9. Restart computer

Hope this helps guys!
__________________
OneFourOne is offline   Reply With Quote
Old 06-27-2011, 01:49 AM   #12
Moderator Hardware Team
 
oscer1's Avatar
 
Join Date: Jan 2010
Location: wisconsin
Posts: 10,727
OS: windows 7

My System


glad you got it solved
__________________

Mark thread solved under thread tools when issue has been resolved.
oscer1 is online now   Reply With Quote
Old 09-06-2011, 04:07 AM   #13
Registered Member
 
Join Date: Jun 2011
Posts: 2
OS: Windows 7 x64 Home Basic



Hey guys

I went looking in my regedit, and none of those upperfilters or lowerfilters were there, but my DVD drive still does not work. Any other ideas?

Faith, Hope and Love
Bakerbakura
__________________
Bakerbakura is offline   Reply With Quote
Old 09-06-2011, 04:20 AM   #14
Registered User
 
Join Date: Oct 2007
Location: Kansas
Posts: 1,123
OS: Windows



Use Microsoft Fix It. It will fix the filters and test the drive.
Microsoft Fix It Center - Download
__________________
hitech is offline   Reply With Quote
Old 09-04-2012, 02:01 PM   #15
Registered Member
 
Join Date: Sep 2012
Posts: 2
OS: Win7HB


Grin

THANKS VERY MUTCH! IT WOOOOOOORK!!!!!!!! I have it problem more 1 year! Now i forget it! СОВЕТ ГОДА! ОГРОМНОЕ СПАСИБО!!!!! slimtype dvd a ds8a4s СНОВА РАБОТАЕТ!!! У Р А !!!! FANTASTIC!!!!!!!!!






Quote:
Originally Posted by OneFourOne View Post
Guys, i solved this.

Heres the solution:

1. Goto RegEdit.exe

2. Expand HKEY_LOCAL_MACHINE

3. Expand SYSTEM

4. Expand CurrentControlSet

5. Expand Control

6. Expand Class

7. Expand the folder starting with {4D36E965...}

8. If any of these files are shown, delete them;
UpperFilters
LowerFilters
UpperFilters.bak
LowerFilters.bak

9. Restart computer

Hope this helps guys!
__________________
alexleon is offline   Reply With Quote
Old 11-21-2012, 10:11 AM   #16
Registered Member
 
Join Date: Nov 2012
Posts: 1
OS: Windows 7 pro



Quote:
Originally Posted by OneFourOne View Post
Guys, i solved this.

Heres the solution:

1. Goto RegEdit.exe

2. Expand HKEY_LOCAL_MACHINE

3. Expand SYSTEM

4. Expand CurrentControlSet

5. Expand Control

6. Expand Class

7. Expand the folder starting with {4D36E965...}

8. If any of these files are shown, delete them;
UpperFilters
LowerFilters
UpperFilters.bak
LowerFilters.bak

9. Restart computer

Hope this helps guys!


Great thanks it did work! However I would like to say mine was located on the root of the {4D36E965...} folder I expanded it and found nothing and was about to move on to another suggestion when I on hunch decided to click on the {4D36E965...} folder itself and there was an upper filter there. Deleted the entry, restarted, checked device manager and we are good to go. Thank you so much wish I would have found this thread first!

__________________
LDietrich is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 07:21 PM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts