Go Back   Tech Support Forum > Gaming Forum > Console Gaming Support

Turtle Beach x1 problem

This is a discussion on Turtle Beach x1 problem within the Console Gaming Support forums, part of the Tech Support Forum category. I have had my x1 fine and working for about a month. Suddenly, other people over xbox live could not


Closed Thread
 
Thread Tools Search this Thread
Old 07-25-2009, 04:58 PM   #1
Registered Member
 
Join Date: Jul 2009
Posts: 1
OS: xp



I have had my x1 fine and working for about a month. Suddenly, other people over xbox live could not hear me. I could hear them along with the game volume but i could not emit sound into my mic. I had all the setttings correct, checked if it was just the controller, but whenever i talk into the headset the indicator that I am talking never shows and nobody can hear me. If possible I would like to know the problem or problems that my turtle beach x1 headset could have and how to diagnose(fix) the problems as well.

__________________
barbedbash is offline  
Old 07-26-2009, 04:52 PM   #2
TSF Team, Emeritus
 
ebackhus's Avatar
 
Join Date: Apr 2005
Location: SATX
Posts: 17,423
OS: Windows 7 Ultimate x64 SP1

My System

Send a message via ICQ to ebackhus Send a message via AIM to ebackhus Send a message via MSN to ebackhus Send a message via Yahoo to ebackhus Send a message via Skype™ to ebackhus

Can you test using the original headset that came with the 360?

__________________

-----------------------------
There are no dumb questions, unless a customer is asking them.

Help in the fight against cancer and other serious illnesses.
ebackhus is offline  
Old 07-27-2009, 03:37 PM   #3
Registered Member
 
Join Date: Jun 2009
Posts: 274
OS: Vista sp2



First thing to check is the adapter that goes to the controller. Do you see the tip of the pin? I had a similar problem and I had to replace the part that connects to the controller which you can buy off their website for $12.00 in total...the shipping costing more then the product lol.
The way to diagnose it is simple, check the pin. Compare the pin to another headset pin that connects to the controller. If the one for the X1 is shorter, its broke and needs replacement. Try using it on a different controller. Same results? Then try this. Go into an area in a game or anywhere where you can see activity every time you speak. Such as a mic icon blinking. Unplug the adapter from the controller and plug it in, if you see for a split second the icon coming up suggesting sound then goes right off. Then there may be a short in that adapter, or your pin is busted.
__________________
icebelowzero is offline  
Old 02-16-2010, 05:02 PM   #4
Registered Member
 
Join Date: Feb 2010
Posts: 4
OS: xp



I have the same problem and bought a new headset and plugged it into the controller and you can hear great but the mike doesn't seem to work it just flickers on and off.Any ideas?
__________________
sittingduck123 is offline  
Old 02-16-2010, 05:07 PM   #5
Moderator
-Articles Team
-Games Team
 
Redeye3323's Avatar
 
Join Date: Sep 2009
Location: Norfolk, East Anglia, England, United Kingdom, Europe, Earth, Milky Way, Universe
Posts: 11,883
OS: Windows 7 Pro 64-bit SP1 :D

My System


Welcome to TSF.

Did you try what Steve posted?
__________________

Games & Articles Team

Redeye3323 is offline  
Old 02-16-2010, 05:20 PM   #6
Registered Member
 
Join Date: Feb 2010
Posts: 4
OS: xp



yes I did
__________________
sittingduck123 is offline  
Old 02-16-2010, 05:28 PM   #7
Moderator
-Articles Team
-Games Team
 
Redeye3323's Avatar
 
Join Date: Sep 2009
Location: Norfolk, East Anglia, England, United Kingdom, Europe, Earth, Milky Way, Universe
Posts: 11,883
OS: Windows 7 Pro 64-bit SP1 :D

My System


Have you tried a different controller?
__________________

Games & Articles Team

Redeye3323 is offline  
Old 02-16-2010, 05:36 PM   #8
Registered Member
 
Join Date: Feb 2010
Posts: 4
OS: xp



yes I tried the other controller I have and the same thing happens so I've bought a new headset the same kind and plugged it in to both controllers and that doesn't work either so is there something on the console that could have gone wrong that I should be checking?Thanks for your help I appreciate it.
__________________
sittingduck123 is offline  
Old 02-16-2010, 05:57 PM   #9
Moderator
-Articles Team
-Games Team
 
Redeye3323's Avatar
 
Join Date: Sep 2009
Location: Norfolk, East Anglia, England, United Kingdom, Europe, Earth, Milky Way, Universe
Posts: 11,883
OS: Windows 7 Pro 64-bit SP1 :D

My System


Have a look through all the settings (both in-game and the system ones)
__________________

Games & Articles Team

Redeye3323 is offline  
Old 02-16-2010, 06:21 PM   #10
Registered Member
 
Join Date: Feb 2010
Posts: 4
OS: xp



I just went up and checked the settings and everything is as it should be.I put the headset on and spoke into it and had the mic icon come up for a few seconds then disappear again.It really doesn't seem to make any sense,it's soooo frustrating.
__________________
sittingduck123 is offline  
Old 02-17-2010, 09:28 AM   #11
Moderator
-Articles Team
-Games Team
 
Redeye3323's Avatar
 
Join Date: Sep 2009
Location: Norfolk, East Anglia, England, United Kingdom, Europe, Earth, Milky Way, Universe
Posts: 11,883
OS: Windows 7 Pro 64-bit SP1 :D

My System


It may be a short like Steve said or it could be a damaged mic.

Is it possible to try the headsets on another console to rule that out/show thats the problem
__________________

Games & Articles Team

Redeye3323 is offline  
Old 02-22-2010, 06:50 AM   #12
Registered Member
 
Join Date: Feb 2010
Posts: 3
OS: Win XP



Here are the troubleshooting steps you need to take:

1) Connect the headset to your PC. This eliminates the controller cable from the equation. Use windows recorder. Does the mic work? If it works on the PC (but not the xbox) you just need to replace the controller cable.

2) If the mic does not work on the PC, you need to contact the company for repair/replacement. Support@turtlebeach.com

__________________
sithwarrior86 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is on
Smilies are on
[IMG] code is on
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Post a Question


» Site Navigation
 > FAQ
  > 10.0.0.2


All times are GMT -7. The time now is 04:23 AM.


Copyright 2001 - 2014, Tech Support Forum

Windows 7 - Windows XP - Windows Vista - Trojan Removal - Spyware Removal - Virus Removal - Networking - Security - Top Web Hosts